summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-16 17:42:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-16 17:42:14 +0000
commit10226fee963cb976204a9e4dce0d66512ba9d1fa (patch)
tree577ad486ebd74aeb4e952071a9855ab40648b553 /sys-apps/kbd/files
parentstable bump (diff)
downloadhistorical-10226fee963cb976204a9e4dce0d66512ba9d1fa.tar.gz
historical-10226fee963cb976204a9e4dce0d66512ba9d1fa.tar.bz2
historical-10226fee963cb976204a9e4dce0d66512ba9d1fa.zip
old
Diffstat (limited to 'sys-apps/kbd/files')
-rw-r--r--sys-apps/kbd/files/digest-kbd-1.08-r51
-rw-r--r--sys-apps/kbd/files/kbd-1.06-othervt.patch55
-rw-r--r--sys-apps/kbd/files/kbd-1.08-find-map-fix.patch35
-rw-r--r--sys-apps/kbd/files/kbd-1.08-kbd_repeat.patch157
-rw-r--r--sys-apps/kbd/files/kbd-1.08-nowarn.patch11
-rw-r--r--sys-apps/kbd/files/kbd-1.08-po-install-locations.patch16
-rw-r--r--sys-apps/kbd/files/kbd-1.12-kbd_repeat.patch34
7 files changed, 0 insertions, 309 deletions
diff --git a/sys-apps/kbd/files/digest-kbd-1.08-r5 b/sys-apps/kbd/files/digest-kbd-1.08-r5
deleted file mode 100644
index 9b77d0dd0db3..000000000000
--- a/sys-apps/kbd/files/digest-kbd-1.08-r5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 924e6a05e52715dc0f96385b35f2f680 kbd-1.08.tar.gz 819924
diff --git a/sys-apps/kbd/files/kbd-1.06-othervt.patch b/sys-apps/kbd/files/kbd-1.06-othervt.patch
deleted file mode 100644
index 5a4d69eaa7d0..000000000000
--- a/sys-apps/kbd/files/kbd-1.06-othervt.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- kbd-1.06/src/setfont.c.p4 Mon Feb 12 11:17:59 2001
-+++ kbd-1.06/src/setfont.c Wed Jul 18 18:06:38 2001
-@@ -84,6 +84,7 @@
- " setfont -{8|14|16} codepage.cp[.gz] Load 8x<N> font from codepage.cp\n"
- "Explicitly (with -m or -u) or implicitly (in the fontfile) given mappings\n"
- "will be loaded and, in the case of consolemaps, activated.\n"
-+" --tty=device Use `device' as console device for ioctls.\n"
- " -h<N> (no space) Override font height.\n"
- " -m <fn> Load console screen map.\n"
- " -u <fn> Load font unicode map.\n"
-@@ -101,7 +101,7 @@
- int
- main(int argc, char *argv[]) {
- char *ifiles[MAXIFILES];
-- char *mfil, *ufil, *Ofil, *ofil, *omfil, *oufil;
-+ char *mfil, *ufil, *Ofil, *ofil, *omfil, *oufil, *tty;
- int ifilct = 0, fd, i, iunit, hwunit, no_m, no_u;
- int restore = 0;
-
-@@ -111,9 +111,7 @@
- bindtextdomain(PACKAGE, LOCALEDIR);
- textdomain(PACKAGE);
-
-- fd = getfd();
--
-- ifiles[0] = mfil = ufil = Ofil = ofil = omfil = oufil = 0;
-+ ifiles[0] = mfil = ufil = Ofil = ofil = omfil = oufil = tty = NULL;
- iunit = hwunit = 0;
- no_m = no_u = 0;
-
-@@ -160,6 +158,8 @@
- hwunit = atoi(argv[i]+2);
- if (hwunit <= 0 || hwunit > 32)
- usage();
-+ } else if (!strncmp(argv[i], "--tty", 5)) {
-+ tty = argv[i] + 6;
- } else if (argv[i][0] == '-') {
- iunit = atoi(argv[i]+1);
- if(iunit <= 0 || iunit > 32)
-@@ -171,6 +171,15 @@
- }
- ifiles[ifilct++] = argv[i];
- }
-+ }
-+
-+ if (tty) {
-+ if ((fd = open(tty, O_RDWR)) == -1) {
-+ perror("open");
-+ exit(EX_OSERR);
-+ }
-+ } else {
-+ fd = getfd();
- }
-
- if (ifilct && restore) {
diff --git a/sys-apps/kbd/files/kbd-1.08-find-map-fix.patch b/sys-apps/kbd/files/kbd-1.08-find-map-fix.patch
deleted file mode 100644
index bdb06d31246b..000000000000
--- a/sys-apps/kbd/files/kbd-1.08-find-map-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- kbd-1.08/src/findfile.c.orig 2004-01-29 01:47:40.735190832 +0200
-+++ kbd-1.08/src/findfile.c 2004-01-29 02:06:51.703217096 +0200
-@@ -167,6 +167,7 @@
- FILE *fp;
- int dl, recdepth;
- struct decompressor *dc;
-+ struct stat tstat;
-
- if (strlen(fnam) >= sizeof(pathname))
- return NULL;
-@@ -211,6 +212,7 @@
-
- /* delete trailing slashes; trailing stars denote recursion */
- dir = xstrdup(*dp);
-+loop:
- dl = strlen(dir);
- recdepth = 0;
- while (dl && dir[dl-1] == '*') {
-@@ -224,8 +226,15 @@
- }
-
- fp = findfile_in_dir(fnam, dir, recdepth, suffixes);
-- if (fp)
-+ if (fp) {
-+ if ((lstat(pathname, &tstat) == 0)
-+ && (S_ISDIR(tstat.st_mode) != 0)) {
-+ dir = xstrdup(pathname);
-+ goto loop;
-+ }
-+
- return fp;
-+ }
- }
-
- return NULL;
diff --git a/sys-apps/kbd/files/kbd-1.08-kbd_repeat.patch b/sys-apps/kbd/files/kbd-1.08-kbd_repeat.patch
deleted file mode 100644
index 7dd9524bcee5..000000000000
--- a/sys-apps/kbd/files/kbd-1.08-kbd_repeat.patch
+++ /dev/null
@@ -1,157 +0,0 @@
-diff -urN kbd-1.08.orig/configure kbd-1.08/configure
---- kbd-1.08.orig/configure 2003-08-01 20:31:50.298316445 -0700
-+++ kbd-1.08/configure 2003-08-01 21:00:17.812534740 -0700
-@@ -193,3 +193,33 @@
- else
- echo "HAVE_XGETTEXT=no" >> make_include
- fi
-+
-+#
-+# 4. Do we have <linux/kd.h>, and if so what is the name of the second
-+# member of struct kbd_repeat?
-+#
-+echo "
-+#include <linux/kd.h>
-+main(){ struct kbd_repeat x; x.rate = 0; exit(0); }
-+" > conftest.c
-+eval $compile
-+if test -s conftest && ./conftest 2>/dev/null; then
-+ echo "You have <linux/kd.h> (rate)"
-+ echo "#define HAVE_kd_h" >> defines.h
-+ echo "#define kd_PERIOD rate" >> defines.h
-+else
-+ echo "
-+#include <linux/kd.h>
-+main(){ struct kbd_repeat x; x.period = 0; exit(0); }
-+" > conftest.c
-+ eval $compile
-+ if test -s conftest && ./conftest 2>/dev/null; then
-+ echo "You have <linux/kd.h> (period)"
-+ echo "#define HAVE_kd_h" >> defines.h
-+ echo "#define kd_PERIOD period" >> defines.h
-+ else
-+ echo "You don't have <linux/kd.h>"
-+ fi
-+fi
-+rm -f conftest conftest.c
-+
-diff -urN kbd-1.08.orig/src/kbdrate.c kbd-1.08/src/kbdrate.c
---- kbd-1.08.orig/src/kbdrate.c 2003-08-01 20:31:50.443296940 -0700
-+++ kbd-1.08/src/kbdrate.c 2003-08-01 21:02:36.135807454 -0700
-@@ -75,21 +75,15 @@
- #include <sys/file.h>
- #include <sys/ioctl.h>
-
-+#include "../defines.h"
-+#ifdef HAVE_kd_h
-+#include <linux/kd.h>
-+#endif
- #ifdef __sparc__
- #include <asm/param.h>
- #include <asm/kbio.h>
- #endif
-
--#ifndef KDKBDREP
--/* usually defined in <linux/kd.h> */
--#define KDKBDREP 0x4B52 /* set keyboard delay/repeat rate;
-- * actually used values are returned */
--struct kbd_repeat {
-- int delay; /* in msec; <= 0: don't change */
-- int period; /* in msec; <= 0: don't change */
--};
--#endif
--
- #include "nls.h"
- #include "version.h"
-
-@@ -104,12 +98,13 @@
-
- static int
- KDKBDREP_ioctl_ok(double rate, int delay, int silent) {
-+#ifdef KDKBDREP
- /* This ioctl is defined in <linux/kd.h> but is not
- implemented anywhere - must be in some m68k patches. */
- struct kbd_repeat kbdrep_s;
-
- /* don't change, just test */
-- kbdrep_s.period = -1;
-+ kbdrep_s.kd_PERIOD = -1;
- kbdrep_s.delay = -1;
- if (ioctl( 0, KDKBDREP, &kbdrep_s )) {
- if (errno == EINVAL)
-@@ -118,38 +113,37 @@
- exit( 1 );
- }
-
--#if 0
-- printf("old delay %d, period %d\n",
-- kbdrep_s.delay, kbdrep_s.period);
--#endif
--
- /* do the change */
-- if (rate == 0) /* switch repeat off */
-- kbdrep_s.period = 0;
-+ if (rate == 0) /* switch repeat off */
-+ kbdrep_s.kd_PERIOD = 0;
- else
-- kbdrep_s.period = 1000.0 / rate; /* convert cps to msec */
-- if (kbdrep_s.period < 1)
-- kbdrep_s.period = 1;
-+ kbdrep_s.kd_PERIOD = 1000.0 / rate; /* convert cps to msec */
-+ if (kbdrep_s.kd_PERIOD < 1)
-+ kbdrep_s.kd_PERIOD = 1;
- kbdrep_s.delay = delay;
- if (kbdrep_s.delay < 1)
- kbdrep_s.delay = 1;
-
-- if (ioctl(0, KDKBDREP, &kbdrep_s)) {
-- perror("ioctl(KDKBDREP)");
-- exit(1);
-+ if (ioctl( 0, KDKBDREP, &kbdrep_s )) {
-+ perror( "ioctl(KDKBDREP)" );
-+ exit( 1 );
- }
-
- /* report */
-- if (kbdrep_s.period == 0)
-+ if (kbdrep_s.kd_PERIOD == 0)
- rate = 0;
- else
-- rate = 1000.0 / (double) kbdrep_s.period;
-+ rate = 1000.0 / (double) kbdrep_s.kd_PERIOD;
-
- if (!silent)
- printf( _("Typematic Rate set to %.1f cps (delay = %d ms)\n"),
- rate, kbdrep_s.delay );
-
- return 1; /* success! */
-+
-+#else /* no KDKBDREP */
-+ return 0;
-+#endif /* KDKBDREP */
- }
-
- static int
-@@ -164,10 +158,10 @@
- exit( 1 );
- }
-
-- kbdrate_s.period = (int) (rate + 0.5); /* round up */
-+ kbdrate_s.rate = (int) (rate + 0.5); /* round up */
- kbdrate_s.delay = delay * HZ / 1000; /* convert ms to Hz */
-- if (kbdrate_s.period > 50)
-- kbdrate_s.period = 50;
-+ if (kbdrate_s.rate > 50)
-+ kbdrate_s.rate = 50;
-
- if (ioctl( fd, KIOCSRATE, &kbdrate_s )) {
- perror( "ioctl(KIOCSRATE)" );
-@@ -177,7 +171,7 @@
-
- if (!silent)
- printf( "Typematic Rate set to %d cps (delay = %d ms)\n",
-- kbdrate_s.period, kbdrate_s.delay * 1000 / HZ );
-+ kbdrate_s.rate, kbdrate_s.delay * 1000 / HZ );
-
- return 1;
- #else /* no KIOCSRATE */
diff --git a/sys-apps/kbd/files/kbd-1.08-nowarn.patch b/sys-apps/kbd/files/kbd-1.08-nowarn.patch
deleted file mode 100644
index 7b0f87960292..000000000000
--- a/sys-apps/kbd/files/kbd-1.08-nowarn.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- kbd-1.08/src/ksyms.c.orig 2003-07-31 15:08:42.000000000 -0400
-+++ kbd-1.08/src/ksyms.c 2003-07-31 15:10:32.000000000 -0400
-@@ -1811,6 +1811,8 @@
- sprintf(buf, "0x%04x", code);
- p = buf;
- }
-+#if 0 /* keep from whining about capslock in unicode mode */
- fprintf(stderr, _("plus before %s ignored\n"), p);
-+#endif
- return code;
- }
diff --git a/sys-apps/kbd/files/kbd-1.08-po-install-locations.patch b/sys-apps/kbd/files/kbd-1.08-po-install-locations.patch
deleted file mode 100644
index 6b7034caddab..000000000000
--- a/sys-apps/kbd/files/kbd-1.08-po-install-locations.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- kbd-1.08/po/Makefile.orig 2003-09-24 01:29:39.746716112 +0200
-+++ kbd-1.08/po/Makefile 2003-09-24 01:30:12.907674880 +0200
-@@ -15,10 +15,10 @@
- SHELL = /bin/sh
-
- prefix = ${DESTDIR}
--datadir = $(prefix)/share
-+datadir = $(DATADIR)
- localedir = $(datadir)/locale
--gnulocaledir = $(prefix)/share/locale
--gettextsrcdir = $(prefix)/share/gettext/po
-+gnulocaledir = $(datadir)/locale
-+gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = /usr/bin/install -c
- INSTALL_DATA = ${INSTALL} -m 644
diff --git a/sys-apps/kbd/files/kbd-1.12-kbd_repeat.patch b/sys-apps/kbd/files/kbd-1.12-kbd_repeat.patch
deleted file mode 100644
index abef25c84f00..000000000000
--- a/sys-apps/kbd/files/kbd-1.12-kbd_repeat.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- kbd-1.12/src/kbdrate.c Fri Jan 16 20:45:31 2004
-+++ kbd-1.12.kbdrate/src/kbdrate.c Sun Feb 8 14:52:04 2004
-@@ -84,11 +84,13 @@
- /* usually defined in <linux/kd.h> */
- #define KDKBDREP 0x4B52 /* set keyboard delay/repeat rate;
- * actually used values are returned */
--struct kbd_repeat {
-+#endif
-+
-+/* Equal to kernel version, but field names vary. */
-+struct my_kbd_repeat {
- int delay; /* in msec; <= 0: don't change */
- int period; /* in msec; <= 0: don't change */
- };
--#endif
-
- #include "nls.h"
- #include "version.h"
-@@ -104,9 +106,12 @@
-
- static int
- KDKBDREP_ioctl_ok(double rate, int delay, int silent) {
-- /* This ioctl is defined in <linux/kd.h> but is not
-- implemented anywhere - must be in some m68k patches. */
-- struct kbd_repeat kbdrep_s;
-+ /*
-+ * This ioctl is defined in <linux/kd.h> but is not
-+ * implemented anywhere - must be in some m68k patches.
-+ * Since 2.4.9 also on i386.
-+ */
-+ struct my_kbd_repeat kbdrep_s;
-
- /* don't change, just test */
- kbdrep_s.period = -1;