summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-05-27 22:29:16 +0000
committerZack Welch <zwelch@gentoo.org>2003-05-27 22:29:16 +0000
commite0622edb620ef8b222a4a55a8dc3d692925499ca (patch)
treee0a4d08e30e3e267bd566783b097105110466442 /sys-apps/hotplug
parentbump revision and add patch to fix bug 20846 (diff)
downloadhistorical-e0622edb620ef8b222a4a55a8dc3d692925499ca.tar.gz
historical-e0622edb620ef8b222a4a55a8dc3d692925499ca.tar.bz2
historical-e0622edb620ef8b222a4a55a8dc3d692925499ca.zip
bump revision and add patch to fix bug 20846
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/Manifest4
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-20030501-r12
-rw-r--r--sys-apps/hotplug/hotplug-20030501-r1.ebuild57
3 files changed, 61 insertions, 2 deletions
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index 9cddd13df8d9..beff2a25a40e 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -1,11 +1,11 @@
-MD5 c119a4930029323372aa5784d21cd225 ChangeLog 2746
+MD5 82ed1ea9e612ce7db6042ee505bafdce ChangeLog 2902
MD5 4add5675ce1bf7372ff9189f27c2317a hotplug-20020114.ebuild 1492
MD5 ff4869e458ad17b4691293ed22b2fcc7 hotplug-20020401-r1.ebuild 1467
MD5 09df0a0f546f1510c00b7d18f2bed59e hotplug-20020826-r1.ebuild 1534
MD5 02124e816a7016f6bf2e311b2fa77155 hotplug-20020826.ebuild 1451
MD5 7d09501e89c7ce3d827df2c465697e3b hotplug-20020826-r2.ebuild 1544
MD5 cede312e2783d607cb0dd3c594cd20e3 hotplug-20030501.ebuild 1488
-MD5 cede312e2783d607cb0dd3c594cd20e3 hotplug-20030501-r1.ebuild 1488
+MD5 e4538149ec1931411f80d1ff8b7a7935 hotplug-20030501-r1.ebuild 1491
MD5 4983c0405e4fc821845e2c9343a231db files/digest-hotplug-20020114 139
MD5 208b61d039c5210217e7e9c850cb33aa files/digest-hotplug-20020401-r1 221
MD5 64aa2a1e7fb2526bb52c6fd4b5f24608 files/digest-hotplug-20020826 221
diff --git a/sys-apps/hotplug/files/digest-hotplug-20030501-r1 b/sys-apps/hotplug/files/digest-hotplug-20030501-r1
new file mode 100644
index 000000000000..65275d83c5b2
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20030501-r1
@@ -0,0 +1,2 @@
+MD5 bd3bd7de70dd06b37daf86feb5970c77 hotplug-2003_05_01.tar.gz 41930
+MD5 89835f43f1568b40db98759b0ad7380a hotplug-20030501-r1-gentoo-patches.tar.bz2 3308
diff --git a/sys-apps/hotplug/hotplug-20030501-r1.ebuild b/sys-apps/hotplug/hotplug-20030501-r1.ebuild
new file mode 100644
index 000000000000..2077f504ffe4
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20030501-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20030501-r1.ebuild,v 1.1 2003/05/27 22:29:13 zwelch Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-${PVR}-gentoo-patches.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~hppa"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/etc/hotplug
+ epatch ${WORKDIR}/hotplug-patches/
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}
+