summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-17 03:28:43 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-17 03:28:43 +0000
commit7356079468b3ea85aa9353c85116567053ad3720 (patch)
tree348dbef6b306cfde264527581f3a9f0de850064b /sys-apps/help2man
parentVersion bump. (diff)
downloadhistorical-7356079468b3ea85aa9353c85116567053ad3720.tar.gz
historical-7356079468b3ea85aa9353c85116567053ad3720.tar.bz2
historical-7356079468b3ea85aa9353c85116567053ad3720.zip
Version bump.
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/ChangeLog7
-rw-r--r--sys-apps/help2man/help2man-1.40.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/help2man/ChangeLog b/sys-apps/help2man/ChangeLog
index 495e233acf3a..5a0a258a733d 100644
--- a/sys-apps/help2man/ChangeLog
+++ b/sys-apps/help2man/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/help2man
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.60 2011/05/02 09:17:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.61 2011/06/17 03:24:05 jer Exp $
+
+*help2man-1.40.3 (17 Jun 2011)
+
+ 17 Jun 2011; Jeroen Roovers <jer@gentoo.org> +help2man-1.40.3.ebuild:
+ Version bump.
02 May 2011; Fabian Groffen <grobian@gentoo.org> help2man-1.39.1.ebuild:
Marked ~x64-freebsd
diff --git a/sys-apps/help2man/help2man-1.40.3.ebuild b/sys-apps/help2man/help2man-1.40.3.ebuild
new file mode 100644
index 000000000000..e6817ef9ff0b
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.40.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.40.3.ebuild,v 1.1 2011/06/17 03:24:05 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="http://www.gnu.org/software/help2man"
+SRC_URI="mirror://gnu/help2man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls elibc_glibc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( nls? (
+ dev-perl/Locale-gettext
+ >=sys-devel/gettext-0.12.1-r1
+ ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.36.4-respect-LDFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-1.38.4-linguas.patch
+}
+
+src_configure() {
+ local myconf
+ use elibc_glibc \
+ && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS
+}