summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-19 16:08:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-19 16:08:57 +0000
commitd9ebfc184fedfd8f7d79714b9b6bc80efa436555 (patch)
treec0835ef401858e161dad0a6fd2b7a41ecf23b821 /sys-apps/file
parentupgrading because upstream claims this version is SMP, previous version was (diff)
downloadhistorical-d9ebfc184fedfd8f7d79714b9b6bc80efa436555.tar.gz
historical-d9ebfc184fedfd8f7d79714b9b6bc80efa436555.tar.bz2
historical-d9ebfc184fedfd8f7d79714b9b6bc80efa436555.zip
remove python from DEPEND since distutils eclass adds it for us
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest10
-rw-r--r--sys-apps/file/file-4.13.ebuild7
-rw-r--r--sys-apps/file/file-4.15.ebuild5
3 files changed, 11 insertions, 11 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index d2b549eecf95..b2ce209b9008 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -3,8 +3,8 @@ Hash: SHA1
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 c6073a11ea3fcb5cc0d1625a54aad8d4 file-4.12.ebuild 2081
-MD5 5c11ddad240c78d7d4afb5577a4b5550 file-4.15.ebuild 1359
-MD5 38fb58232bdc578cad8b10acd16069b7 file-4.13.ebuild 2296
+MD5 30111fda39ec8ab7ddb1223189a32380 file-4.15.ebuild 1344
+MD5 213bc8ded7a22b2fcb129f4ee60e892c file-4.13.ebuild 2226
MD5 d565d5003ccb755877835667dbf91f7b ChangeLog 10919
MD5 f856a50dada76a4ca5cee58fbd04e76b files/file-4.13-cross-compile.patch 964
MD5 a952f0eca26a046e4b815529d2b734ef files/misc.magic 71
@@ -18,7 +18,7 @@ MD5 66df8eecd30769daeb3f643dc6432db3 files/file-4.xx-mips-gentoo.patch 5578
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDBQtlgIKl8Uu19MoRAkqXAJ9O/OxnzE5DxQ22HCQGFXT5VKk/dQCfdomZ
-3pJxO6w07Pg/1baUciBrtfE=
-=ZokM
+iD8DBQFDBgRCgIKl8Uu19MoRAt6tAJ40ODRaxOiv11blu67lT8xdtIIyzgCff9xH
+YadwqaXXMkzcnnQVTrskGuA=
+=tc6h
-----END PGP SIGNATURE-----
diff --git a/sys-apps/file/file-4.13.ebuild b/sys-apps/file/file-4.13.ebuild
index 37f06802683f..176063e142ab 100644
--- a/sys-apps/file/file-4.13.ebuild
+++ b/sys-apps/file/file-4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.10 2005/08/09 16:00:42 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.11 2005/08/19 16:08:57 vapier Exp $
inherit flag-o-matic eutils distutils libtool toolchain-funcs
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="python build"
-DEPEND="!build? ( python? ( virtual/python ) )"
+DEPEND=""
src_unpack() {
unpack ${A}
@@ -53,6 +53,7 @@ src_compile() {
emake || die "emake failed"
emake -C magic || die "emake magic failed"
+ use build && return 0
use python && cd python && distutils_src_compile
}
@@ -63,8 +64,6 @@ src_install() {
if ! use build ; then
dodoc ChangeLog MAINT README
use python && cd python && distutils_src_install
- else
- rm -r "${D}"/usr/share/man "${D}"/usr/lib/*.a
fi
}
diff --git a/sys-apps/file/file-4.15.ebuild b/sys-apps/file/file-4.15.ebuild
index af354180b64a..dfb663b811bb 100644
--- a/sys-apps/file/file-4.15.ebuild
+++ b/sys-apps/file/file-4.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.15.ebuild,v 1.1 2005/08/18 22:27:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.15.ebuild,v 1.2 2005/08/19 16:08:57 vapier Exp $
inherit distutils libtool
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="python build"
-DEPEND="!build? ( python? ( virtual/python ) )"
+DEPEND=""
src_unpack() {
unpack ${P}.tar.gz
@@ -33,6 +33,7 @@ src_compile() {
econf --datadir=/usr/share/misc || die
emake || die "emake failed"
+ use build && return 0
use python && cd python && distutils_src_compile
}