summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-08 20:09:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-08 20:09:47 +0000
commit4017130a0981e4bad00867ca2ac4b898c5767f92 (patch)
tree59a0fbf8330ffcb6eb7a23e992f9535e93b1f1a2 /sys-apps/discover
parentbug #26728, security bump, held up for a long time by DB4.1 (diff)
downloadhistorical-4017130a0981e4bad00867ca2ac4b898c5767f92.tar.gz
historical-4017130a0981e4bad00867ca2ac4b898c5767f92.tar.bz2
historical-4017130a0981e4bad00867ca2ac4b898c5767f92.zip
ver bump #40345
Diffstat (limited to 'sys-apps/discover')
-rw-r--r--sys-apps/discover/ChangeLog7
-rw-r--r--sys-apps/discover/discover-2.0.2.ebuild (renamed from sys-apps/discover/discover-2.0.1.ebuild)28
-rw-r--r--sys-apps/discover/files/digest-discover-2.0.11
-rw-r--r--sys-apps/discover/files/digest-discover-2.0.21
-rw-r--r--sys-apps/discover/files/discover-2.0.1-gcc-3.3.patch75
5 files changed, 19 insertions, 93 deletions
diff --git a/sys-apps/discover/ChangeLog b/sys-apps/discover/ChangeLog
index c9b94b9891c4..e795fd3542df 100644
--- a/sys-apps/discover/ChangeLog
+++ b/sys-apps/discover/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/discover
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/discover/ChangeLog,v 1.6 2003/02/12 15:23:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/discover/ChangeLog,v 1.7 2004/02/08 20:09:47 vapier Exp $
+
+*discover-2.0.2 (08 Feb 2004)
+
+ 08 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #40345 by Diego Garcia.
*discover-1.5 (June 2002)
diff --git a/sys-apps/discover/discover-2.0.1.ebuild b/sys-apps/discover/discover-2.0.2.ebuild
index 2ee32c86c8d2..0cb8253102a5 100644
--- a/sys-apps/discover/discover-2.0.1.ebuild
+++ b/sys-apps/discover/discover-2.0.2.ebuild
@@ -1,41 +1,37 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/discover/discover-2.0.1.ebuild,v 1.1 2003/09/18 17:24:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/discover/discover-2.0.2.ebuild,v 1.1 2004/02/08 20:09:47 vapier Exp $
-IUSE="pcmcia"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Library and front-end for retrieving information about a system's hardware."
-HOMEPAGE="http://hackers.progeny.com/${PN}/"
-SRC_URI="http://archive.progeny.com/progeny/${PN}/${P}.tar.bz2"
+DESCRIPTION="Library and front-end for retrieving information about a system's hardware"
+HOMEPAGE="http://hackers.progeny.com/discover/"
+SRC_URI="http://archive.progeny.com/progeny/discover/${P}.tar.gz"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="pcmcia"
-DEPEND="virtual/linux-sources
+DEPEND="pcmcia? ( virtual/linux-sources )
net-ftp/curl
dev-libs/expat"
-
PDEPEND="sys-apps/discover-data"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-gcc-3.3.patch
+ cd ${S}
+ which docbook-to-man 2>/dev/null \
+ || sed -i 's:docbook-to-man:docbook2man:' doctools/docbook.mk
}
src_compile() {
local myconf=""
-
use pcmcia \
- && myconf="${myconf} --with-pcmcia-headers=/usr/src/linux/include"
-
+ && myconf="--with-pcmcia-headers=/usr/src/linux/include"
econf ${myconf} || die
emake || die
}
src_install() {
einstall || die
-
- dodoc AUTHORS INSTALL LICENSE README RELEASE
+ dodoc AUTHORS README RELEASE
}
diff --git a/sys-apps/discover/files/digest-discover-2.0.1 b/sys-apps/discover/files/digest-discover-2.0.1
deleted file mode 100644
index 01a62e719076..000000000000
--- a/sys-apps/discover/files/digest-discover-2.0.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0b01a00b0ff6534e99b15b0e61501281 discover-2.0.1.tar.bz2 388714
diff --git a/sys-apps/discover/files/digest-discover-2.0.2 b/sys-apps/discover/files/digest-discover-2.0.2
new file mode 100644
index 000000000000..c3f6d220af5f
--- /dev/null
+++ b/sys-apps/discover/files/digest-discover-2.0.2
@@ -0,0 +1 @@
+MD5 22cee445f5f2912c9cdb19422af5db1a discover-2.0.2.tar.gz 755613
diff --git a/sys-apps/discover/files/discover-2.0.1-gcc-3.3.patch b/sys-apps/discover/files/discover-2.0.1-gcc-3.3.patch
deleted file mode 100644
index 014808554d8d..000000000000
--- a/sys-apps/discover/files/discover-2.0.1-gcc-3.3.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff -urN discover-2.0.1/discover/discover.c discover-2.0.1-new/discover/discover.c
---- discover-2.0.1/discover/discover.c 2002-10-11 11:07:26.000000000 -0700
-+++ discover-2.0.1-new/discover/discover.c 2003-09-16 03:43:08.000000000 -0700
-@@ -247,38 +247,14 @@
- static void
- print_usage(void)
- {
-- puts("\
--usage: discover [--bus-summary] [OPTIONS] [BUS [...]]
-- discover --type-summary [OPTIONS] [TYPE [...]]
-- discover --data-path=PATH [--data-version=VERSION] TYPE [...]
-- discover --version
-- discover --help");
-+ puts("\nusage: discover [--bus-summary] [OPTIONS] [BUS [...]] \ndiscover --type-summary [OPTIONS] [TYPE [...]] \ndiscover --data-path=PATH [--data-version=VERSION] TYPE [...] \ndiscover --version \ndiscover --help");
- }
-
- static void
- print_help(void)
- {
- print_usage();
-- puts("
-- -b, --bus-summary Summarize by bus.
-- -t, --type-summary Summarize by device type.
-- --data-path PATH Print the data matching PATH.
--
--OPTIONS
-- -d, --disable-bus BUS Disable the bus BUS.
-- -e, --enable-bus BUS Enable the bus BUS.
-- --data-version VERSION Print only data matching VERSION.
-- --insert-url URL Insert URL in front of the list of data sources.
-- --append-url URL Append URL at the end of the list of data sources.
-- --[no-]vendor Do [not] print the vendor name.
-- --[no-]vendor-id Do [not] print the bus-specific vendor ID.
-- --[no-]model Do [not] print the model name.
-- --[no-]model-id Do [not] print the bus-specific model ID.
-- --normalize-whitespace Condense all white space into individual spaces
-- and eliminate leading and trailing white space.
-- --format TEMPLATE Format the query data output.
-- -v, --verbose Print verbose output.
--");
-+ puts("\n-b, --bus-summary Summarize by bus.\n-t, --type-summary Summarize by device type.\n--data-path PATH Print the data matching PATH.\n\nOPTIONS\n-d, --disable-bus BUS Disable the bus BUS.\n-e, --enable-bus BUS Enable the bus BUS.\n--data-version VERSION Print only data matching VERSION.\n--insert-url URL Insert URL in front of the list of datasources.\n--append-url URL Append URL at the end of the list of datasources.\n--[no-]vendor Do [not] print the vendor name.\n--[no-]vendor-id Do [not] print the bus-specific vendor ID.\n--[no-]model Do [not] print the model name.\n--[no-]model-id Do [not] print the bus-specific model ID.\n--normalize-whitespace Condense all white space into individual spaces\nand eliminate leading and trailing white\nspace.\n--format TEMPLATE Format the query data output.\n-v, --verbose Print verbose output.\n");
- printf("Report bugs to <%s>.\n", PACKAGE_BUGREPORT);
- }
-
-diff -urN discover-2.0.1/discover-xml/discover-xml.c discover-2.0.1-new/discover-xml/discover-xml.c
---- discover-2.0.1/discover-xml/discover-xml.c 2002-10-16 14:35:15.000000000 -0700
-+++ discover-2.0.1-new/discover-xml/discover-xml.c 2003-09-16 03:44:10.000000000 -0700
-@@ -77,25 +77,14 @@
- static void
- print_usage()
- {
-- puts("
--usage: discover-xml [OPTIONS]
-- discover-xml --type-summary [OPTIONS]
-- discover-xml --version
-- discover-xml --help");
-+ puts("\nusage: discover-xml [OPTIONS]\ndiscover-xml --type-summary [OPTIONS]\ndiscover-xml --version\ndiscover-xml --help");
- }
-
- static void
- print_help()
- {
- print_usage();
-- puts("
-- -t, --type-summary Summarize by device type.
--
--OPTIONS
-- -d, --disable-bus BUS Disable the bus BUS.
-- -e, --enable-bus BUS Enable the bus BUS.
-- -v, --verbose Print verbose output.
--");
-+ puts("\n-t, --type-summary Summarize by device type.\n\nOPTIONS\n-d, --disable-bus BUS Disable the bus BUS.\n-e, --enable-bus BUS Enable the bus BUS.\n-v, --verbose Print verbose output.\n");
- printf("Report bugs to <%s>.\n", PACKAGE_BUGREPORT);
- }
-