summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Lameter <christoph@gentoo.org>2002-07-31 15:41:42 +0000
committerChristoph Lameter <christoph@gentoo.org>2002-07-31 15:41:42 +0000
commit0713ccac9c1fd3c6ca3bf51f44c0ef4d77184c85 (patch)
treeb0812a40037a8566ad9163109c3c60f809df1adc /sys-apps/discover
parentdowngraded binutils to a sane version (diff)
downloadhistorical-0713ccac9c1fd3c6ca3bf51f44c0ef4d77184c85.tar.gz
historical-0713ccac9c1fd3c6ca3bf51f44c0ef4d77184c85.tar.bz2
historical-0713ccac9c1fd3c6ca3bf51f44c0ef4d77184c85.zip
Fix issues in ebuild per seemant and George
Diffstat (limited to 'sys-apps/discover')
-rw-r--r--sys-apps/discover/ChangeLog5
-rw-r--r--sys-apps/discover/discover-1.5-r2.ebuild53
-rw-r--r--sys-apps/discover/files/digest-discover-1.5-r21
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/discover/ChangeLog b/sys-apps/discover/ChangeLog
index db2f12e309c3..f4105eec1a31 100644
--- a/sys-apps/discover/ChangeLog
+++ b/sys-apps/discover/ChangeLog
@@ -2,4 +2,9 @@
discover-1.5-r1.ebuild July 30, 2002 christoph@gentoo.org
First release into gentoo cvs tree
+
+discover-1.5-r2.ebuild July 31, 2002 christoph@gentoo.org
+
+ Fix ebuild RDEPEND and other things
+
\ No newline at end of file
diff --git a/sys-apps/discover/discover-1.5-r2.ebuild b/sys-apps/discover/discover-1.5-r2.ebuild
new file mode 100644
index 000000000000..682d0bc4a455
--- /dev/null
+++ b/sys-apps/discover/discover-1.5-r2.ebuild
@@ -0,0 +1,53 @@
+#
+# (C) 2002 The TelemetryBox Corporation. http://telemetrybox.biz
+# Christoph Lameter, <christoph@lameter.com>, July 15, 2002
+#
+# Released under the GPL
+#
+# -r1 provide gentoo discover script. Create missing /var/lib/discover
+# directory
+DESCRIPTION="Discover hardware and load the appropriate drivers for that hardware."
+
+LONGDESC="
+ Discover is a hardware identification system based on the libdiscover1
+ library. Discover provides a flexible interface that programs can use to
+ report a wide range of information about the hardware that is installed on a
+ Linux system. In addition to reporting information, discover includes
+ support for doing hardware detection at boot time. Detection occurs in two
+ stages: The first stage, which runs from an initial ramdisk (initrd), loads
+ just the drivers needed to mount the root file system, and the second stage
+ loads the rest (ethernet cards, sound cards, etc.)."
+
+HOMEPAGE="http://www.progeny.com/discover"
+
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/d/discover/discover_1.5-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="x86 ppc"
+
+DEPEND=""
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+RDEPEND="sys-apps/discover-data"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --sbindir=/sbin \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die "configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ cp ${FILESDIR}/etc-init.d-discover ${D}/etc/init.d/discover
+ insinto /usr/share/discover
+ doins discover/linuxrc
+ dodoc BUGS AUTHORS ChangeLog NEWS README TODO ChangeLog.mandrake docs/ISA-Structure docs/PCI-Structure docs/Programming
+ insinto /var/lib/discover
+ prepallman
+}
diff --git a/sys-apps/discover/files/digest-discover-1.5-r2 b/sys-apps/discover/files/digest-discover-1.5-r2
new file mode 100644
index 000000000000..ef9f5f0ac315
--- /dev/null
+++ b/sys-apps/discover/files/digest-discover-1.5-r2
@@ -0,0 +1 @@
+MD5 0dd025df0f3c7f2c05e4f6f7596e636b discover_1.5-1.tar.gz 382861