summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-30 04:04:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-30 04:04:52 +0000
commitf24a5a53570f3e2a6884f943dc16d644df92f9cd (patch)
treeb5fa23631cb44cdcece92e1fde8140f0372de418 /sys-apps/coreutils
parentseveral changes to this. First, we're using most of Mandrake's patchset with... (diff)
downloadhistorical-f24a5a53570f3e2a6884f943dc16d644df92f9cd.tar.gz
historical-f24a5a53570f3e2a6884f943dc16d644df92f9cd.tar.bz2
historical-f24a5a53570f3e2a6884f943dc16d644df92f9cd.zip
several changes to this. First, we're using most of Mandrake's patchset with fixes, which adds some option to touch -- to make the timestamp move forwards or backwards. I need some input on whether we should keep this. Additionally, there is a patch to restore chown's behaviour to the old way. And another patch to allow old options for several of the utilities here. Additionally, we're using openi18n.org's patches for coreutils, which should sort (no pun intended) out bug #29136 by Sven Sternberger <sven.sternberger@desy.de>
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/Manifest4
-rw-r--r--sys-apps/coreutils/coreutils-5.0.91-r3.ebuild154
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.0.91-r33
3 files changed, 159 insertions, 2 deletions
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 3cc134820897..0a04cb717ce6 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -1,8 +1,8 @@
-MD5 83b1d17309f106f59decb840026746e8 coreutils-5.0.91-r3.ebuild 3798
+MD5 9d69108d1e3037c051505d758075e702 coreutils-5.0.91-r3.ebuild 3797
MD5 fb0112dcad7f6d1ee0531fa66426a261 coreutils-5.0-r6.ebuild 2741
MD5 0e94e0dc62c3ccba5d6e080a7a822d0f coreutils-5.0.91-r2.ebuild 3595
MD5 abdfeb9b44e6951ae6ed1229d436ffca coreutils-5.0-r5.ebuild 2573
-MD5 bfe8c3655e3e1285029d39d66a6d9609 ChangeLog 11133
+MD5 b6a95cda6115b10160782a5239d9cd83 ChangeLog 11797
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 4638c50e0ea024536055d69519cd5fad files/digest-coreutils-5.0.91-r2 151
MD5 a56b66f95289815e386f537689ef29a0 files/digest-coreutils-5.0.91-r3 229
diff --git a/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild b/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild
new file mode 100644
index 000000000000..340e9fbcb312
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild,v 1.1 2003/12/30 04:04:46 seemant Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="nls build acl selinux static"
+
+PATCH_VER=1.4.4
+I18N_PATCH=i18n-0.2
+PATCHDIR=${WORKDIR}/patch
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/coreutils/${P}.tar.bz2
+ mirror://coreutils/${P}.tar.bz2
+ http://www.openi18n.org/subgroups/utildev/patch/${P}-${I18N_PATCH}.patch.gz
+ mirror://gentoo/${P}-gentoo-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~seemant/extras/${P}-gentoo-${PATCH_VER}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~ia64 ~amd64 ~ppc64"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.49
+ >=sys-devel/automake-1.7.6
+ >=sys-devel/autoconf-2.57
+ sys-apps/help2man
+ ppc? ( >=sys-devel/m4-1.4-r1 )
+ nls? ( sys-devel/gettext )
+ acl? ( !hppa? ( sys-apps/acl ) )
+ selinux? ( sys-libs/libselinux )"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ if use acl && use selinux
+ then
+ ewarn "Both ACL and SELINUX are not supported together!"
+ ewarn "Will Select SELINUX instead"
+ fi
+
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/mandrake
+ epatch ${WORKDIR}/${P}-${I18N_PATCH}.patch
+
+ # ARM platform does not work well with the uname patch
+ # (see below about it)
+ if use arm
+ then
+ mv ${PATCHDIR}/003* ${PATCHDIR}/excluded
+ fi
+
+ # Apply the ACL patches.
+ # WARNING: These CONFLICT with the SELINUX patches
+ if use acl
+ then
+ #
+ # This one also needs porting like the rest, but its a bit more involved,
+ # so I will leave it for somebody that use i18n that can actually test it.
+ #
+ # if [ -z "`use nls`" ] ; then
+ mv ${PATCHDIR}/acl/004* ${PATCHDIR}/excluded
+ # fi
+
+ # This test do seem to be fixed in another way, the acl guys
+ # can just verify please ...
+ mv ${PATCHDIR}/acl/006* ${PATCHDIR}/excluded
+
+ use selinux || mv ${PATCHDIR}/{001*,002*,004*} ${PATCHDIR}/excluded
+ use selinux || EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/acl
+ fi
+
+ # patch to remove Stallman's su/wheel group rant (which doesn't apply,
+ # since Gentoo's su is not GNU/su, but that from shadow.
+ # do not include su infopage, as it is not valid for the su
+ # from sys-apps/shadow that we are using.
+ # Patch to add processor specific info to the uname output
+
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
+
+ use selinux && EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/selinux
+}
+
+src_compile() {
+ append-flags "-fPIC"
+
+ local myconf=
+ use nls || myconf="--disable-nls"
+
+ if use acl
+ then
+ if [ -z "`use selinux`" ]
+ then
+ if [ -z "`which cvs 2>/dev/null`" ]
+ then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+ mv m4/inttypes.m4 m4/inttypes-eggert.m4
+ fi
+ fi
+
+ export WANT_AUTOMAKE=1.7
+
+ aclocal -I ${S}/m4 || die
+ autoconf || die
+ automake || die
+
+ econf \
+ --bindir=/bin \
+ ${myconf} || die
+
+ if use static
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin || die
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
+ then
+ rm -f ${ROOT}/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.0.91-r3 b/sys-apps/coreutils/files/digest-coreutils-5.0.91-r3
new file mode 100644
index 000000000000..3332f646de3e
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.0.91-r3
@@ -0,0 +1,3 @@
+MD5 e62c18cde8b254c2512e47dd0c47c332 coreutils-5.0.91.tar.bz2 4183673
+MD5 816c0a3ebdf9f66d004d822dd94b3864 coreutils-5.0.91-i18n-0.2.patch.gz 26150
+MD5 d0ef097c6e1b40542a20071bf5a426e0 coreutils-5.0.91-gentoo-1.4.4.tar.bz2 85518