summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-11 04:43:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-11 04:43:07 +0000
commitdf42505792b230caceb93f94e1db516814579723 (patch)
treed2fa9d5042302268990fe83aded8c66c396db9ed /sys-apps/coreutils
parenterrno fixes (diff)
downloadhistorical-df42505792b230caceb93f94e1db516814579723.tar.gz
historical-df42505792b230caceb93f94e1db516814579723.tar.bz2
historical-df42505792b230caceb93f94e1db516814579723.zip
fix invalid symlinks; fix not installing all manpages
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-4.5.9.ebuild30
2 files changed, 22 insertions, 15 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 0d6e8b785963..08dfaa906294 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.1 2003/03/05 21:39:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.2 2003/03/11 04:43:07 azarah Exp $
+
+ 11 Mar 2003; Martin Schlemmer <azarah@gentoo.org> coreutils-4.5.9.ebuild :
+ Move symlink stuff till after we remove stuff we do not use, else we have
+ invalid symlinks. Change einstall to 'make DESTDIR=$D install', else it
+ do not install all the manpages.
*coreutils-4.5.9 (06 Mar 2003)
diff --git a/sys-apps/coreutils/coreutils-4.5.9.ebuild b/sys-apps/coreutils/coreutils-4.5.9.ebuild
index 4f7d705e8efe..d35bcdde29e1 100644
--- a/sys-apps/coreutils/coreutils-4.5.9.ebuild
+++ b/sys-apps/coreutils/coreutils-4.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-4.5.9.ebuild,v 1.1 2003/03/05 21:39:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-4.5.9.ebuild,v 1.2 2003/03/11 04:43:07 azarah Exp $
inherit eutils
@@ -51,9 +51,22 @@ src_compile() {
}
src_install() {
- einstall \
- bindir=${D}/bin || die
+# Do not install all the manpages, etc
+# einstall \
+# bindir=${D}/bin || die
+ make DESTDIR=${D} install || die
+ # hostname comes from net-base
+ # hostname does not work with the -f switch, which breaks gnome2
+ # amongst other things
+ rm -f ${D}/usr/bin/hostname
+
+ # /bin/su comes from sys-apps/shadow
+ rm -f ${D}/bin/su ${D}/usr/share/man/man1/su*
+
+ # /usr/bin/uptime comes from the sys-apps/procps packaga
+ rm -f ${D}/usr/bin/uptime ${D}/usr/share/man/man1/uptime*
+
cd ${D}
dodir /usr/bin
rm -rf usr/lib
@@ -67,17 +80,6 @@ src_install() {
else
rm -rf ${D}/usr/share
fi
-
- # hostname comes from net-base
- # hostname does not work with the -f switch, which breaks gnome2
- # amongst other things
- rm -f ${D}/usr/bin/hostname
-
- # /bin/su comes from sys-apps/shadow
- rm -f ${D}/bin/su ${D}/usr/share/man/man1/su
-
- # /usr/bin/uptime comes from the sys-apps/procps packaga
- rm -f ${D}/usr/bin/uptime ${D}/usr/share/man/man1/uptime*
}
pkg_postinst() {