summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-28 06:00:19 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-28 06:00:19 +0000
commit9ada254a8f18284b88130639f9d385c26b56bc61 (patch)
tree890f305bea44401ad25fdcf589bb7b2597e6cce4 /sys-apps/busybox/busybox-1.4.1-r2.ebuild
parentwhitespace (diff)
downloadhistorical-9ada254a8f18284b88130639f9d385c26b56bc61.tar.gz
historical-9ada254a8f18284b88130639f9d385c26b56bc61.tar.bz2
historical-9ada254a8f18284b88130639f9d385c26b56bc61.zip
set the config static flag on the cmdline rather than forcing LDFLAGS #160879
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'sys-apps/busybox/busybox-1.4.1-r2.ebuild')
-rw-r--r--sys-apps/busybox/busybox-1.4.1-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/busybox/busybox-1.4.1-r2.ebuild b/sys-apps/busybox/busybox-1.4.1-r2.ebuild
index 4760438af9d4..612baf7be2a2 100644
--- a/sys-apps/busybox/busybox-1.4.1-r2.ebuild
+++ b/sys-apps/busybox/busybox-1.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.1-r2.ebuild,v 1.8 2007/03/25 16:29:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.1-r2.ebuild,v 1.9 2007/03/28 06:00:19 vapier Exp $
inherit eutils flag-o-matic
@@ -183,7 +183,7 @@ src_compile() {
emake busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}
- LDFLAGS="${LDFLAGS} -static" emake busybox || die "static build failed"
+ emake CONFIG_STATIC=y busybox || die "static build failed"
mv busybox_unstripped bb
mv busybox_unstripped{.bak,}
fi