summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2004-10-08 03:04:51 +0000
committerKito Danya Dietrich <kito@gentoo.org>2004-10-08 03:04:51 +0000
commit16ed3138b1c5a4a5347ac6ccce69a976b1af64db (patch)
tree5e063efe1368a51c77ccb0a63f94220c10a8f47e /sys-apps/bootstrap_cmds
parentCloses bug #66435 (diff)
downloadhistorical-16ed3138b1c5a4a5347ac6ccce69a976b1af64db.tar.gz
historical-16ed3138b1c5a4a5347ac6ccce69a976b1af64db.tar.bz2
historical-16ed3138b1c5a4a5347ac6ccce69a976b1af64db.zip
major syntax cleanup
Diffstat (limited to 'sys-apps/bootstrap_cmds')
-rw-r--r--sys-apps/bootstrap_cmds/Manifest2
-rw-r--r--sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild51
2 files changed, 17 insertions, 36 deletions
diff --git a/sys-apps/bootstrap_cmds/Manifest b/sys-apps/bootstrap_cmds/Manifest
index 0ece3c398e66..8227ba6d1486 100644
--- a/sys-apps/bootstrap_cmds/Manifest
+++ b/sys-apps/bootstrap_cmds/Manifest
@@ -1,4 +1,4 @@
MD5 a5f2512be3bc798344df9dba19131918 ChangeLog 331
-MD5 dca9b2809221fa2a211a73f87b714623 bootstrap_cmds-44.ebuild 1676
+MD5 63d08b2748136b302136227770d5df98 bootstrap_cmds-44.ebuild 1306
MD5 65d0ad2167dd016e2981b7a3df82cc50 metadata.xml 212
MD5 476b98a9a8f0ba1fccda9ccdd2a58edc files/digest-bootstrap_cmds-44 69
diff --git a/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild b/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
index 90148b983bd2..dd9b8cb19fd2 100644
--- a/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
+++ b/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild,v 1.5 2004/09/27 20:03:14 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild,v 1.6 2004/10/08 03:04:51 kito Exp $
DESCRIPTION="Darwin bootstrap_cmds - config, decomment, mig, relpath"
HOMEPAGE="http://darwinsource.opendarwin.org/10.3.5/"
@@ -13,48 +13,29 @@ KEYWORDS="~ppc-macos"
IUSE=""
DEPEND="virtual/libc"
-##
-# Setup the Darwin build environment
-#=================================================================
-# requires fat build tools
-# use build && BUILDARCHS="ppc i386" ||
-
-BUILDARCHS="ppc"
-
-pkg_setup() {
- export RC_OS=macos
- export RC_ARCHS=${BUILDARCHS}
- export TARGETS=${BUILDARCHS}
- export SRCROOT=${S}
- export OBJROOT=${WORKDIR}/build/obj
- export DSTROOT=${D}
- export SYMROOT=${WORKDIR}/build/sym
- export RC_CFLAGS="${CFLAGS}"
-}
-
src_unpack() {
unpack ${A}
- mkdir -p ${WORKDIR}/build/obj ${WORKDIR}/build/sym ${S}/BUILD
+
+ cd ${S}
+ sed -i -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
+
+ cd ${S}/decomment.tproj
+ sed -i -e 's:^NEXTSTEP_INSTALLDIR = .*:NEXTSTEP_INSTALLDIR = /usr/bin:' Makefile
+ sed -i -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
+
+ cd ${S}/relpath.tproj
+ sed -i -e 's:^NEXTSTEP_INSTALLDIR = .*:NEXTSTEP_INSTALLDIR = /usr/bin:' Makefile
+ sed -i -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
+
rm ${S}/Makefile.postamble
rm ${S}/config.tproj/Makefile.postamble
rm ${S}/decomment.tproj/Makefile.postamble
rm ${S}/relpath.tproj/Makefile.postamble
}
-src_compile() {
- emake || die "make failed"
-}
-
src_install() {
- make install DSTROOT=${S}/BUILD || die "make install failed"
-
- newbin ${S}/migcom.tproj/mig.sh mig || die "newbin mig failed"
- newbin ${S}/vers_string.sh vers_string || die "newbin vers_string failed"
- dobin ${S}/BUILD/usr/local/bin/{decomment,relpath} ${S}/BUILD/usr/bin/config \
- || die "dobin decomment, relpath, config failed"
-
- exeinto /usr/libexec
- doexe ${S}/BUILD/usr/libexec/migcom
+ make install DSTROOT=${D} || die "make install failed"
- doman ${S}/vers_string.1
+ newbin vers_string.sh vers_string
+ doman *.1
} \ No newline at end of file