summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-07-27 17:20:28 +0000
committerTom William Payne <twp@gentoo.org>2003-07-27 17:20:28 +0000
commitd323ab70d6d69252a74ab1ebb7f2f55b4cb204cd (patch)
tree25c723e71476693b6617f194510f337fbdbf070d /sys-apps/acpid
parentBug # 22238 (diff)
downloadhistorical-d323ab70d6d69252a74ab1ebb7f2f55b4cb204cd.tar.gz
historical-d323ab70d6d69252a74ab1ebb7f2f55b4cb204cd.tar.bz2
historical-d323ab70d6d69252a74ab1ebb7f2f55b4cb204cd.zip
Bug # 22238
Diffstat (limited to 'sys-apps/acpid')
-rw-r--r--sys-apps/acpid/Manifest4
-rw-r--r--sys-apps/acpid/acpid-1.0.2-r2.ebuild44
-rw-r--r--sys-apps/acpid/files/default.sh-gentoo.patch27
-rw-r--r--sys-apps/acpid/files/digest-acpid-1.0.2-r21
4 files changed, 74 insertions, 2 deletions
diff --git a/sys-apps/acpid/Manifest b/sys-apps/acpid/Manifest
index b3cbbf92f6ab..6f4a2361321f 100644
--- a/sys-apps/acpid/Manifest
+++ b/sys-apps/acpid/Manifest
@@ -1,7 +1,7 @@
-MD5 2330fd2d4b3427c6cbc2f763c9884c67 ChangeLog 1699
+MD5 f0327fb73c5c7b0f6a59a431436d1bf5 ChangeLog 1803
MD5 5c681052b24190636b453b9708669747 acpid-1.0.1.ebuild 1011
MD5 86fe76ed8fa5d12ab3a4bf704c9a3d29 acpid-1.0.2-r1.ebuild 1131
-MD5 085ec4c3e07852fe93d6e70a3457e21d acpid-1.0.2-r2.ebuild 1197
+MD5 03b28b0dfd6ae498f2273d343b28c52e acpid-1.0.2-r2.ebuild 1229
MD5 4bd2fb8d3844765258c746c05ca35c50 files/acpid.rc6 665
MD5 1ad4b7deead64fc207ea20bd1c340973 files/digest-acpid-1.0.1 62
MD5 4bf4b207e7f3c9f7a966c62236dd73be files/digest-acpid-1.0.2-r1 62
diff --git a/sys-apps/acpid/acpid-1.0.2-r2.ebuild b/sys-apps/acpid/acpid-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..a116eab2b2f4
--- /dev/null
+++ b/sys-apps/acpid/acpid-1.0.2-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.2-r2.ebuild,v 1.1 2003/07/27 17:20:02 twp Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface."
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+HOMEPAGE="http://acpid.sourceforge.net/"
+IUSE=""
+KEYWORDS="~x86 ~amd64 -ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+# We need the patched kernel with latest ACPI code, or else it will
+# be broken. Hopefully it will be merge into release kernel soon.
+DEPEND="virtual/glibc
+ virtual/linux-sources"
+
+src_compile() {
+
+ # Fix bug # 22238 (default.sh broken)
+ ( cd debian && epatch ${FILESDIR}/default.sh-gentoo.patch )
+
+ # DO NOT COMPILE WITH OPTIMISATIONS.
+ # That is a note to the devs. IF you are a user, go ahead and optimise
+ # if you want, but we won't support bugs associated with that"
+ make INSTPREFIX=${D} || die
+}
+
+src_install() {
+ make INSTPREFIX=${D} install || die
+
+ dodir /etc/acpi/events
+ exeinto /etc/acpi
+ doexe debian/default.sh
+ insinto /etc/acpi/events
+ doins debian/default
+
+ dodoc README Changelog
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/acpid.rc6 acpid
+}
+
diff --git a/sys-apps/acpid/files/default.sh-gentoo.patch b/sys-apps/acpid/files/default.sh-gentoo.patch
new file mode 100644
index 000000000000..6da547d2ded1
--- /dev/null
+++ b/sys-apps/acpid/files/default.sh-gentoo.patch
@@ -0,0 +1,27 @@
+--- acpi/default.sh 2003-07-27 19:06:47.000000000 +0200
++++ acpi-gentoo/default.sh 2003-07-27 19:11:45.000000000 +0200
+@@ -3,17 +3,20 @@
+
+ set $*
+
+-case "$1" in
++group=${1/\/*/}
++action=${1/*\//}
++
++case "$group" in
+ button)
+- case "$2" in
++ case "$action" in
+ power) /sbin/init 0
+ ;;
+- *) logger "ACPI action $2 is not defined"
++ *) logger "ACPI action $action is not defined"
+ ;;
+ esac
+ ;;
+
+ *)
+- logger "ACPI group $1 / action $2 is not defined"
++ logger "ACPI group $group / action $action is not defined"
+ ;;
+ esac
diff --git a/sys-apps/acpid/files/digest-acpid-1.0.2-r2 b/sys-apps/acpid/files/digest-acpid-1.0.2-r2
new file mode 100644
index 000000000000..ea5c9cf27a55
--- /dev/null
+++ b/sys-apps/acpid/files/digest-acpid-1.0.2-r2
@@ -0,0 +1 @@
+MD5 15884aaf0b82717954f9366b5c00808b acpid-1.0.2.tar.gz 23554