summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-18 11:44:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-18 11:44:11 +0000
commit237fb1b997c8004133c5f75892fd5309090941b1 (patch)
tree565d045b31baef0dce0a8048576ed8843f556483 /sci-physics/hepmc
parentFix wrong functions usage. Per bug #248769. Thanks to Martin von Gagern for t... (diff)
downloadhistorical-237fb1b997c8004133c5f75892fd5309090941b1.tar.gz
historical-237fb1b997c8004133c5f75892fd5309090941b1.tar.bz2
historical-237fb1b997c8004133c5f75892fd5309090941b1.zip
Bump, thanks Ben Bannier, closing bug #257689
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/ChangeLog10
-rw-r--r--sci-physics/hepmc/hepmc-2.04.01.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
index 90654aedb65d..90f6c8d4b7a6 100644
--- a/sci-physics/hepmc/ChangeLog
+++ b/sci-physics/hepmc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/hepmc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.3 2008/09/16 12:44:24 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.4 2009/02/18 11:44:11 bicatali Exp $
+
+*hepmc-2.04.01 (18 Feb 2009)
+
+ 18 Feb 2009; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +hepmc-2.04.01.ebuild:
+ Bump, thanks Ben Bannier, closing bug #257689
16 Sep 2008; Jeroen Roovers <jer@gentoo.org> hepmc-2.04.00.ebuild:
Marked ~hppa (bug #236718).
diff --git a/sci-physics/hepmc/hepmc-2.04.01.ebuild b/sci-physics/hepmc/hepmc-2.04.01.ebuild
new file mode 100644
index 000000000000..6bdc3e5784ba
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.04.01.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.04.01.ebuild,v 1.1 2009/02/18 11:44:11 bicatali Exp $
+
+EAPI=2
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://savannah.cern.ch/projects/hepmc/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples gev cm"
+
+DEPEND=""
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ # random default choice: use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ econf \
+ --with-length=${length_conf} \
+ --with-momentum=${momentum_conf}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ INSTALLDIR=/usr/share/doc/${PF}/examples \
+ doc_installdir=/usr/share/doc/${PF} \
+ install || die "emake install failed"
+
+ dodoc README AUTHORS ChangeLog
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r doc/html || die
+ else
+ rm -f "${D}"/usr/share/doc/${PF}/*pdf
+ fi
+ use examples || rm -rf "${D}"/usr/share/doc/${PF}/examples
+}