summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-10-20 18:31:21 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-10-20 18:31:21 +0000
commit85bfa91fdc14081a9732698485cfca0b1d0311bc (patch)
tree798bf464fed1d0e5e8284c036b7b56a77b805cb3 /sci-mathematics
parentMark 2.14.2 stable on alpha (diff)
downloadhistorical-85bfa91fdc14081a9732698485cfca0b1d0311bc.tar.gz
historical-85bfa91fdc14081a9732698485cfca0b1d0311bc.tar.bz2
historical-85bfa91fdc14081a9732698485cfca0b1d0311bc.zip
Version bump, marked newer version stable on amd64 and pruned old version.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog9
-rw-r--r--sci-mathematics/mathomatic/files/digest-mathomatic-12.6.53
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.5.20.ebuild4
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.6.5.ebuild39
4 files changed, 52 insertions, 3 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 19eacea40004..3860dc904b88 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.15 2006/10/06 18:43:22 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.16 2006/10/20 18:31:21 cryos Exp $
+
+*mathomatic-12.6.5 (20 Oct 2006)
+
+ 20 Oct 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ -mathomatic-12.5.13.ebuild, mathomatic-12.5.20.ebuild,
+ +mathomatic-12.6.5.ebuild:
+ Version bump, marked newer version stable on amd64 and pruned old version.
*mathomatic-12.6.4 (06 Oct 2006)
diff --git a/sci-mathematics/mathomatic/files/digest-mathomatic-12.6.5 b/sci-mathematics/mathomatic/files/digest-mathomatic-12.6.5
new file mode 100644
index 000000000000..a8cf9daf9de1
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/digest-mathomatic-12.6.5
@@ -0,0 +1,3 @@
+MD5 d460c762fc3e65f346918ea205bb6bc8 mathomatic-12.6.5.tar.bz2 117517
+RMD160 078d9e069d132ed6c848cbd42a02f8f4814cac2c mathomatic-12.6.5.tar.bz2 117517
+SHA256 c99a2beb58715d4f8f8912e2676c1bba3a37ceb8f8f7521208c1952aa1086ba3 mathomatic-12.6.5.tar.bz2 117517
diff --git a/sci-mathematics/mathomatic/mathomatic-12.5.20.ebuild b/sci-mathematics/mathomatic/mathomatic-12.5.20.ebuild
index d9ca2d7b44d8..99efc4e87152 100644
--- a/sci-mathematics/mathomatic/mathomatic-12.5.20.ebuild
+++ b/sci-mathematics/mathomatic/mathomatic-12.5.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.5.20.ebuild,v 1.1 2006/07/15 22:09:53 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.5.20.ebuild,v 1.2 2006/10/20 18:31:21 cryos Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc ~x86"
IUSE="doc icc"
DEPEND="sys-libs/readline
diff --git a/sci-mathematics/mathomatic/mathomatic-12.6.5.ebuild b/sci-mathematics/mathomatic/mathomatic-12.6.5.ebuild
new file mode 100644
index 000000000000..7d9cc084c934
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.6.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.6.5.ebuild,v 1.1 2006/10/20 18:31:21 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc icc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ icc? ( dev-lang/icc )"
+
+src_compile() {
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake READLINE=1 || die "emake failed"
+ else
+ emake READLINE=1 || die "emake failed"
+ fi
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic
+ dodoc changes.txt README.txt
+ doman mathomatic.1
+
+ if use doc; then
+ dohtml doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*.in
+ fi
+}