summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-01-07 09:40:26 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-01-07 09:40:26 +0000
commit26cc357dc572a0096f932aa09828e50937b0f528 (patch)
treeacdb8b38d6a716b8fce7506becacf7c3e31f3ee6 /sci-mathematics/pari
parentsort (diff)
downloadhistorical-26cc357dc572a0096f932aa09828e50937b0f528.tar.gz
historical-26cc357dc572a0096f932aa09828e50937b0f528.tar.bz2
historical-26cc357dc572a0096f932aa09828e50937b0f528.zip
Fixing the fix.
Diffstat (limited to 'sci-mathematics/pari')
-rw-r--r--sci-mathematics/pari/ChangeLog10
-rw-r--r--sci-mathematics/pari/Manifest11
-rw-r--r--sci-mathematics/pari/files/digest-pari-2.1.5-r4 (renamed from sci-mathematics/pari/files/digest-pari-2.1.5-r3)0
-rw-r--r--sci-mathematics/pari/files/wrong_functype-r1.patch35
-rw-r--r--sci-mathematics/pari/files/wrong_functype.patch13
-rw-r--r--sci-mathematics/pari/pari-2.1.5-r4.ebuild (renamed from sci-mathematics/pari/pari-2.1.5-r3.ebuild)2
-rw-r--r--sci-mathematics/pari/pari-2.1.6.ebuild4
7 files changed, 66 insertions, 9 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index d2c2084704e4..50bcc4c0dd5c 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.4 2005/01/06 10:34:52 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.5 2005/01/07 09:40:26 phosphan Exp $
+
+*pari-2.1.5-r4 (07 Jan 2005)
+
+ 07 Jan 2005; Patrick Kursawe <phosphan@gentoo.org>
+ +files/wrong_functype-r1.patch, files/wrong_functype.patch,
+ -pari-2.1.5-r3.ebuild, +pari-2.1.5-r4.ebuild, pari-2.1.6.ebuild:
+ Function call patch was missing one line of 2.1.5. Bumping revision,
+ modified patch, removed old version.
*pari-2.1.6 (06 Jan 2005)
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index b6b3fa323833..9238dc90f77b 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -1,10 +1,11 @@
-MD5 abfc1a6d3677ef9634d91a3b29ec2cef pari-2.1.6.ebuild 1893
+MD5 4818ef4876441247184df2b11538de44 pari-2.1.5-r4.ebuild 1882
+MD5 73082ae75e95e6ef63e87b2bf267f255 pari-2.1.6.ebuild 1896
MD5 d33b0309bbbaa8e508e35af360efb31b pari-2.1.5-r1.ebuild 953
-MD5 ad2659bd31e0af8cc4269765dc375964 pari-2.1.5-r3.ebuild 1882
-MD5 bbf0ffa213678b0d6db06e766ef3124d ChangeLog 3249
+MD5 bcb807d16b683aaa33ee7661306f6c50 ChangeLog 3572
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 c3f89da5ddbdb73646e3d64ee31ea887 files/docs.patch 915
MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r1 63
-MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r3 63
-MD5 dccf7ef464f99fa750a5c7fc3ec67e8f files/wrong_functype.patch 1498
+MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r4 63
+MD5 cbd309a01e2fee1a5ba6cb3a93ba5708 files/wrong_functype.patch 1946
MD5 2fd9906f2bf293fdad42d572846508de files/digest-pari-2.1.6 60
+MD5 dccf7ef464f99fa750a5c7fc3ec67e8f files/wrong_functype-r1.patch 1498
diff --git a/sci-mathematics/pari/files/digest-pari-2.1.5-r3 b/sci-mathematics/pari/files/digest-pari-2.1.5-r4
index 2e0d53a28384..2e0d53a28384 100644
--- a/sci-mathematics/pari/files/digest-pari-2.1.5-r3
+++ b/sci-mathematics/pari/files/digest-pari-2.1.5-r4
diff --git a/sci-mathematics/pari/files/wrong_functype-r1.patch b/sci-mathematics/pari/files/wrong_functype-r1.patch
new file mode 100644
index 000000000000..5eb95e622c7a
--- /dev/null
+++ b/sci-mathematics/pari/files/wrong_functype-r1.patch
@@ -0,0 +1,35 @@
+diff -ru src/gp/gp_rl.c src.new/gp/gp_rl.c
+--- src/gp/gp_rl.c 2001-04-27 15:55:38.000000000 +0200
++++ src.new/gp/gp_rl.c 2005-01-06 11:04:45.198086689 +0100
+@@ -79,11 +79,13 @@
+ #endif
+
+ #ifdef HAS_RL_COMPLETION_MATCHES
+-# define COMPLETION_MATCHES ((CF)rl_completion_matches)
++# define COMPLETION_MATCHES(a,b) \
++ (completion_matches((char *)(a),(b)))
+ # define FILE_COMPLETION ((GF)rl_filename_completion_function)
+ # define USER_COMPLETION ((GF)rl_username_completion_function)
+ #else
+-# define COMPLETION_MATCHES ((CF)completion_matches)
++# define COMPLETION_MATCHES(a,b) \
++ (completion_matches((char *)(a),(b)))
+ # define FILE_COMPLETION ((GF)filename_completion_function)
+ # define USER_COMPLETION ((GF)username_completion_function)
+ #endif
+diff -ru src.old/gp/gp_rl.c src/gp/gp_rl.c
+--- src.old/gp/gp_rl.c 2005-01-06 11:07:18.000000000 +0100
++++ src/gp/gp_rl.c 2005-01-06 11:15:10.509112328 +0100
+@@ -625,10 +625,8 @@
+ /* we always want the whole list of completions under emacs */
+ if (under_emacs) rl_completion_query_items = 0x8fff;
+
+-#define Bind(a,b,c) (((void(*)(int,Function*,Keymap)) rl_bind_key_in_map)\
+- ((a), (Function*)(b), (c)))
+-#define Defun(a,b,c) (((void(*)(const char*,Function*,int)) rl_add_defun)\
+- ((a), (Function*)(b), (c)))
++#define Bind(a,b,c) (rl_bind_key_in_map((a), (Function*)(b), (c)))
++#define Defun(a,b,c) (rl_add_defun((char*)(a), (Function*)(b), (c)))
+
+ Defun("short-help", rl_short_help, -1);
+ Defun("long-help", rl_long_help, -1);
diff --git a/sci-mathematics/pari/files/wrong_functype.patch b/sci-mathematics/pari/files/wrong_functype.patch
index 5eb95e622c7a..a1dd4c98fe0a 100644
--- a/sci-mathematics/pari/files/wrong_functype.patch
+++ b/sci-mathematics/pari/files/wrong_functype.patch
@@ -33,3 +33,16 @@ diff -ru src.old/gp/gp_rl.c src/gp/gp_rl.c
Defun("short-help", rl_short_help, -1);
Defun("long-help", rl_long_help, -1);
+diff -ru src-old/basemath/buch2.c src/basemath/buch2.c
+--- src-old/basemath/buch2.c 2001-11-04 15:09:54.000000000 +0100
++++ src/basemath/buch2.c 2005-01-07 10:08:25.442785391 +0100
+@@ -2922,7 +2922,8 @@
+
+ /* random relations */
+ if (cglob == KCCO) /* enough relations, initialize nevertheless */
+- ((void(*)(long))random_relation)(-1);
++ random_relation(-1,0,0,0,0,0,NULL,NULL,NULL,NULL,NULL,NULL,NULL);
++
+ else
+ {
+ GEN maarch;
diff --git a/sci-mathematics/pari/pari-2.1.5-r3.ebuild b/sci-mathematics/pari/pari-2.1.5-r4.ebuild
index 33585facc208..4127e28ad08c 100644
--- a/sci-mathematics/pari/pari-2.1.5-r3.ebuild
+++ b/sci-mathematics/pari/pari-2.1.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r3.ebuild,v 1.2 2005/01/06 10:34:52 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r4.ebuild,v 1.1 2005/01/07 09:40:26 phosphan Exp $
inherit eutils
diff --git a/sci-mathematics/pari/pari-2.1.6.ebuild b/sci-mathematics/pari/pari-2.1.6.ebuild
index 851cb4c49f22..b156f842b4fc 100644
--- a/sci-mathematics/pari/pari-2.1.6.ebuild
+++ b/sci-mathematics/pari/pari-2.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.1 2005/01/06 10:34:52 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.2 2005/01/07 09:40:26 phosphan Exp $
inherit eutils
@@ -20,7 +20,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/docs.patch
- epatch ${FILESDIR}/wrong_functype.patch
+ epatch ${FILESDIR}/wrong_functype-r1.patch
}
src_compile() {