summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2014-12-06 21:06:14 +0000
committerMatthias Maier <tamiko@gentoo.org>2014-12-06 21:06:14 +0000
commit2d079d456ea198d816a4e4794381eba690c718b9 (patch)
tree51746b5f723072ab85735eaf495ac8649abcb2c8 /sci-mathematics/freemat/freemat-4.2.ebuild
parentNew package, imported from perl overlay, bug 311017 (diff)
downloadhistorical-2d079d456ea198d816a4e4794381eba690c718b9.tar.gz
historical-2d079d456ea198d816a4e4794381eba690c718b9.tar.bz2
historical-2d079d456ea198d816a4e4794381eba690c718b9.zip
drop python-r1 eclass; fix dependencies; fix llvm configuration wrt bug #531316
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0xBD3A97A3
Diffstat (limited to 'sci-mathematics/freemat/freemat-4.2.ebuild')
-rw-r--r--sci-mathematics/freemat/freemat-4.2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sci-mathematics/freemat/freemat-4.2.ebuild b/sci-mathematics/freemat/freemat-4.2.ebuild
index 00a825088007..a229c3ae267a 100644
--- a/sci-mathematics/freemat/freemat-4.2.ebuild
+++ b/sci-mathematics/freemat/freemat-4.2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-4.2.ebuild,v 1.1 2014/12/01 00:26:34 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-4.2.ebuild,v 1.2 2014/12/06 21:05:59 tamiko Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_{3,4}} )
-
-inherit eutils cmake-utils fdo-mime python-r1
+inherit eutils cmake-utils fdo-mime
MY_PN=FreeMat
MY_P=${MY_PN}-${PV}
@@ -34,6 +32,7 @@ RDEPEND="dev-libs/libpcre
dev-qt/qtgui:4
dev-qt/qtopengl:4
dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
volpack? ( media-libs/volpack )
vtk? ( sci-libs/vtk )"
@@ -46,8 +45,8 @@ S="${WORKDIR}/${MY_P}-Source"
src_prepare(){
epatch \
"${FILESDIR}"/${PN}-4.1-fixes.patch \
- "${FILESDIR}"/${PN}-4.1-use_llvm.patch \
- "${FILESDIR}"/${PN}-4.1-python3.patch
+ "${FILESDIR}"/${PN}-4.1-python3.patch \
+ "${FILESDIR}"/${P}-use_llvm.patch
rm -f CMakeCache.txt
find . -type f -name '*.moc.cpp' -exec rm -f {} \;
find . -type f -name 'add.so' -exec rm -f {} \;