summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-25 18:47:43 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-25 18:47:43 +0000
commita8597fb45bb233acb6fd3fc327363875cf2c61c4 (patch)
treed621ee93a8c7dd6a389d589088d3d10f29297d4c /sci-mathematics/drgeo/drgeo-1.1.0.ebuild
parentAdd ~x86 (diff)
downloadhistorical-a8597fb45bb233acb6fd3fc327363875cf2c61c4.tar.gz
historical-a8597fb45bb233acb6fd3fc327363875cf2c61c4.tar.bz2
historical-a8597fb45bb233acb6fd3fc327363875cf2c61c4.zip
sci-mathematics/drgeo: Moved to EAPI=4, dropped unnessecary die
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics/drgeo/drgeo-1.1.0.ebuild')
-rw-r--r--sci-mathematics/drgeo/drgeo-1.1.0.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sci-mathematics/drgeo/drgeo-1.1.0.ebuild b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
index 0955f17e2a4c..b00b156e71b3 100644
--- a/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
+++ b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.1.0.ebuild,v 1.8 2011/03/02 13:55:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.1.0.ebuild,v 1.9 2012/04/25 18:47:43 jlec Exp $
-EAPI="2"
+EAPI=4
inherit eutils
@@ -11,12 +11,13 @@ DOCV="1.5"
DOC="${DOCN}-${DOCV}"
DESCRIPTION="Interactive geometry package"
-LICENSE="GPL-2"
HOMEPAGE="http://www.ofset.org/drgeo"
-SRC_URI="mirror://sourceforge/ofset/${P}.tar.gz
+SRC_URI="
+ mirror://sourceforge/ofset/${P}.tar.gz
mirror://sourceforge/ofset/${DOC}.tar.gz"
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc x86"
IUSE="nls"
@@ -28,7 +29,6 @@ RDEPEND="
>=dev-scheme/guile-1.8[deprecated]
=dev-scheme/guile-1.6*
)"
-
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -42,17 +42,15 @@ src_configure() {
# yet in portage. Fortunately HTML is already compiled for us in the
# tarball and so can be installed. Just create the make install target.
cd "${WORKDIR}"/${DOC}
- econf || die "docs econf failed."
+ econf
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed."
- dodoc AUTHORS ChangeLog README NEWS TODO || die
+ default
if use nls; then
cd "${WORKDIR}"/${DOC}
else
cd "${WORKDIR}"/${DOC}/c
fi
- emake install DESTDIR="${D}" || die "emake docs installation failed"
-
+ emake install DESTDIR="${D}"
}