summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-27 15:17:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-27 15:17:24 +0000
commitc2d68d5c7721bd809e016ce5f1e82fac4ce9a07b (patch)
treef9d5cb62788a41a4fe2328705638cf3d1590b630 /sci-mathematics/cgal
parentVersion bump. Cleanup (diff)
downloadhistorical-c2d68d5c7721bd809e016ce5f1e82fac4ce9a07b.tar.gz
historical-c2d68d5c7721bd809e016ce5f1e82fac4ce9a07b.tar.bz2
historical-c2d68d5c7721bd809e016ce5f1e82fac4ce9a07b.zip
Initial import. Closing bug #167944.
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'sci-mathematics/cgal')
-rw-r--r--sci-mathematics/cgal/ChangeLog11
-rw-r--r--sci-mathematics/cgal/Manifest16
-rw-r--r--sci-mathematics/cgal/cgal-3.3.1.ebuild97
-rw-r--r--sci-mathematics/cgal/files/cgal-3.3.1-qt.patch71
-rw-r--r--sci-mathematics/cgal/files/cgal-3.3.1-rpath.patch116
-rw-r--r--sci-mathematics/cgal/metadata.xml21
6 files changed, 332 insertions, 0 deletions
diff --git a/sci-mathematics/cgal/ChangeLog b/sci-mathematics/cgal/ChangeLog
new file mode 100644
index 000000000000..6b9e8973861e
--- /dev/null
+++ b/sci-mathematics/cgal/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/cgal
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.1 2008/10/27 15:17:24 bicatali Exp $
+
+*cgal-3.3.1 (27 Oct 2008)
+
+ 27 Oct 2008; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +files/cgal-3.3.1-qt.patch, +files/cgal-3.3.1-rpath.patch, +metadata.xml,
+ +cgal-3.3.1.ebuild:
+ Initial import. Closing bug #167944.
+
diff --git a/sci-mathematics/cgal/Manifest b/sci-mathematics/cgal/Manifest
new file mode 100644
index 000000000000..660823fc108e
--- /dev/null
+++ b/sci-mathematics/cgal/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX cgal-3.3.1-qt.patch 2029 RMD160 340035482282e118b72adfdd45945b82bc951175 SHA1 3b19e7d0d3ef92526ecc54daa6a5676a9ca9cf9a SHA256 9177a289eddd4356f79baecb19e20c126462c585314ee67512eb116accf32f94
+AUX cgal-3.3.1-rpath.patch 5043 RMD160 3eae61377d17487576ffb06b7ba3928ac5e1358f SHA1 8b241d9523bb464c0ac774a50ef878872135a7a4 SHA256 d9559cf91ca90dad8cb4a4b13f0b624da84205ae563fb10a9f471d43a4d20d49
+DIST CGAL-3.3.1.tar.gz 8593200 RMD160 e2c2e785a7c61bc9b651903df539bb00ce689b07 SHA1 b17b12fdf106003e1257e1465b0ba1d17e6cefb9 SHA256 c6e4e5a284ccb07b38321cd265f07a0cb8eaa4df67efb7f40f70a311cae00d37
+EBUILD cgal-3.3.1.ebuild 2817 RMD160 837cb79d49695b61277f2f01eed5052ca09ed69c SHA1 f84973140f9af709763ecfc17e5a72df39ae34f3 SHA256 e54bd1db9d433febc3911a42991f81cacd2e21ded65bc4dbc8cbe51b214c2d1f
+MISC ChangeLog 435 RMD160 dfc5857c203316466c1daeaea1a8802f12ef9370 SHA1 493f5ca745ce8131657c037bc4f7f4b74554a28e SHA256 ceff053e0db4092f2805893c5334eb17f544d94006b53d85476c32a7a6edebe0
+MISC metadata.xml 1025 RMD160 da14e8b7ef6f3ce0aa192b47bbd509a66b5c07af SHA1 449624b3734ca4c2b5da1e3018536d8fe8580b5e SHA256 29cf5a72c2119df2fbb5b0ca0bb8f3abd1779e8b0ac31e99408cc0895ade515b
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkkF24wACgkQ1ycZbhPLE2DRRwCcD0+ZmhLAolu5Ji6GnYKHJwnk
+RyYAnRv2F4Uh8fGPBbwnLCQlEhvUWL0p
+=ehWP
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/cgal/cgal-3.3.1.ebuild b/sci-mathematics/cgal/cgal-3.3.1.ebuild
new file mode 100644
index 000000000000..5af0a6ca625d
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-3.3.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.3.1.ebuild,v 1.1 2008/10/27 15:17:24 bicatali Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MYP=CGAL-${PV}
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="http://www.cgal.org/"
+SRC_URI="ftp://ftp.mpi-sb.mpg.de/pub/outgoing/CGAL/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1 QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples gmp lapack opengl qt3 taucs X zlib"
+
+RDEPEND="dev-libs/boost
+ dev-libs/mpfr
+ gmp? ( dev-libs/gmp )
+ lapack? ( virtual/lapack )
+ opengl? ( virtual/opengl )
+ qt3? ( x11-libs/qt:3 )
+ taucs? ( sci-libs/taucs )
+ X? ( x11-libs/libX11 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ lapack? ( dev-util/pkgconfig )"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rpath.patch
+ # a patch from debian on missing qt headers
+ epatch "${FILESDIR}"/${P}-qt.patch
+ # sed for blas and lapack gentoo style
+ sed -e 's/Intel MKL/Gentoo BLAS-LAPACK/' \
+ -e "s/^LIBS.=.*/LIBS=$(pkg-config --libs-only-l lapack | sed 's/-l//g')/" \
+ -e "s/^STDLIBDIRS.=*/STDLIBDIRS=$(pkg-config --libs-only-L lapack | sed 's/-L//g')/" \
+ config/support/S48a-MKL64 \
+ > config/support/S48e-GENTOOLAPACK || die
+ sed -i -e 's/-O2//' install_cgal || die
+}
+
+src_configure() {
+ CGALDIR="${S}/usr"
+ MYCONF="-ni
+ --prefix=${CGALDIR}
+ --cxx=$(tc-getCXX)
+ --without-autofind
+ --with-boost
+ --with-boost_program_options
+ --with-mpfr"
+
+ use gmp && MYCONF="${MYCONF} --with-gmp --with-gmpxx"
+ use lapack && MYCONF="${MYCONF} --with-gentoolapack"
+ use opengl && MYCONF="${MYCONF} --with-opengl"
+ use taucs && MYCONF="${MYCONF} --with-gentoolapack --with-taucslapack"
+ use X && MYCONF="${MYCONF} --with-x11"
+ use zlib && MYCONF="${MYCONF} --with-zlib"
+ use qt3 && MYCONF="${MYCONF} --with-qt3mt --qt_incl_dir ${QTDIR}/include --qt_lib_dir ${QTDIR}/lib"
+}
+
+src_compile() {
+ ./install_cgal ${MYCONF} || die "compilation failed"
+ grep -q failed compile.log && die "see ${S}/compile.log for problems"
+}
+
+src_test() {
+ cd "${S}"/examples
+ export CGAL_MAKEFILE="${CGALDIR}/share/cgal/cgal.mk"
+ emake || die "emake examples failed"
+ # basic testing, does not compare with original
+ for t in */*.cpp; do
+ local run_testt=${t%.cpp}
+ if [[ -x ${run_test} ]]; then
+ ${run_test} || die "Running test from ${t} failed"
+ fi
+ done
+}
+
+src_install(){
+ mv usr/lib usr/$(get_libdir)
+ sed -i \
+ -e "s:${CGALDIR}:/usr:g" \
+ "${CGALDIR}/share/cgal/cgal.mk" || die "sed cgal.mk failed"
+ cp -pPR usr "${D}" || die "install failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demo examples || die "samples install failed"
+ fi
+ echo "CGAL_MAKEFILE=/usr/share/cgal/cgal.mk" > 99cgal
+ doenvd 99cgal || die
+}
diff --git a/sci-mathematics/cgal/files/cgal-3.3.1-qt.patch b/sci-mathematics/cgal/files/cgal-3.3.1-qt.patch
new file mode 100644
index 000000000000..406c025bcf78
--- /dev/null
+++ b/sci-mathematics/cgal/files/cgal-3.3.1-qt.patch
@@ -0,0 +1,71 @@
+--- config/support/test_QT.cpp.orig 2007-08-25 21:01:03.000000000 +0200
++++ config/support/test_QT.cpp 2008-02-06 18:34:06.000000000 +0100
+@@ -25,7 +25,7 @@
+
+ #include <iostream>
+ #include <qglobal.h>
+-#include <qarray.h>
++#include <qmemarray.h>
+
+ QArray<int> fib( int num ) // returns fibonacci array
+ {
+--- demo/Apollonius_graph_2/qt_file_toolbar.h.orig 2007-08-25 21:00:54.000000000 +0200
++++ demo/Apollonius_graph_2/qt_file_toolbar.h 2008-02-06 18:34:51.000000000 +0100
+@@ -21,7 +21,7 @@
+ #define QT_FILE_TOOLBAR_H
+
+ // include files for QT
+-#include <qapp.h>
++#include <qapplication.h>
+ #include <qmainwindow.h>
+ #include <qaction.h>
+ #include <qmenubar.h>
+@@ -32,7 +32,7 @@
+ #include <qwhatsthis.h>
+ #include <qstring.h>
+ #include <qpixmap.h>
+-#include <qmsgbox.h>
++#include <qmessagebox.h>
+ #include <qfiledialog.h>
+ #include <qprinter.h>
+ #include <qpainter.h>
+--- demo/Segment_Delaunay_graph_2/qt_file_toolbar.h.orig 2007-08-25 21:01:03.000000000 +0200
++++ demo/Segment_Delaunay_graph_2/qt_file_toolbar.h 2008-02-06 18:35:06.000000000 +0100
+@@ -21,7 +21,7 @@
+ #define QT_FILE_TOOLBAR_H
+
+ // include files for QT
+-#include <qapp.h>
++#include <qapplication.h>
+ #include <qmainwindow.h>
+ #include <qaction.h>
+ #include <qmenubar.h>
+@@ -32,7 +32,7 @@
+ #include <qwhatsthis.h>
+ #include <qstring.h>
+ #include <qpixmap.h>
+-#include <qmsgbox.h>
++#include <qmessagebox.h>
+ #include <qfiledialog.h>
+ #include <qprinter.h>
+ #include <qpainter.h>
+--- demo/Voronoi_diagram_2/qt_file_toolbar.h.orig 2007-08-25 21:00:21.000000000 +0200
++++ demo/Voronoi_diagram_2/qt_file_toolbar.h 2008-02-06 18:34:36.000000000 +0100
+@@ -21,7 +21,7 @@
+ #define QT_FILE_TOOLBAR_H
+
+ // include files for QT
+-#include <qapp.h>
++#include <qapplication.h>
+ #include <qmainwindow.h>
+ #include <qaction.h>
+ #include <qmenubar.h>
+@@ -32,7 +32,7 @@
+ #include <qwhatsthis.h>
+ #include <qstring.h>
+ #include <qpixmap.h>
+-#include <qmsgbox.h>
++#include <qmessagebox.h>
+ #include <qfiledialog.h>
+ #include <qprinter.h>
+ #include <qpainter.h>
diff --git a/sci-mathematics/cgal/files/cgal-3.3.1-rpath.patch b/sci-mathematics/cgal/files/cgal-3.3.1-rpath.patch
new file mode 100644
index 000000000000..b104c678e0a6
--- /dev/null
+++ b/sci-mathematics/cgal/files/cgal-3.3.1-rpath.patch
@@ -0,0 +1,116 @@
+diff -urNad cgal-3.3.1~/install_cgal cgal-3.3.1/install_cgal
+--- cgal-3.3.1~/install_cgal 2008-04-16 19:37:23.000000000 +0200
++++ cgal-3.3.1/install_cgal 2008-04-16 19:37:25.000000000 +0200
+@@ -836,7 +836,7 @@
+ CGAL_SHARED_LIB_SONAME=""
+ CGAL_SHARED_LIBNAME_WITH_SOVERSION="\$(CGAL_SHARED_LIBNAME)"
+ CGAL_SHARED_LIBNAME_WITH_SOMAJOR="\$(CGAL_SHARED_LIBNAME)"
+- RUNTIME_LINKER_FLAG=''
++# RUNTIME_LINKER_FLAG=''
+ PRINT_STACKTRACE_PROGRAM="gdb"
+ WINDOWS_COMPILER=""
+ CYGWIN_COMPILER=""
+@@ -937,7 +937,7 @@
+ #### settings for sgi mipspro compiler on irix5
+ CGAL_SHARED_LIB_CXXFLAGS=
+ CGAL_SHARED_LIB_LDFLAGS="-lm"
+- RUNTIME_LINKER_FLAG="-rpath "
++# RUNTIME_LINKER_FLAG="-rpath "
+ PRINT_STACKTRACE_PROGRAM="dbx"
+ ;;
+ *IRIX*6.*CC*7.3*)
+@@ -946,14 +946,14 @@
+ ADDITIONAL_LDFLAGS="-LANG:std"
+ CGAL_STATIC_LIB_CREATE="\$(CGAL_CXX) -ar -o''"
+ CGAL_SHARED_LIB_CXXFLAGS=
+- RUNTIME_LINKER_FLAG="-rpath "
++# RUNTIME_LINKER_FLAG="-rpath "
+ PRINT_STACKTRACE_PROGRAM="dbx"
+ ;;
+ *IRIX*6.*CC*)
+ #### settings for sgi mipspro compiler on irix6
+ CGAL_STATIC_LIB_CREATE="\$(CGAL_CXX) -ar -o''"
+ CGAL_SHARED_LIB_CXXFLAGS=
+- RUNTIME_LINKER_FLAG="-rpath "
++# RUNTIME_LINKER_FLAG="-rpath "
+ PRINT_STACKTRACE_PROGRAM="dbx"
+ ;;
+ *IRIX*g++*)
+@@ -961,7 +961,7 @@
+ ADDITIONAL_CXXFLAGS="-Wall"
+ LONG_NAME_PROBLEM_LDFLAGS="-U -s"
+ CGAL_SHARED_LIB_LDFLAGS="-lm"
+- RUNTIME_LINKER_FLAG="-Xlinker -rpath -Xlinker "
++# RUNTIME_LINKER_FLAG="-Xlinker -rpath -Xlinker "
+ CGAL_SHARED_LIB_SONAME="-Wl,-soname,\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+ CGAL_SHARED_LIBNAME_WITH_SOVERSION="\$(CGAL_SHARED_LIBNAME).\$(SOVERSION)"
+ CGAL_SHARED_LIBNAME_WITH_SOMAJOR="\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+@@ -973,7 +973,7 @@
+ CGAL_STATIC_LIB_CREATE="\$(CGAL_CXX) -xar -o ''"
+ CGAL_SHARED_LIB_CXXFLAGS="-PIC"
+ CGAL_SHARED_LIB_CREATE="\$(CGAL_CXX) -G"
+- RUNTIME_LINKER_FLAG="-R "
++# RUNTIME_LINKER_FLAG="-R "
+ PRINT_STACKTRACE_PROGRAM="dbx"
+ CGAL_SHARED_LIB_SONAME="-Qoption ld -h\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+ CGAL_SHARED_LIBNAME_WITH_SOVERSION="\$(CGAL_SHARED_LIBNAME).\$(SOVERSION)"
+@@ -986,7 +986,7 @@
+ LONG_NAME_PROBLEM_CXXFLAGS="-g"
+ LONG_NAME_PROBLEM_LDFLAGS="-z nodefs -s"
+ CGAL_SHARED_LIB_CREATE="\$(CGAL_CXX) -G"
+- RUNTIME_LINKER_FLAG="-R "
++# RUNTIME_LINKER_FLAG="-R "
+ CGAL_SHARED_LIB_SONAME="-h \$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+ CGAL_SHARED_LIBNAME_WITH_SOVERSION="\$(CGAL_SHARED_LIBNAME).\$(SOVERSION)"
+ CGAL_SHARED_LIBNAME_WITH_SOMAJOR="\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+@@ -995,7 +995,7 @@
+ #### settings for g++ on alpha-linux (special FPU handling)
+ #### LONG_NAME_PROBLEM is cured by disabling debugging
+ ADDITIONAL_CXXFLAGS="-Wall -mieee -mfp-rounding-mode=d"
+- RUNTIME_LINKER_FLAG='-Wl,-R'
++# RUNTIME_LINKER_FLAG='-Wl,-R'
+ CGAL_SHARED_LIB_SONAME="-Wl,-soname,\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+ CGAL_SHARED_LIBNAME_WITH_SOVERSION="\$(CGAL_SHARED_LIBNAME).\$(SOVERSION)"
+ CGAL_SHARED_LIBNAME_WITH_SOMAJOR="\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+@@ -1003,7 +1003,7 @@
+ *Linux*g++*)
+ #### settings for g++ on linux
+ ADDITIONAL_CXXFLAGS="-Wall"
+- RUNTIME_LINKER_FLAG='-Wl,-R'
++# RUNTIME_LINKER_FLAG='-Wl,-R'
+ CGAL_SHARED_LIB_SONAME="-Wl,-soname,\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+ CGAL_SHARED_LIBNAME_WITH_SOVERSION="\$(CGAL_SHARED_LIBNAME).\$(SOVERSION)"
+ CGAL_SHARED_LIBNAME_WITH_SOMAJOR="\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+@@ -1013,12 +1013,12 @@
+ # -mp is required for correct enough floating point operations
+ # necessary for interval arithmetic.
+ ADDITIONAL_CXXFLAGS="-mp"
+- RUNTIME_LINKER_FLAG='-Wl,-R'
++# RUNTIME_LINKER_FLAG='-Wl,-R'
+ PRINT_STACKTRACE_PROGRAM="idb"
+ ;;
+ *Linux*pgCC*|*Linux*pgcpp*)
+ #### settings for Portland Group Compiler on linux
+- RUNTIME_LINKER_FLAG='-Wl,-R'
++# RUNTIME_LINKER_FLAG='-Wl,-R'
+ # PGCC has long name problems with "-g".
+ DEBUG_OPT=""
+ ;;
+@@ -1029,7 +1029,7 @@
+ CGAL_STATIC_LIB_CREATE="\$(CGAL_CXX) -xar -o ''"
+ CGAL_SHARED_LIB_CXXFLAGS="-PIC"
+ CGAL_SHARED_LIB_CREATE="\$(CGAL_CXX) -G"
+- RUNTIME_LINKER_FLAG="-R "
++# RUNTIME_LINKER_FLAG="-R "
+ PRINT_STACKTRACE_PROGRAM="dbx"
+ CGAL_SHARED_LIB_SONAME="-Qoption ld -h\$(CGAL_SHARED_LIBNAME).\$(SOMAJOR)"
+ CGAL_SHARED_LIBNAME_WITH_SOVERSION="\$(CGAL_SHARED_LIBNAME).\$(SOVERSION)"
+@@ -4335,7 +4335,7 @@
+ _buildlog_marker="log for $1 $2 shown"
+
+ ${_printf} "%s %s\n" "${MAKE}" "${MAKE_OPTION}" > "${COMPILE_LOGFILE}"
+- if ${MAKE} ${MAKE_OPTION} >"${COMPILE_LOGFILE}" 2>&1; then
++ if ${MAKE} ${MAKE_OPTION} | tee "${COMPILE_LOGFILE}" 2>&1; then
+ log_print "Compilation of $1 $2 ${_libname} succeeded."
+ log_print "vvvvvvvvvvvv build ${_buildlog_marker} below vvvvvvvvvvvv"
+ eval ${_cat} \"${COMPILE_LOGFILE}\" ${INSTALL_LOGFILE_REDIRECTION}
diff --git a/sci-mathematics/cgal/metadata.xml b/sci-mathematics/cgal/metadata.xml
new file mode 100644
index 000000000000..4eaba7502dc9
--- /dev/null
+++ b/sci-mathematics/cgal/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The Computational Geometry Algorithms Library is a collaborative
+ open source library containing:
+ * the Kernel with geometric primitives such as points, vectors,
+ lines, predicates for testing things such as relative positions of
+ points, and operations such as intersections and distance calculation.
+ * the Basic Library which is a collection of standard data
+ structures and geometric algorithms, such as convex hull in 2D/3D,
+ (Delaunay) triangulation in 2D/3D, planar map, polyhedron, smallest
+ enclosing circle, and multidimensional query structures.
+ * the Support Library which offers interfaces to other packages,
+ e.g., for visualisation, and I/O, and other support facilities.
+</longdescription>
+<use>
+ <flag name='taucs'>Add support for the sparse solver library <pkg>sci-libs/taucs</pkg></flag>
+</use>
+</pkgmetadata>