summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-18 20:40:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-18 20:40:03 +0000
commit4b331479bf8fc901a45b351a2d3f876feed7163f (patch)
tree93bba2588269e512142f43e95cc20ef638dd361c /sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild
parentInitial addition (diff)
downloadhistorical-4b331479bf8fc901a45b351a2d3f876feed7163f.tar.gz
historical-4b331479bf8fc901a45b351a2d3f876feed7163f.tar.bz2
historical-4b331479bf8fc901a45b351a2d3f876feed7163f.zip
Initial addition, #250415
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild')
-rw-r--r--sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild b/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild
new file mode 100644
index 000000000000..65ef698a2138
--- /dev/null
+++ b/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild,v 1.1 2010/05/18 20:40:03 jlec Exp $
+
+EAPI="2"
+
+inherit flag-o-matic fortran
+
+DESCRIPTION="Fragment library for rosetta"
+HOMEPAGE="www.rosettacommons.org"
+SRC_URI="rosetta3.1_fragments.tgz"
+
+LICENSE="rosetta"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+RDEPEND="
+ sci-biology/ncbi-tools
+ sci-biology/ncbi-tools++
+ sci-biology/psipred"
+
+S="${WORKDIR}"/${PN/-/_}
+
+FORTRAN="g77 gfortran ifc"
+
+pkg_nofetch() {
+ einfo "Go to ${HOMEPAGE} and get ${PN}.tgz and rename it to ${A}"
+ einfo "which must be placed in ${DISTDIR}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-nnmake.patch
+ epatch "${FILESDIR}"/${PV}-chemshift.patch
+}
+
+src_compile() {
+ append-fflags -ffixed-line-length-132
+
+ cd "${S}"/nnmake && \
+ emake || die
+
+ cd "${S}"/chemshift && \
+ emake || die
+}
+
+src_install() {
+ find . -type d -name ".svn" -exec rm -rf '{}' \; 2> /dev/null
+
+ newbin nnmake/pNNMAKE.gnu pNNMAKE && \
+ newbin chemshift/pCHEMSHIFT.gnu pCHEMSHIFT || \
+ die "failed to install the bins"
+
+ dobin nnmake/*.pl || die "no additional perl scripts"
+
+ insinto /usr/share/${PN}
+ doins -r *_database || die
+ dodoc fragments.README nnmake/{nnmake.README,vall/*.pl} chemshift/chemshift.README || die "no docs"
+}