summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-03 14:52:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-03 14:52:53 +0000
commit71e855cde383e1e2f1e2c5cb9a986cb5897dcba4 (patch)
treeee8271a536ec4bc7faff889b16fc6c617bd3546f /sci-libs/libticalcs2
parentMake kdepim-meta optional since it requires mysql. Forcing due to the ppc fla... (diff)
downloadhistorical-71e855cde383e1e2f1e2c5cb9a986cb5897dcba4.tar.gz
historical-71e855cde383e1e2f1e2c5cb9a986cb5897dcba4.tar.bz2
historical-71e855cde383e1e2f1e2c5cb9a986cb5897dcba4.zip
Initial import from sunrise, thanks to Christian Helbling and all contributors in bug #146028
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/libticalcs2')
-rw-r--r--sci-libs/libticalcs2/ChangeLog39
-rw-r--r--sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch11
-rw-r--r--sci-libs/libticalcs2/libticalcs2-1.1.0.ebuild44
-rw-r--r--sci-libs/libticalcs2/metadata.xml12
4 files changed, 106 insertions, 0 deletions
diff --git a/sci-libs/libticalcs2/ChangeLog b/sci-libs/libticalcs2/ChangeLog
new file mode 100644
index 000000000000..1dc91d7d6f3f
--- /dev/null
+++ b/sci-libs/libticalcs2/ChangeLog
@@ -0,0 +1,39 @@
+# ChangeLog for sci-libs/libticalcs2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticalcs2/ChangeLog,v 1.1 2009/02/03 14:49:43 bicatali Exp $
+
+*libticalcs2-1.1.0 (03 Feb 2009)
+
+ 03 Feb 2009; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +files/libticalcs2-1.1.0-locale.patch, +metadata.xml,
+ +libticalcs2-1.1.0.ebuild:
+ Initial import from sunrise, thanks to Christian Helbling and all
+ contributors in bug #146028
+
+ 15 Jan 2008; Christian Helbling <helch@gmx.ch> -libticalcs2-1.0.7.ebuild,
+ +libticalcs2-1.1.0.ebuild:
+ Version bump
+
+ 22 Sep 2007; Christian Helbling <helch@gmx.ch> -libticalcs2-1.0.6.ebuild,
+ +libticalcs2-1.0.7.ebuild:
+ version bump
+
+ 30 Jun 2007; Jakub Moc <jakub@gentoo.org> libticalcs2-1.0.6.ebuild:
+ Fix up gettext dependencies
+
+ 15 Jun 2007; Christian Helbling <helch@gmx.ch> +libticalcs2-1.0.6.ebuild,
+ -libticalcs2-20061030.ebuild:
+ Version bump. Better version numbers.
+
+ 04 Dec 2006; Markus Ullmann <jokey@gentoo.org>
+ -libticalcs2-20060723.ebuild:
+ Remove old
+
+ 02 Dec 2006; Christian Helbling <helch@gmx.ch>
+ +libticalcs2-20061030.ebuild:
+ Version bump
+
+ 04 Sep 2006; Christian Helbling <helch@gmx.ch>
+ +libticalcs2-20060723.ebuild, +metadata.xml:
+ New ebuild for bug 146028
+
diff --git a/sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch b/sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch
new file mode 100644
index 000000000000..4602dfdba3da
--- /dev/null
+++ b/sci-libs/libticalcs2/files/libticalcs2-1.1.0-locale.patch
@@ -0,0 +1,11 @@
+--- src/gettext.h~ 2007-02-23 16:05:21.000000000 +0000
++++ src/gettext.h 2009-02-03 12:41:31.584312058 +0000
+@@ -24,7 +24,7 @@
+
+ /* Get declarations of GNU message catalog functions. */
+ # include <libintl.h>
+-
++# include <locale.h>
+ #else
+
+ /* Solaris /usr/include/locale.h includes /usr/include/libintl.h, which
diff --git a/sci-libs/libticalcs2/libticalcs2-1.1.0.ebuild b/sci-libs/libticalcs2/libticalcs2-1.1.0.ebuild
new file mode 100644
index 000000000000..01d83c435703
--- /dev/null
+++ b/sci-libs/libticalcs2/libticalcs2-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticalcs2/libticalcs2-1.1.0.ebuild,v 1.1 2009/02/03 14:49:43 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Library for communication with TI calculators"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/gtktiemu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls threads"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ >=sci-libs/libticables2-1.2.0
+ >=sci-libs/libticonv-1.1.0
+ >=sci-libs/libtifiles2-1.1.0
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS LOGO NEWS README ChangeLog docs/api.txt
+ if use doc; then
+ dohtml docs/html/*
+ fi
+}
diff --git a/sci-libs/libticalcs2/metadata.xml b/sci-libs/libticalcs2/metadata.xml
new file mode 100644
index 000000000000..f5c1e171a28b
--- /dev/null
+++ b/sci-libs/libticalcs2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The libticalcs provides a set of functions to communicate with Texas
+ Instruments calculators. It implements the TI protocol for each type
+ of calculator, independently of the link cable used to establish the
+ link.
+ All graphing calculators from Texas Instruments are supported
+</longdescription>
+</pkgmetadata>