summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-11-06 19:57:04 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-11-06 19:57:04 +0000
commit519732ce144369dafb11ac3da7e8d89cc0d9e065 (patch)
tree8e112816a6a87dca4045f24036813fc45db4453e /sci-libs/hdf5/files
parentStable for amd64, wrt bug #442044 (diff)
downloadhistorical-519732ce144369dafb11ac3da7e8d89cc0d9e065.tar.gz
historical-519732ce144369dafb11ac3da7e8d89cc0d9e065.tar.bz2
historical-519732ce144369dafb11ac3da7e8d89cc0d9e065.zip
Version bump
Package-Manager: portage-2.2.0_alpha138/cvs/Linux x86_64 Manifest-Sign-Key: 0x5D21B852895192F9
Diffstat (limited to 'sci-libs/hdf5/files')
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch33
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch54
2 files changed, 87 insertions, 0 deletions
diff --git a/sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch b/sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch
new file mode 100644
index 000000000000..58bcc500165f
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.10-buildsystem.patch
@@ -0,0 +1,33 @@
+Prevent build system with messing up LD_LIBRARY_PATH
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -2331,8 +2331,6 @@ AC_TRY_COMPILE(,[
+ ##
+ AC_MSG_CHECKING([how to print long long])
+ AC_CACHE_VAL([hdf5_cv_printf_ll], [
+-LD_LIBRARY_PATH="$LD_LIBRARY_PATH`echo $AM_LDFLAGS $LDFLAGS | sed -e 's/-L/:/g' -e 's/ //g'`"
+-export LD_LIBRARY_PATH
+
+ for hdf5_cv_printf_ll in l ll L q unknown; do
+ AC_TRY_RUN([
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -125,8 +125,6 @@ settings_DATA=libhdf5.settings
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5Tinit.c: H5detect$(EXEEXT)
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
+@@ -137,8 +135,6 @@ H5Tinit.c: H5detect$(EXEEXT)
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
diff --git a/sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch
new file mode 100644
index 000000000000..a0b59b74e703
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.10-implicits.patch
@@ -0,0 +1,54 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1494,6 +1494,9 @@ case "$host_cpu-$host_vendor-$host_os" in
+ ## however, we do not do this since it breaks the big test on some
+ ## older platforms.
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ dnl _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
+--- a/hl/src/H5LTanalyze.c
++++ b/hl/src/H5LTanalyze.c
+@@ -49,6 +49,7 @@
+ #define YY_FLEX_MINOR_VERSION 5
+
+ #include <stdio.h>
++#include "H5pubconf.h"
+ #ifdef H5_HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+--- a/test/cache_common.h
++++ b/test/cache_common.h
+@@ -702,5 +702,9 @@ void validate_mdc_config(hid_t file_id,
+ hbool_t compare_init,
+ int test_num);
+
++hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
++ const H5C_auto_size_ctl_t *b,
++ hbool_t compare_init);
++
+ #endif /* _CACHE_COMMON_H */
+
+--- a/tools/h5repack/testh5repack_detect_szip.c
++++ b/tools/h5repack/testh5repack_detect_szip.c
+@@ -18,6 +18,7 @@
+ #include "h5tools.h"
+ #include "h5tools_utils.h"
+ #include "h5test.h"
++#include "h5tools_utils.h"
+
+
+ /* Name of tool */
+--- a/tools/misc/talign.c
++++ b/tools/misc/talign.c
+@@ -23,6 +23,7 @@
+
+ #include "hdf5.h"
+ #include "H5private.h"
++#include "h5tools.h"
+
+ const char *fname = "talign.h5";
+ const char *setname = "align";