summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-27 11:36:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-27 11:36:57 +0000
commitcc6d710cc74db8b594e0dce258f472a338267fab (patch)
tree1ba31c3773f452940785f2e3496a042932b6dc84 /sci-libs/geos/geos-3.0.3.ebuild
parentFix manifest for 2.6.27.7 distfile. (diff)
downloadhistorical-cc6d710cc74db8b594e0dce258f472a338267fab.tar.gz
historical-cc6d710cc74db8b594e0dce258f472a338267fab.tar.bz2
historical-cc6d710cc74db8b594e0dce258f472a338267fab.zip
Version bump
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'sci-libs/geos/geos-3.0.3.ebuild')
-rw-r--r--sci-libs/geos/geos-3.0.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-3.0.3.ebuild b/sci-libs/geos/geos-3.0.3.ebuild
new file mode 100644
index 000000000000..f999c036970c
--- /dev/null
+++ b/sci-libs/geos/geos-3.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.0.3.ebuild,v 1.1 2008/11/27 11:36:57 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc python ruby"
+
+RDEPEND="ruby? ( virtual/ruby )
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )\
+ ruby? ( >=dev-lang/swig-1.3.29 )
+ python? ( >=dev-lang/swig-1.3.29 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-test.patch
+}
+
+src_compile() {
+ local myconf
+
+ if ! use python && ! use ruby ; then
+ myconf="--disable-swig"
+ fi
+
+ econf ${myconf} \
+ $(use_enable python) \
+ $(use_enable ruby)
+ emake || die "emake failed"
+ if use doc; then
+ cd "${S}/doc"
+ emake doxygen-html || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO || die
+ if use doc; then
+ cd "${S}/doc"
+ dohtml -r doxygen_docs/html/* || die
+ fi
+}