summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:44:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:44:59 +0000
commit20ffc322b14b8241148e75185fb47ba101fc6fa8 (patch)
treed2041fa63bbcbe0320e1eff92f6ddaf6d3a33104 /sci-libs/csparse
parentstable x86, bug 208997 (diff)
downloadhistorical-20ffc322b14b8241148e75185fb47ba101fc6fa8.tar.gz
historical-20ffc322b14b8241148e75185fb47ba101fc6fa8.tar.bz2
historical-20ffc322b14b8241148e75185fb47ba101fc6fa8.zip
Initial import, part of the suitesparse
Package-Manager: portage-2.1.4
Diffstat (limited to 'sci-libs/csparse')
-rw-r--r--sci-libs/csparse/ChangeLog11
-rw-r--r--sci-libs/csparse/Manifest5
-rw-r--r--sci-libs/csparse/csparse-2.2.1.ebuild30
-rw-r--r--sci-libs/csparse/files/csparse-2.2.1-autotools.patch59
-rw-r--r--sci-libs/csparse/metadata.xml13
5 files changed, 118 insertions, 0 deletions
diff --git a/sci-libs/csparse/ChangeLog b/sci-libs/csparse/ChangeLog
new file mode 100644
index 000000000000..90bf19cad48c
--- /dev/null
+++ b/sci-libs/csparse/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/csparse
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/ChangeLog,v 1.1 2008/02/05 18:44:59 bicatali Exp $
+
+*csparse-2.2.1 (05 Feb 2008)
+
+ 05 Feb 2008; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +files/csparse-2.2.1-autotools.patch, +metadata.xml,
+ +csparse-2.2.1.ebuild:
+ Initial import, part of the suitesparse
+
diff --git a/sci-libs/csparse/Manifest b/sci-libs/csparse/Manifest
new file mode 100644
index 000000000000..476cc5b4563a
--- /dev/null
+++ b/sci-libs/csparse/Manifest
@@ -0,0 +1,5 @@
+AUX csparse-2.2.1-autotools.patch 2262 RMD160 1cf4cfa1ce55946498d0d0ed6070093994856442 SHA1 0279b5c77c7f0ccb54e1ff2b0192a701eeb7c13f SHA256 8deecba19fe66a964841cc24dcfa89896019c58c2fd5ab965b40e5646f6629b3
+DIST CSparse-2.2.1.tar.gz 1365607 RMD160 17982a35c481235e67b669400c039acc39f4ecbe SHA1 731c062a8e804f7a1d2ccb666f9a436ba6f0cc83 SHA256 75aa04437444f2a829743c57387079641e7aa2ac107dc3e89673d76b3c15b77f
+EBUILD csparse-2.2.1.ebuild 681 RMD160 ce18c0761b3048e81fa331e82677663dc42c06ba SHA1 b655e8419f0b1acd063c3f8834e5b0402f268b39 SHA256 3e5086fa12fdcd6f1672cb0cb6dce0fa2382b6333881f95a04a03f585c188d00
+MISC ChangeLog 325 RMD160 d0839dca88e4753b30f3522dde8201b793ecb69d SHA1 bfb8fe14f86b5d53c2d6c893bc72121052b1370a SHA256 2f248c53de5cae562cccd1781fab49616575d542360406a808dc06491262d812
+MISC metadata.xml 562 RMD160 d5bcb502069ef1fb8c018ddbb1a8ed2c054d2d36 SHA1 0df820628b5fa2b495e1c819a3295e655c8f02f4 SHA256 d19953c777c3646e149790954a1858494b9874f83b0d3b5ab447820e54e70308
diff --git a/sci-libs/csparse/csparse-2.2.1.ebuild b/sci-libs/csparse/csparse-2.2.1.ebuild
new file mode 100644
index 000000000000..5e846e9af952
--- /dev/null
+++ b/sci-libs/csparse/csparse-2.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/csparse-2.2.1.ebuild,v 1.1 2008/02/05 18:44:59 bicatali Exp $
+
+inherit autotools eutils
+
+MY_PN=CSparse
+DESCRIPTION="Concise sparse matrix package."
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CSparse"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/versions/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+}
diff --git a/sci-libs/csparse/files/csparse-2.2.1-autotools.patch b/sci-libs/csparse/files/csparse-2.2.1-autotools.patch
new file mode 100644
index 000000000000..3f96170cfa6e
--- /dev/null
+++ b/sci-libs/csparse/files/csparse-2.2.1-autotools.patch
@@ -0,0 +1,59 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-30 18:34:40.659910749 +0000
+@@ -0,0 +1,10 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(csparse, 2.2.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([Makefile Source/Makefile Demo/Makefile])
++AC_OUTPUT
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-30 18:35:32.154594734 +0000
+@@ -0,0 +1,4 @@
++SUBDIRS = Source Demo
++EXTRA_DIST = README.txt
++include_HEADERS = Include/cs.h
++
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-30 18:45:50.337822988 +0000
+@@ -0,0 +1,12 @@
++AM_CPPFLAGS = -I$(top_builddir)/Include
++lib_LTLIBRARIES = libcsparse.la
++libcsparse_la_SOURCES = \
++ cs_add.c cs_amd.c cs_chol.c cs_cholsol.c cs_counts.c cs_cumsum.c \
++ cs_droptol.c cs_dropzeros.c cs_dupl.c cs_entry.c \
++ cs_etree.c cs_fkeep.c cs_gaxpy.c cs_happly.c cs_house.c cs_ipvec.c \
++ cs_lsolve.c cs_ltsolve.c cs_lu.c cs_lusol.c cs_util.c cs_multiply.c \
++ cs_permute.c cs_pinv.c cs_post.c cs_pvec.c cs_qr.c cs_qrsol.c \
++ cs_scatter.c cs_schol.c cs_sqr.c cs_symperm.c cs_tdfs.c cs_malloc.c \
++ cs_transpose.c cs_compress.c cs_usolve.c cs_utsolve.c cs_scc.c \
++ cs_maxtrans.c cs_dmperm.c cs_updown.c cs_print.c cs_norm.c cs_load.c \
++ cs_dfs.c cs_reach.c cs_spsolve.c cs_ereach.c cs_leaf.c cs_randperm.c
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-31 11:11:28.880545257 +0000
+@@ -0,0 +1,21 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++LDADD = $(top_builddir)/Source/libcsparse.la -lm
++
++check_PROGRAMS = cs_demo1 cs_demo2 cs_demo3
++
++check-local: $(check_PROGRAMS)
++ - ./cs_demo1 < ../Matrix/t1
++ - ./cs_demo2 < ../Matrix/t1
++ - ./cs_demo2 < ../Matrix/ash219
++ - ./cs_demo2 < ../Matrix/bcsstk01
++ - ./cs_demo2 < ../Matrix/fs_183_1
++ - ./cs_demo2 < ../Matrix/mbeacxc
++ - ./cs_demo2 < ../Matrix/west0067
++ - ./cs_demo2 < ../Matrix/lp_afiro
++ - ./cs_demo2 < ../Matrix/bcsstk16
++ - ./cs_demo3 < ../Matrix/bcsstk01
++ - ./cs_demo3 < ../Matrix/bcsstk16
++
++cs_demo1_SOURCE = cs_demo1.c
++cs_demo2_SOURCES= cs_demo2.c cs_demo.c cs_demo.h
++cs_demo3_SOURCES = cs_demo3.c cs_demo.c cs_demo.h
diff --git a/sci-libs/csparse/metadata.xml b/sci-libs/csparse/metadata.xml
new file mode 100644
index 000000000000..00a4db0786ad
--- /dev/null
+++ b/sci-libs/csparse/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ CSparse a small yet feature-rich sparse matrix package written
+ specifically for the book "Direct Methods for Sparse Linear Systems".
+ The purpose of the package is to demonstrate a wide range of sparse
+ matrix algorithms in as concise a code as possible. Note that the LU
+ and Cholesky factorization algorithms are not as fast as UMFPACK or
+ CHOLMOD.
+</longdescription>
+</pkgmetadata>