summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-18 14:50:12 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-18 14:50:12 +0000
commitd98681c2ba2f5e9cffeb251b9304896639bd2316 (patch)
treead288c6095d2ecab42c5d11af4d642bd0be306c0 /sci-chemistry
parentVersion bump (bug #285241), also change metadata.xml, i take over proxy-maint... (diff)
downloadhistorical-d98681c2ba2f5e9cffeb251b9304896639bd2316.tar.gz
historical-d98681c2ba2f5e9cffeb251b9304896639bd2316.tar.bz2
historical-d98681c2ba2f5e9cffeb251b9304896639bd2316.zip
Migrate to EAPI 2 in order to remove built_with_use call.
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/sparky/ChangeLog7
-rw-r--r--sci-chemistry/sparky/sparky-3.113.ebuild19
2 files changed, 12 insertions, 14 deletions
diff --git a/sci-chemistry/sparky/ChangeLog b/sci-chemistry/sparky/ChangeLog
index febe8c1df8b1..02de2df57de1 100644
--- a/sci-chemistry/sparky/ChangeLog
+++ b/sci-chemistry/sparky/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/sparky
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/ChangeLog,v 1.12 2008/06/03 02:07:38 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/ChangeLog,v 1.13 2009/09/18 14:50:12 betelgeuse Exp $
+
+ 18 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> sparky-3.113.ebuild:
+ Migrate to EAPI 2 in order to remove built_with_use call.
03 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org> sparky-3.113.ebuild:
remove reference to app-shells/csh which has been removed
diff --git a/sci-chemistry/sparky/sparky-3.113.ebuild b/sci-chemistry/sparky/sparky-3.113.ebuild
index c15237e54ea3..6aeebdd5b18e 100644
--- a/sci-chemistry/sparky/sparky-3.113.ebuild
+++ b/sci-chemistry/sparky/sparky-3.113.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.113.ebuild,v 1.3 2008/06/03 02:07:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.113.ebuild,v 1.4 2009/09/18 14:50:12 betelgeuse Exp $
+
+EAPI="2"
inherit eutils toolchain-funcs multilib python
@@ -14,7 +16,7 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
RESTRICT="mirror"
-RDEPEND="=dev-lang/python-2.4*
+RDEPEND="dev-lang/python:2.4[tk]
=dev-lang/tk-8.4*
app-shells/tcsh"
DEPEND="${RDEPEND}
@@ -27,10 +29,6 @@ pkg_setup() {
python="/usr/bin/python2.4"
python_version
- if ! built_with_use dev-lang/python tk; then
- die "Rebuild python with USE=tk"
- fi
-
arguments=( SPARKY="${S}" \
SPARKY_INSTALL_MAC="" \
SPARKY_INSTALL="${D}/usr" \
@@ -49,10 +47,7 @@ pkg_setup() {
# PYDIR="\$(SPARKY_INSTALL)/$(get_libdir)/python\$(PYTHON_VERSION)/site-packages" \
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/fix-install.patch
sed -i \
@@ -66,7 +61,7 @@ src_compile() {
}
src_install() {
- make "${arguments[@]}" install || die "install failed"
+ emake "${arguments[@]}" install || die "install failed"
# Make internal help work
dosym ../../share/doc/sparky/manual /usr/lib/sparky/manual
# It returns a weird threading error message without this