summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-10-20 01:22:57 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-10-20 01:22:57 +0000
commit4b958b9e7d224e95c903b8bcb6aef941f8777c84 (patch)
treea183a437857b6320331622e674a396c5a270adb1 /sci-chemistry
parentInitial import (diff)
downloadhistorical-4b958b9e7d224e95c903b8bcb6aef941f8777c84.tar.gz
historical-4b958b9e7d224e95c903b8bcb6aef941f8777c84.tar.bz2
historical-4b958b9e7d224e95c903b8bcb6aef941f8777c84.zip
Initial import
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog10
-rw-r--r--sci-chemistry/apbs/Manifest4
-rw-r--r--sci-chemistry/apbs/apbs-0.3.2.ebuild61
-rw-r--r--sci-chemistry/apbs/files/digest-apbs-0.3.21
-rw-r--r--sci-chemistry/apbs/metadata.xml5
5 files changed, 81 insertions, 0 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
new file mode 100644
index 000000000000..c0b8c2b62a0f
--- /dev/null
+++ b/sci-chemistry/apbs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/apbs
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.1 2005/10/20 01:22:57 ribosome Exp $
+
+*apbs-0.3.2 (20 Oct 2005)
+
+ 20 Oct 2005; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +apbs-0.3.2.ebuild:
+ Initial import. Thanks to Markus Dittrich <markusle@gmail.com> for his work.
+
diff --git a/sci-chemistry/apbs/Manifest b/sci-chemistry/apbs/Manifest
new file mode 100644
index 000000000000..68bba8a47248
--- /dev/null
+++ b/sci-chemistry/apbs/Manifest
@@ -0,0 +1,4 @@
+MD5 0b9a9c16ec71e0de2df9f561129d61ed ChangeLog 408
+MD5 0ffcd41aa96cf1bcffd8b539c27957db metadata.xml 157
+MD5 401bb19a1a50e92cccd4580795528579 apbs-0.3.2.ebuild 1591
+MD5 fe78d29b43ac5fd73de88376a5db2855 files/digest-apbs-0.3.2 63
diff --git a/sci-chemistry/apbs/apbs-0.3.2.ebuild b/sci-chemistry/apbs/apbs-0.3.2.ebuild
new file mode 100644
index 000000000000..2111417a608b
--- /dev/null
+++ b/sci-chemistry/apbs/apbs-0.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-0.3.2.ebuild,v 1.1 2005/10/20 01:22:57 ribosome Exp $
+
+inherit eutils fortran
+
+DESCRIPTION=" Software for evaluating the electrostatic properties of nanoscale biomolecular systems"
+LICENSE="GPL-2"
+HOMEPAGE="http://agave.wustl.edu/apbs/"
+SRC_URI="http://agave.wustl.edu/apbs/download/dist/${P}.tar.gz"
+
+SLOT="0"
+IUSE="blas"
+KEYWORDS="~x86"
+
+DEPEND="blas? ( virtual/blas )
+ sys-libs/readline
+ dev-libs/maloc"
+
+pkg_setup() {
+ need_fortran g77
+}
+
+src_compile() {
+ # use blas
+ use blas && local myconf="--with-blas=-lblas"
+
+ # configure
+ econf ${myconf} || die "configure failed"
+
+ # build
+ make || die "make failed"
+}
+
+src_install() {
+
+ # install apbs binary
+ dobin bin/apbs || die "failed to install apbs binary"
+
+ # fix up and install examples
+ sed -e "s|\${bindir}|/usr/bin|" \
+ -i examples/ion-pmf/runme || \
+ die "failed fixing ion-pmf/runme file"
+
+ sed -e "s|bindir=''|bindir=/usr/bin|" \
+ -i examples/point-pmf/runme.sh || \
+ die "failed fixing point-pmf/runme.sh"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "failed to install examples"
+
+ # install docs
+ insinto /usr/share/doc/${PF}/html/programmer
+ doins doc/html/programmer/* || die "failed to install html docs"
+
+ insinto /usr/share/doc/${PF}/html/tutorial
+ doins doc/html/tutorial/* || die "failed to install html docs"
+
+ insinto /usr/share/doc/${PF}/html/user-guide
+ doins doc/html/user-guide/* || die "failed to install html docs"
+}
diff --git a/sci-chemistry/apbs/files/digest-apbs-0.3.2 b/sci-chemistry/apbs/files/digest-apbs-0.3.2
new file mode 100644
index 000000000000..4659f3d3c792
--- /dev/null
+++ b/sci-chemistry/apbs/files/digest-apbs-0.3.2
@@ -0,0 +1 @@
+MD5 b2a417c1d9c102157f45cf00fd0ae196 apbs-0.3.2.tar.gz 6560956
diff --git a/sci-chemistry/apbs/metadata.xml b/sci-chemistry/apbs/metadata.xml
new file mode 100644
index 000000000000..d369d068ffb8
--- /dev/null
+++ b/sci-chemistry/apbs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>