summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-07-13 10:12:46 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-07-13 10:12:46 +0000
commitc0c50f5f4eb0973fccedf0ff8238288375b0694c (patch)
tree2b9d0fe281b89dcd7de8aaaf74107f140c47d7bf /sci-chemistry/molmol/molmol-2k_p2.ebuild
parentFor sci-chemistry/molmol. (diff)
downloadhistorical-c0c50f5f4eb0973fccedf0ff8238288375b0694c.tar.gz
historical-c0c50f5f4eb0973fccedf0ff8238288375b0694c.tar.bz2
historical-c0c50f5f4eb0973fccedf0ff8238288375b0694c.zip
Initial commit.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sci-chemistry/molmol/molmol-2k_p2.ebuild')
-rw-r--r--sci-chemistry/molmol/molmol-2k_p2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-chemistry/molmol/molmol-2k_p2.ebuild b/sci-chemistry/molmol/molmol-2k_p2.ebuild
new file mode 100644
index 000000000000..d7765bf4ed99
--- /dev/null
+++ b/sci-chemistry/molmol/molmol-2k_p2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2.ebuild,v 1.1 2005/07/13 10:12:46 spyderous Exp $
+
+inherit eutils toolchain-funcs multilib
+
+MY_PV="${PV/_p/.}.0"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Publication-quality molecular visualization package"
+HOMEPAGE="http://hugin.ethz.ch/wuthrich/software/molmol/index.html"
+SRC_URI="ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-src.tar.gz
+ ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-doc.tar.gz"
+LICENSE="molmol"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/motif
+ virtual/x11
+ media-libs/jpeg
+ media-libs/tiff
+ media-libs/libpng
+ sys-libs/zlib"
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+# Yeah, the gz's aren't in a subdir.
+S=${WORKDIR}
+
+MMDIR="/usr/$(get_libdir)/molmol"
+
+src_unpack() {
+ unpack ${A}
+
+ # Patch from http://pjf.net/science/molmol.html, where src.rpm is provided
+ epatch ${FILESDIR}/pjf_RH9_molmol2k2.diff
+
+ ln -s makedef.lnx ${S}/makedef
+
+ # 1) The Korn shell is only taken by default because the Bourne shell
+ # on DEC systems cannot handle the script.
+ # We don't want this needless dependency.
+ # 2) Fix up MOLMOLHOME, which determines the directory the binary's in.
+ sed -i \
+ -e "s:/bin/ksh:/bin/sh:" \
+ -e "s:^MOLMOLHOME.*:MOLMOLHOME=${MMDIR}:" \
+ ${S}/molmol
+ # 1) Set CFLAGS.
+ # 2) Set compiler.
+ sed -i \
+ -e "s:^MCFLAGS.*:MCFLAGS = ${CFLAGS}:" \
+ -e "s:^CC.*:CC = $(tc-getCC):" \
+ ${S}/makedef
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin molmol
+
+ EXEDESTTREE=/usr/lib/molmol newexe src/main/molmol molmol.lnx
+
+ # Macros, setup and tips must be subdirs of molmol.
+ # Perhaps we should do /usr/lib/molmol?
+
+ INSDESTTREE=${MMDIR} doins -r auxil help macros man setup tips
+
+ dodoc HISTORY README
+}