summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOmkhar Arasaratnam <omkhar@gentoo.org>2005-08-05 15:55:41 +0000
committerOmkhar Arasaratnam <omkhar@gentoo.org>2005-08-05 15:55:41 +0000
commitfc0f4b24c43379608b704b4245b615b4914863fe (patch)
tree6f48350cf388cffa083fd9f67519d3bf8a7b106f /sci-chemistry/gromacs
parent*** empty log message *** (diff)
downloadhistorical-fc0f4b24c43379608b704b4245b615b4914863fe.tar.gz
historical-fc0f4b24c43379608b704b4245b615b4914863fe.tar.bz2
historical-fc0f4b24c43379608b704b4245b615b4914863fe.zip
Fixed broken patch and made patch only apply if ppc64 and altivec
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog6
-rw-r--r--sci-chemistry/gromacs/files/gromacs-ppc64-altivec.patch18
-rw-r--r--sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild6
3 files changed, 27 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index d9e1bf27d29c..d2c5eb0dc8d1 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gromacs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.4 2005/08/04 19:05:26 omkhar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.5 2005/08/05 15:55:41 omkhar Exp $
+
+ 05 Aug 2005; <omkhar@gentoo.org> +files/gromacs-ppc64-altivec.patch,
+ gromacs-3.2.1-r1.ebuild:
+ Added patch back as binary due to metatags. Made sure patch only applies when ppc64 && altivec
*gromacs-3.2.1-r1 (04 Aug 2005)
diff --git a/sci-chemistry/gromacs/files/gromacs-ppc64-altivec.patch b/sci-chemistry/gromacs/files/gromacs-ppc64-altivec.patch
new file mode 100644
index 000000000000..d170bbd70ad3
--- /dev/null
+++ b/sci-chemistry/gromacs/files/gromacs-ppc64-altivec.patch
@@ -0,0 +1,18 @@
+diff -Naur gromacs-3.2.1/include/ppc_altivec.h gromacs-3.2.1-new/include/ppc_altivec.h
+--- gromacs-3.2.1/include/ppc_altivec.h 2003-11-18 02:41:58.000000000 -0600
++++ gromacs-3.2.1-new/include/ppc_altivec.h 2005-08-04 13:42:05.000000000 -0500
+@@ -33,6 +33,14 @@
+ #ifndef _ppc_altivec_h
+ #define _ppc_altivec_h
+
++#if !defined(__APPLE_ALTIVEC__)
++#include <altivec.h>
++#ifdef bool
++#undef bool
++#define bool int
++#endif
++#endif
++
+ static char *SRCID_ppc_altivec_h = "$Id: ppc_altivec.h,v 1.7 2003/11/18 08:41:58 lindahl Exp $";
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
diff --git a/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild b/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild
index a5015f9b669b..785fd0bef965 100644
--- a/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild,v 1.1 2005/08/04 19:05:26 omkhar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.2.1-r1.ebuild,v 1.2 2005/08/05 15:55:41 omkhar Exp $
inherit eutils
@@ -24,7 +24,9 @@ DEPEND="=sci-libs/fftw-2.1*
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PN}-ppc64-altivec.patch
+ if use ppc64 && use altivec ; then
+ epatch ${FILESDIR}/${PN}-ppc64-altivec.patch
+ fi
}
src_compile() {