summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 06:38:10 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 06:38:10 +0000
commit42541a720cb9fe3290e2c92d1f465cbbb1abf06c (patch)
tree976b6131993a3340519178dd58b17ae54cfc337c /sci-biology/raxml/files
parentMaintainer changed to net-mail with dertobi123's permission (diff)
downloadhistorical-42541a720cb9fe3290e2c92d1f465cbbb1abf06c.tar.gz
historical-42541a720cb9fe3290e2c92d1f465cbbb1abf06c.tar.bz2
historical-42541a720cb9fe3290e2c92d1f465cbbb1abf06c.zip
Tweaking ebuild, respect LDFLAGS #335629
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/raxml/files')
-rw-r--r--sci-biology/raxml/files/raxml-7.2.5-makefile.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-biology/raxml/files/raxml-7.2.5-makefile.patch b/sci-biology/raxml/files/raxml-7.2.5-makefile.patch
new file mode 100644
index 000000000000..8b381e50cb58
--- /dev/null
+++ b/sci-biology/raxml/files/raxml-7.2.5-makefile.patch
@@ -0,0 +1,29 @@
+ Makefile.gcc | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.gcc b/Makefile.gcc
+index 8d09549..59af556 100644
+--- a/Makefile.gcc
++++ b/Makefile.gcc
+@@ -1,10 +1,10 @@
+ # Makefile August 2006 by Alexandros Stamatakis
+ # Makefile cleanup October 2006, Courtesy of Peter Cordes <peter@cordes.ca>
+
+-CC = gcc
++CC ?= gcc
+
+
+-CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2
++CFLAGS += -D_GNU_SOURCE
+ #-Wall -std=c99 -pedantic -Wunused-parameter -Wredundant-decls -Wreturn-type -Wswitch-default -Wunused-value -Wimplicit -Wimplicit-function-declaration -Wimplicit-int -Wimport -pedantic-errors -Wunused -Wunused-function -Wunused-label -Wno-int-to-pointer-cast -Wbad-function-cast -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wold-style-definition -Wstrict-prototypes -Wdeclaration-after-statement -Wpointer-sign -Wextra -Wredundant-decls -Wunused -Wunused-function -Wunused-parameter -Wunused-value -Wunused-variable -Wformat -Wformat-nonliteral -Wparentheses -Wsequence-point -Wuninitialized -Wundef -Wbad-function-cast
+
+
+@@ -19,7 +19,7 @@ all : raxmlHPC
+ GLOBAL_DEPS = axml.h globalVariables.h
+
+ raxmlHPC : $(objs)
+- $(CC) -o raxmlHPC $(objs) $(LIBRARIES)
++ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES)
+
+ classify.o : classify.c $(GLOBAL_DEPS)
+ evaluatePartialSpecialGeneric.o : evaluatePartialSpecialGeneric.c $(GLOBAL_DEPS)