summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-07-25 18:15:30 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-07-25 18:15:30 +0000
commit4c94e50a5492f815f74512fbdc09bb71041c6632 (patch)
tree3fa96d959d185eae8d590d52e3474f1ce176511f /sci-biology/piler/piler-1.0.ebuild
parentVersion bump (diff)
downloadhistorical-4c94e50a5492f815f74512fbdc09bb71041c6632.tar.gz
historical-4c94e50a5492f815f74512fbdc09bb71041c6632.tar.bz2
historical-4c94e50a5492f815f74512fbdc09bb71041c6632.zip
Import from Science overlay
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/piler/piler-1.0.ebuild')
-rw-r--r--sci-biology/piler/piler-1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/piler/piler-1.0.ebuild b/sci-biology/piler/piler-1.0.ebuild
new file mode 100644
index 000000000000..674cd82f6af9
--- /dev/null
+++ b/sci-biology/piler/piler-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/piler/piler-1.0.ebuild,v 1.1 2009/07/25 18:15:30 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Analysis of repetitive DNA found in genome sequences"
+HOMEPAGE="http://www.drive5.com/piler/"
+#SRC_URI="http://www.drive5.com/piler/piler_source.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( sci-biology/muscle
+ sci-libs/libmuscle )
+ sci-biology/pals"
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake GPP="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ dobin piler
+}