summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-12-14 16:28:55 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-12-14 16:28:55 +0000
commite30ebfe5a19b302b58f7dcf78da6372bca6bb67b (patch)
tree6d6055192a1d1e2c5b76ed7b8ec874d88c6dd85d /sci-biology/phylip/phylip-3.65-r1.ebuild
parentDrop old versions. (diff)
downloadhistorical-e30ebfe5a19b302b58f7dcf78da6372bca6bb67b.tar.gz
historical-e30ebfe5a19b302b58f7dcf78da6372bca6bb67b.tar.bz2
historical-e30ebfe5a19b302b58f7dcf78da6372bca6bb67b.zip
Fixed file collision with "sys-apps/coreutils" (bug #115482)
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'sci-biology/phylip/phylip-3.65-r1.ebuild')
-rw-r--r--sci-biology/phylip/phylip-3.65-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/phylip/phylip-3.65-r1.ebuild b/sci-biology/phylip/phylip-3.65-r1.ebuild
new file mode 100644
index 000000000000..5414b633c8a0
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.65-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.65-r1.ebuild,v 1.1 2005/12/14 16:28:55 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
+LICENSE="freedist"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="ftp://evolution.genetics.washington.edu/pub/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~ppc-macos ~x86"
+
+DEPEND="virtual/libc
+ virtual/x11"
+
+S="${WORKDIR}/${PN}${PV}/src"
+
+src_compile() {
+ sed -e "s/CFLAGS = -O3 -fomit-frame-pointer/CFLAGS = ${CFLAGS}/" \
+ -e "s/CC = cc/CC = $(tc-getCC)/" \
+ -e "s/DC = cc/DC = $(tc-getCC)/" \
+ -i Makefile || die "Patching Makefile failed."
+ mkdir ../fonts
+ emake -j1 all put || die "Compilation failed."
+ mv ../exe/font* ../fonts || die "Font move failed."
+ mv ../exe/factor ../exe/factor-${PN} || die "Renaming factor failed."
+}
+
+src_install() {
+ cd "${WORKDIR}/${PN}${PV}"
+
+ dobin exe/* || "Failed to install programs."
+
+ dodoc "${FILESDIR}"/README.Gentoo || die "Failed to install Gentoo notes."
+
+ dohtml phylip.html || "Failed to install HTML documentation index."
+ insinto /usr/share/doc/${PF}/html/doc
+ doins doc/* || "Failed to install HTML documentation."
+
+ insinto /usr/share/${PN}/fonts
+ doins fonts/* || die "Fonts installation failed."
+}