summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-08-11 14:55:25 +0000
committerJustin Lecher <jlec@gentoo.org>2013-08-11 14:55:25 +0000
commit4e8d4a3c5aad6a6eef594967bf48c624b04017ad (patch)
tree4f6d3932a08e190bf46e643e4181ef843c6f55af /sci-biology/abyss/files
parentfix doc install dir wrt #480518 (diff)
downloadhistorical-4e8d4a3c5aad6a6eef594967bf48c624b04017ad.tar.gz
historical-4e8d4a3c5aad6a6eef594967bf48c624b04017ad.tar.bz2
historical-4e8d4a3c5aad6a6eef594967bf48c624b04017ad.zip
sci-biology/abyss: Version BUmp, respect AR, #477580
Package-Manager: portage-2.2.0_alpha196/cvs/Linux x86_64 Manifest-Sign-Key: 0xB9D4F231BD1558AB!
Diffstat (limited to 'sci-biology/abyss/files')
-rw-r--r--sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch18
-rw-r--r--sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch18
-rw-r--r--sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch15
3 files changed, 51 insertions, 0 deletions
diff --git a/sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch b/sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch
new file mode 100644
index 000000000000..300868f52b76
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch
@@ -0,0 +1,18 @@
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 5c6cb92..b99bedd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -12,6 +12,10 @@ AC_PROG_CPP
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AN_MAKEVAR([AR], [AC_PROG_AR])
++AN_PROGRAM([ar], [AC_PROG_AR])
++AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL(AR, ar, :)])
++AC_PROG_AR
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([dlfcn.h fcntl.h float.h limits.h \
diff --git a/sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch b/sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch
new file mode 100644
index 000000000000..158e9b1262e4
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch
@@ -0,0 +1,18 @@
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 9d4bb66..aa94364 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -12,6 +12,10 @@ AC_PROG_CPP
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AN_MAKEVAR([AR], [AC_PROG_AR])
++AN_PROGRAM([ar], [AC_PROG_AR])
++AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL(AR, ar, :)])
++AC_PROG_AR
+ AC_CHECK_TOOL(GHC, ghc)
+ AM_CONDITIONAL([HAVE_GHC], [test "$GHC"])
+
diff --git a/sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch b/sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch
new file mode 100644
index 000000000000..c2cc35c31d98
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ ParseAligns/abyss-fixmate.cc | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/ParseAligns/abyss-fixmate.cc b/ParseAligns/abyss-fixmate.cc
+index 1a169cf..36cc05b 100644
+--- a/ParseAligns/abyss-fixmate.cc
++++ b/ParseAligns/abyss-fixmate.cc
+@@ -16,6 +16,7 @@
+ #include <iterator>
+ #include <sstream>
+ #include <string>
++#include <unistd.h>
+
+ using namespace std;
+