summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-10-24 11:40:04 +0000
committerBen de Groot <yngwin@gentoo.org>2012-10-24 11:40:04 +0000
commit86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38 (patch)
treed95657be6ecd3644a62f909a646dd62fbc78e0be /razorqt-base/razorqt-panel
parentNew revision, eapi4 bump, respect CC, LDFLAGS, add ~amd64 (diff)
downloadhistorical-86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38.tar.gz
historical-86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38.tar.bz2
historical-86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38.zip
Version bump
Package-Manager: portage-2.2.0_alpha123/cvs/Linux x86_64
Diffstat (limited to 'razorqt-base/razorqt-panel')
-rw-r--r--razorqt-base/razorqt-panel/ChangeLog7
-rw-r--r--razorqt-base/razorqt-panel/razorqt-panel-0.5.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/razorqt-base/razorqt-panel/ChangeLog b/razorqt-base/razorqt-panel/ChangeLog
index b44c4e0ce551..1e023c6f9bd1 100644
--- a/razorqt-base/razorqt-panel/ChangeLog
+++ b/razorqt-base/razorqt-panel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for razorqt-base/razorqt-panel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-panel/ChangeLog,v 1.1 2012/10/15 10:11:06 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-panel/ChangeLog,v 1.2 2012/10/24 11:38:11 yngwin Exp $
+
+*razorqt-panel-0.5.1 (24 Oct 2012)
+
+ 24 Oct 2012; Ben de Groot <yngwin@gentoo.org> +razorqt-panel-0.5.1.ebuild:
+ Version bump
*razorqt-panel-0.5.0 (15 Oct 2012)
diff --git a/razorqt-base/razorqt-panel/razorqt-panel-0.5.1.ebuild b/razorqt-base/razorqt-panel/razorqt-panel-0.5.1.ebuild
new file mode 100644
index 000000000000..856aeb26576f
--- /dev/null
+++ b/razorqt-base/razorqt-panel/razorqt-panel-0.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-panel/razorqt-panel-0.5.1.ebuild,v 1.1 2012/10/24 11:38:11 yngwin Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="Razor-qt panel and its plugins"
+HOMEPAGE="http://razor-qt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Razor-qt/razor-qt.git"
+ EGIT_BRANCH="master"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/downloads/Razor-qt/razor-qt/razorqt-${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/razorqt-${PV}"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+clock colorpicker cpuload +desktopswitch +mainmenu +mount networkmonitor
+ +quicklaunch screensaver sensors +showdesktop +taskbar +tray +volume"
+
+DEPEND="razorqt-base/razorqt-libs
+ cpuload? ( sys-libs/libstatgrab )
+ networkmonitor? ( sys-libs/libstatgrab )
+ sensors? ( sys-apps/lm_sensors )
+ volume? ( || ( media-libs/alsa-lib media-sound/pulseaudio ) )"
+RDEPEND="${DEPEND}
+ razorqt-base/razorqt-data
+ mount? ( sys-fs/udisks )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSPLIT_BUILD=On
+ -DMODULE_PANEL=On
+ )
+ # probably needs fixing for automagic deps (e.g. alsa / pulse)
+ for i in clock colorpicker cpuload desktopswitch mainmenu mount networkmonitor \
+ quicklaunch screensaver sensors showdesktop taskbar tray volume; do
+ use $i || mycmakeargs+=( -D${i^^}_PLUGIN=No )
+ done
+ cmake-utils_src_configure
+}