summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-05-27 12:59:12 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-05-27 12:59:12 +0000
commitb530576220a8b54a88c50aacd9f82d481dcf5b20 (patch)
treeb602b8d40fc15237ceb35e1adea86e19ceeda884 /net-zope/zope
parentversion bump (diff)
downloadhistorical-b530576220a8b54a88c50aacd9f82d481dcf5b20.tar.gz
historical-b530576220a8b54a88c50aacd9f82d481dcf5b20.tar.bz2
historical-b530576220a8b54a88c50aacd9f82d481dcf5b20.zip
version bump
Package-Manager: portage-2.1_rc2-r3
Diffstat (limited to 'net-zope/zope')
-rw-r--r--net-zope/zope/ChangeLog9
-rw-r--r--net-zope/zope/files/digest-zope-2.9.33
-rw-r--r--net-zope/zope/files/digest-zope-3.2.13
-rw-r--r--net-zope/zope/zope-2.9.3.ebuild79
-rw-r--r--net-zope/zope/zope-3.2.1.ebuild124
5 files changed, 217 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 8bed912578b5..b9854512081b 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.101 2006/04/27 22:24:48 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.102 2006/05/27 12:57:45 radek Exp $
+
+*zope-3.2.1 (27 May 2006)
+*zope-2.9.3 (27 May 2006)
+
+ 27 May 2006; Radoslaw Stachowiak <radek@gentoo.org> +zope-2.9.3.ebuild,
+ +zope-3.2.1.ebuild:
+ version bump
27 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-zope-2.6.4-r1,
files/digest-zope-2.7.7, files/digest-zope-2.7.8, files/digest-zope-2.8.3,
diff --git a/net-zope/zope/files/digest-zope-2.9.3 b/net-zope/zope/files/digest-zope-2.9.3
new file mode 100644
index 000000000000..0e70ee5563e9
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.9.3
@@ -0,0 +1,3 @@
+MD5 4e8b4e076cadd6eb62dd4513748cb9f9 Zope-2.9.3.tgz 8010113
+RMD160 a4aa2303400efa17ec0d225b501c5282c454705b Zope-2.9.3.tgz 8010113
+SHA256 2c60f25266663d676c1c8c2c6864a038a1b675ff8879cec40fbc72f72efc0bfa Zope-2.9.3.tgz 8010113
diff --git a/net-zope/zope/files/digest-zope-3.2.1 b/net-zope/zope/files/digest-zope-3.2.1
new file mode 100644
index 000000000000..57c3851f4d03
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-3.2.1
@@ -0,0 +1,3 @@
+MD5 becbc5aba9573c46cf5820ab12720d1d Zope-3.2.1.tgz 6532373
+RMD160 f7aeb56ab5f09e6780d0df787939af4c7815ceba Zope-3.2.1.tgz 6532373
+SHA256 8431984af75054e4ddfe45bf708924240f8b6b02220cd84d090138413ac82341 Zope-3.2.1.tgz 6532373
diff --git a/net-zope/zope/zope-2.9.3.ebuild b/net-zope/zope/zope-2.9.3.ebuild
new file mode 100644
index 000000000000..f36b3ad1f24d
--- /dev/null
+++ b/net-zope/zope/zope-2.9.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.3.ebuild,v 1.1 2006/05/27 12:57:45 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix=. --force --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR}
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}
diff --git a/net-zope/zope/zope-3.2.1.ebuild b/net-zope/zope/zope-3.2.1.ebuild
new file mode 100644
index 000000000000..7243b7f48ffb
--- /dev/null
+++ b/net-zope/zope/zope-3.2.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-3.2.1.ebuild,v 1.1 2006/05/27 12:57:45 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.0
+ >=sys-apps/sed-4.0.5"
+
+S=${WORKDIR}/Zope-${PV}
+
+ZUNAME=zope
+ZGNAME=zope
+
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+ZSKELDIR=${ZSERVDIR}/zopeskel
+ZINSTDIR=/var/lib/zope/${P}
+
+src_compile() {
+
+ cd ${S}
+
+ ./configure --prefix=${D}${ZSERVDIR} --with-python=/usr/bin/python2.4 || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+
+ cd ${S}
+
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ for DIR in schema security skins style zcml zsync
+ do
+ docinto ${DIR}
+ dodoc Zope/doc/${DIR}/*
+ done
+
+ make install prefix=${D}${ZSERVDIR}
+
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to zopeskel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}${ZSKELDIR}/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGNAME} 261
+ usermod -g ${ZGNAME} -c "Zope Admin User" -d /var/lib/zope -s /bin/bash ${ZUNAME} 2>&1 >/dev/null || \
+ enewuser ${ZUNAME} 261 /bin/bash /var/lib/zope ${ZGNAME} -c "Zope Admin User"
+
+ einfo "This release can create a default instance using the command: "
+ einfo " emerge --config =${PF}"
+ einfo "Instance (${P}) will be created in ${ZINSTDIR} as its home."
+ einfo "System uid/gid for instance will be: ${ZUNAME}:${ZGNAME}"
+}
+
+pkg_prerm() {
+
+ find ${ZSERVDIR}/lib/python -name \*.py[co] -exec rm -f {} \;
+}
+
+pkg_postrm() {
+
+ rmdir /usr/$(get_libdir)/${ZSERVDIR} 2>/dev/null
+ ewarn "Instances created for this package are NOT automaticaly deleted!"
+ ewarn "Inspect these locations and manually remove them (if needed):"
+ ewarn " /etc/init.d/${P}"
+ ewarn " ${ZINSTDIR}"
+}
+
+pkg_config() {
+
+ if [ -f /etc/init.d/${P} -o -d ${ZINSTDIR} ]
+ then
+ ewarn "Default instance already exists, aborting.."
+ ewarn "Please delete first /etc/init.d/${P} and ${ZINSTDIR}"
+ die "Failed to create default instance."
+ fi
+
+ mkdir -p ${ZINSTDIR}
+ einfo "Instance ${P} creation, calling mkzopeinstance.."
+ ${ZSERVDIR}/bin/mkzopeinstance --non-interactive -d ${ZINSTDIR} -u admin:admin
+
+ # bug in zope
+ einfo "Patching ${ZINSTDIR}/etc/zdaemon.conf"
+ sed -i -e 's|daemon on|daemon on\n\n # socket has to be defined inside of instance\n socket-name $INSTANCE/var/zdsock|' ${ZINSTDIR}/etc/zdaemon.conf
+
+ # remove unnecessary zope.initd
+ rm -f ${ZINSTDIR}/zope.initd
+
+ # log symlink
+ rm -rf ${ZINSTDIR}/log
+ mkdir -p /var/log/zope/${PN}
+ ln -s /var/log/zope/${PN} ${ZINSTDIR}/log
+
+ # permissions changes
+ chmod go-rwx -R ${ZINSTDIR}
+ chown ${ZUNAME}:${ZGNAME} -R ${ZINSTDIR} /var/log/zope/${PN}
+
+ cp ${ZSKELDIR}/zope.initd /etc/init.d/${P}
+ chmod 755 /etc/init.d/${P}
+ sed -i -e "s|INSTANCE_HOME|${ZINSTDIR}|" /etc/init.d/${P}
+ sed -i -e "s|zopectl|zopectl -u ${ZUNAME}|" /etc/init.d/${P}
+
+ einfo "Default instance created at ${ZINSTDIR}"
+ einfo "Created default zope user 'admin' with password 'admin'."
+ einfo "System uid/gid for instance is: ${ZUNAME}:${ZGNAME}."
+ einfo "To start instance (default ports 8080,8021) use: /etc/init.d/${P} start"
+ einfo "To start instance on every restart use: rc-update -a ${P} default"
+}