summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-31 18:51:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-31 18:51:42 +0000
commit43f93864add99f2890e66e7e70c4e8cfb68bcc19 (patch)
tree4170f0519048d017bf5c9b111fda0987757ddaab /net-zope/zope-tal
parentMask net-firewall/knetfilter wrt #251992. (diff)
downloadhistorical-43f93864add99f2890e66e7e70c4e8cfb68bcc19.tar.gz
historical-43f93864add99f2890e66e7e70c4e8cfb68bcc19.tar.bz2
historical-43f93864add99f2890e66e7e70c4e8cfb68bcc19.zip
Initial addition.
Package-Manager: portage-14751-svn/cvs/Linux x86_64
Diffstat (limited to 'net-zope/zope-tal')
-rw-r--r--net-zope/zope-tal/ChangeLog10
-rw-r--r--net-zope/zope-tal/Manifest4
-rw-r--r--net-zope/zope-tal/metadata.xml6
-rw-r--r--net-zope/zope-tal/zope-tal-3.5.2.ebuild32
4 files changed, 52 insertions, 0 deletions
diff --git a/net-zope/zope-tal/ChangeLog b/net-zope/zope-tal/ChangeLog
new file mode 100644
index 000000000000..c7ab58480cd3
--- /dev/null
+++ b/net-zope/zope-tal/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-tal
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-tal/ChangeLog,v 1.1 2009/10/31 18:51:42 arfrever Exp $
+
+*zope-tal-3.5.2 (31 Oct 2009)
+
+ 31 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-tal-3.5.2.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-tal/Manifest b/net-zope/zope-tal/Manifest
new file mode 100644
index 000000000000..2249cb990245
--- /dev/null
+++ b/net-zope/zope-tal/Manifest
@@ -0,0 +1,4 @@
+DIST zope.tal-3.5.2.zip 149003 RMD160 e39488392d50a3d41fb6eb36920347639f7f31d4 SHA1 4fd7712cc38e51181fd66cb4e680bd6644446209 SHA256 dab6ed841046382c1fb39c543ffd09cbd152593b7cbdf5a67970b2a805c5feba
+EBUILD zope-tal-3.5.2.ebuild 788 RMD160 27184c5ac87d16f8a593e208de2e851137ad96a7 SHA1 afbb07c10a6f81b81ef5b6ca02c5cf75da08038a SHA256 0b4365a5a3b6c61c66b8d13898f11b1b3540df5ee8f10d434ec191e20990dd85
+MISC ChangeLog 397 RMD160 fb3ad60b2f0133bb28c2e48c2d1ba425d2998c18 SHA1 7a7bfa94ca928bfd5d0f77061c2f2a609be53d6c SHA256 fce5138f886079b28fd226a4b505a4eb9fb03ccd18b29ef2bf45573f8c164d51
+MISC metadata.xml 183 RMD160 0e2d86898897ee70cc1f6e9ceb76d00388d3b2fa SHA1 19635a9dfa15036e341a7cbdd8cbd018db62be82 SHA256 f480763451083d2f7be8fc23d38e02952ccc383b4cc65e103a9901a0907ce50d
diff --git a/net-zope/zope-tal/metadata.xml b/net-zope/zope-tal/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-tal/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-tal/zope-tal-3.5.2.ebuild b/net-zope/zope-tal/zope-tal-3.5.2.ebuild
new file mode 100644
index 000000000000..a058d1c9dcf7
--- /dev/null
+++ b/net-zope/zope-tal/zope-tal-3.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-tal/zope-tal-3.5.2.ebuild,v 1.1 2009/10/31 18:51:42 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope 3 Template Application Language (TAL)"
+HOMEPAGE="http://pypi.python.org/pypi/zope.tal"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-i18nmessageid
+ net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"