summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-23 04:46:52 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-23 04:46:52 +0000
commitc45d9d0b4f20ac78b5497101e35349fe5d594cd9 (patch)
tree1c99076c51b4a9cac19f6358fb2a22bce3f21ddc /net-www
parentCLean up after cvs.gentoo.org meltdown. (diff)
downloadhistorical-c45d9d0b4f20ac78b5497101e35349fe5d594cd9.tar.gz
historical-c45d9d0b4f20ac78b5497101e35349fe5d594cd9.tar.bz2
historical-c45d9d0b4f20ac78b5497101e35349fe5d594cd9.zip
clean up after cvs.gentoo.org meltdown.
remove old ebuilds. tweak initscript, we install an httpd.conf, so dont warn about that.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/apache-1.3.20-r1.ebuild118
-rw-r--r--net-www/apache/apache-1.3.20-r6.ebuild102
-rw-r--r--net-www/apache/files/digest-apache-1.3.20-r12
-rw-r--r--net-www/apache/files/digest-apache-1.3.20-r62
-rw-r--r--net-www/apache/files/httpd.rc5121
-rw-r--r--net-www/apache/files/httpd.rc616
6 files changed, 2 insertions, 359 deletions
diff --git a/net-www/apache/apache-1.3.20-r1.ebuild b/net-www/apache/apache-1.3.20-r1.ebuild
deleted file mode 100644
index e6917bf46f85..000000000000
--- a/net-www/apache/apache-1.3.20-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.20-r1.ebuild,v 1.2 2001/09/06 08:00:57 woodchip Exp $
-
-AV="1.3.20"
-MSV="2.8.4"
-
-A="apache_${AV}.tar.gz mod_ssl-${MSV}-${AV}.tar.gz"
-S=${WORKDIR}/apache_${AV}
-DESCRIPTION="The Apache Web Server v1.3.19 with mod_ssl"
-SRC_URI="http://httpd.apache.org/dist/httpd/apache_${AV}.tar.gz
- ftp://ftp.modssl.org/source/mod_ssl-${MSV}-${AV}.tar.gz"
-HOMEPAGE="http://www.apache.org http://www.modssl.org"
-
-DEPEND="virtual/glibc
- >=sys-libs/db-3.2.3h-r3
- =sys-libs/db-1.85-r1
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-
-src_compile() {
- export SSL_BASE=SYSTEM
- export CFLAGS="${CFLAGS} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
-if [ "`use ssl`" ]; then
- cd ${S}/../mod_ssl-${MSV}-${AV}
- try ./configure --with-apache=${S} --with-ssl=SYSTEM
- cd ${S}
-fi
-local myconf
-if [ "`use ssl`" ]; then
- myconf="--enable-module=ssl"
-fi
- export RULE_EXPAT=NO
- try ./configure --prefix=/usr/local/httpd --bindir=/usr/bin \
- --sbindir=/usr/sbin --datadir=/usr/local/httpd \
- --sysconfdir=/etc/httpd --libexecdir=/usr/lib/apache \
- --mandir=/usr/share/man --logfiledir=/var/log/apache --localstatedir=/var/lock \
- --proxycachedir=/var/cache/httpd --includedir=/usr/include/apache \
- --enable-module=all \
- --enable-shared=max --suexec-caller=wwwrun \
- --suexec-userdir=public_html --suexec-uidmin=96 \
- --suexec-gidmin=96 --suexec-safepath="/bin:/usr/bin" \
- --disable-rule=EXPAT --with-perl=/usr/bin/perl ${myconf}
-# --disable-module=auth_dbm"
-
- try make
-if [ "`use ssl`" ]; then
- try make certificate TYPE=dummy
-fi
-}
-
-src_install() {
- try make install-quiet root=${D}
- dosed "s:/usr/local/bin/perl5:/usr/bin/perl:" /usr/local/httpd/htdocs/manual/search/manual-index.cgi
- cd ${D}/usr/sbin
- cp apachectl apachectl.orig
- sed -e "s:^PIDFILE.*:PIDFILE=/var/run/httpd.pid:" \
- apachectl.orig > apachectl
- rm apachectl.orig
- cd ${S}
- dodoc ABOUT_APACHE Announcement INSTALL* KEYS LICENSE* README* WARNING*
-if [ "`use ssl`" ];then
- docinto mod_ssl
- cd ../mod_ssl-${MSV}-${AV}
-fi
- dodoc ANNOUNCE CHANGES CREDITS INSTALL* LICENSE NEWS README*
- dodir /etc/rc.d/init.d
-
- insinto /etc/httpd
- doins ${FILESDIR}/httpd.conf
-
- exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/httpd.rc5 httpd
- dodir /etc/skel/public_html
-}
-
-pkg_config() {
-
- source ${ROOT}/etc/rc.d/config/functions
-
- if [ "$ServerName" = "" ]
- then
- ServerName=`uname -n`
- fi
- if [ "$ServerAdmin" = "" ]
-
- then
- ServerAdmin="webmaster\@$ServerName"
- fi
-
- # Make apache start at boot
- ${ROOT}/usr/sbin/rc-update add httpd
-
- # Set ServerName and ServerAdmin
- einfo "Setting Servername to $ServerName..."
- cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
- sed -e "s/^\#ServerName.*/ServerName $ServerName/" \
- -e "s/^ServerName.*/ServerName $ServerName/" \
- -e "s/^ServerAdmin.*/ServerAdmin $ServerAdmin/" \
- ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
-
-}
-
-pkg_prerm() {
-
- source ${ROOT}/etc/rc.d/config/functions
- if [ "$ROOT" = "/" ]
- then
- if [ -f /var/run/httpd.pid ]
- then
- einfo "Stopping running daemon..."
- /etc/rc.d/init.d/httpd stop
- fi
- fi
-
-}
-
diff --git a/net-www/apache/apache-1.3.20-r6.ebuild b/net-www/apache/apache-1.3.20-r6.ebuild
deleted file mode 100644
index 5a7fe40a7074..000000000000
--- a/net-www/apache/apache-1.3.20-r6.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.20-r6.ebuild,v 1.1 2001/09/06 08:00:57 woodchip Exp $
-
-AV="1.3.20"
-MSV="2.8.4"
-
-A="apache_${AV}.tar.gz mod_ssl-${MSV}-${AV}.tar.gz"
-S=${WORKDIR}/apache_${AV}
-DESCRIPTION="The Apache Web Server"
-HOMEPAGE="http://www.apache.org http://www.modssl.org"
-SRC_URI="http://httpd.apache.org/dist/httpd/apache_${AV}.tar.gz
- ftp://ftp.modssl.org/source/mod_ssl-${MSV}-${AV}.tar.gz"
-
-DEPEND="virtual/glibc
- >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-src_compile() {
-
- local myconf
- export SSL_BASE=SYSTEM
- export CFLAGS="${CFLAGS} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
- export RULE_EXPAT=NO
-
- if [ "`use ssl`" ]; then
- myconf="${myconf} --enable-module=ssl"
- cd ${S}/../mod_ssl-${MSV}-${AV}
- ./configure --with-apache=${S} --with-ssl=SYSTEM || die
- cd ${S}
- fi
-
- ./configure --prefix=/usr/local/httpd --bindir=/usr/bin \
- --sbindir=/usr/sbin --datadir=/usr/local/httpd \
- --sysconfdir=/etc/httpd --libexecdir=/usr/lib/apache \
- --mandir=/usr/share/man --logfiledir=/var/log/apache --localstatedir=/var/lock \
- --proxycachedir=/var/cache/httpd --includedir=/usr/include/apache \
- --enable-module=all \
- --enable-shared=max --suexec-caller=wwwrun \
- --suexec-userdir=public_html --suexec-uidmin=96 \
- --suexec-gidmin=96 --suexec-safepath="/bin:/usr/bin" \
- --disable-rule=EXPAT --with-perl=/usr/bin/perl ${myconf}
- assert "bad configure"
-
- make || die "compile problem"
- use ssl && ( make certificate TYPE=dummy || die "make ssl certificate failed" )
-}
-
-src_install() {
-
- make install-quiet root=${D} || die
- dodoc ABOUT_APACHE Announcement INSTALL* KEYS LICENSE* README* WARNING* ${FILESDIR}/httpd.conf
- dosed "s:^PIDFILE.*:PIDFILE=/var/run/httpd.pid:" /usr/sbin/apachectl
- dosed "s:/usr/local/bin/perl5:/usr/bin/perl:" \
- /usr/local/httpd/htdocs/manual/search/manual-index.cgi
-
- if [ "`use ssl`" ] ; then
- cd ../mod_ssl-${MSV}-${AV}
- docinto mod_ssl
- dodoc ANNOUNCE CHANGES CREDITS INSTALL* LICENSE NEWS README*
- fi
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/httpd.rc6 httpd
- insinto /etc/httpd
- doins ${FILESDIR}/httpd.conf
-}
-
-pkg_config() {
-
- #${ROOT}/sbin/rc-update add httpd default
-
- if [ "$ServerName" = "" ] ; then
- ServerName=`uname -n`
- fi
- if [ "$ServerAdmin" = "" ] ; then
- ServerAdmin="webmaster\@$ServerName"
- fi
-
- mv ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
- sed -e "s/^\#ServerName.*/ServerName $ServerName/" \
- -e "s/^ServerName.*/ServerName $ServerName/" \
- -e "s/^ServerAdmin.*/ServerAdmin $ServerAdmin/" \
- ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
-}
-
-pkg_prerm() {
-
- if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/httpd ] ; then
- /etc/init.d/httpd stop
- fi
- return # dont fail
-}
-
-pkg_preinst() {
-
- if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/httpd ] ; then
- /etc/init.d/httpd stop
- fi
- return # dont fail
-}
diff --git a/net-www/apache/files/digest-apache-1.3.20-r1 b/net-www/apache/files/digest-apache-1.3.20-r1
deleted file mode 100644
index 3327d8d67d25..000000000000
--- a/net-www/apache/files/digest-apache-1.3.20-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 d58d373b5f528a61a3490daec5e8f91f apache_1.3.20.tar.gz 1974272
-MD5 ff1a548c2387f123a3df4436a1e884f9 mod_ssl-2.8.4-1.3.20.tar.gz 753664
diff --git a/net-www/apache/files/digest-apache-1.3.20-r6 b/net-www/apache/files/digest-apache-1.3.20-r6
deleted file mode 100644
index 3327d8d67d25..000000000000
--- a/net-www/apache/files/digest-apache-1.3.20-r6
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 d58d373b5f528a61a3490daec5e8f91f apache_1.3.20.tar.gz 1974272
-MD5 ff1a548c2387f123a3df4436a1e884f9 mod_ssl-2.8.4-1.3.20.tar.gz 753664
diff --git a/net-www/apache/files/httpd.rc5 b/net-www/apache/files/httpd.rc5
deleted file mode 100644
index a2d9da0b897c..000000000000
--- a/net-www/apache/files/httpd.rc5
+++ /dev/null
@@ -1,121 +0,0 @@
-#!/bin/sh
-#RCUPDATE:3 4:75:This line is required for script management
-#
-
-. /etc/rc.d/config/functions
-. /etc/rc.d/config/basic
-
-# Apache control script designed to allow an easy command line interface
-# to controlling Apache. Written by Marc Slemko, 1997/08/23
-#
-# The exit codes returned are:
-# 0 - operation completed successfully
-# 1 -
-# 2 - usage error
-# 3 - httpd could not be started
-# 4 - httpd could not be stopped
-# 5 - httpd could not be started during a restart
-# 6 - httpd could not be restarted during a restart
-# 7 - httpd could not be restarted during a graceful restart
-# 8 - configuration syntax error
-#
-# When multiple arguments are given, only the error from the _last_
-# one is reported. Run "apachectl help" for usage info
-#
-#
-# |||||||||||||||||||| START CONFIGURATION SECTION ||||||||||||||||||||
-# -------------------- --------------------
-#
-# the path to your PID file
-PIDFILE=/var/run/httpd.pid
-#
-# the path to your httpd binary, including options if necessary
-HTTPD=/usr/sbin/httpd
-#
-# a command that outputs a formatted text version of the HTML at the
-# url given on the command line. Designed for lynx, however other
-# programs may work.
-LYNX="lynx -dump"
-#
-# the URL to your server's mod_status status page. If you do not
-# have one, then status and fullstatus will not work.
-STATUSURL="http://localhost/server-status"
-#
-# -------------------- --------------------
-# |||||||||||||||||||| END CONFIGURATION SECTION ||||||||||||||||||||
-
-ERROR=0
-ARGV="$@"
-
-if [ "x$ARGV" = "x" ] ; then
- ARGS="help"
-fi
-
-RUNNING=0
-check_pid() {
-
- # check for pidfile
- if [ -f $PIDFILE ] ; then
- PID=`cat $PIDFILE`
- if [ "x$PID" != "x" ] && kill -0 $PID 2>/dev/null ; then
- STATUS="httpd (pid $PID) running"
- RUNNING=1
- else
- STATUS="httpd (pid $PID?) not running"
- RUNNING=0
- fi
- else
- STATUS="httpd (no pid file) not running"
- RUNNING=0
- fi
-}
-
-SERVICE="Apache Webserver"
-opts="start stop restart status"
-
-start() {
- check_pid
- if [ $RUNNING -eq 1 ]; then
- echo "$0 $ARG: httpd (pid $PID) already running"
- break
- fi
- ebegin "Starting service $SERVICE"
- start-stop-daemon --quiet --start --exec $HTTPD -- $HTTPD_OPTS 1>&2
- eend $? "Error starting $SERVICE"
-}
-
-stop() {
- check_pid
- if [ $RUNNING -eq 0 ]; then
- echo "$0 $ARG: $STATUS"
- fi
- ebegin "Stopping service $SERVICE"
- start-stop-daemon --quiet --stop --pid $PIDFILE 1>&2
- eend $? "Error stopping $SERVICE"
-}
-
-restart () {
-
- stop
- start
-
-}
-
-status() {
- $LYNX $STATUSURL | awk ' /process$/ { print; exit } { print } '
-}
-
-fullstatus () {
- $LYNX $STATUSURL
-}
-
-configtest () {
- if $HTTPD -t; then
- :
- else
- ERROR=8
- fi
-}
-
-doservice ${@}
-
diff --git a/net-www/apache/files/httpd.rc6 b/net-www/apache/files/httpd.rc6
index f6ed8b3c9aaf..2fa1f042adbb 100644
--- a/net-www/apache/files/httpd.rc6
+++ b/net-www/apache/files/httpd.rc6
@@ -1,27 +1,15 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/httpd.rc6,v 1.6 2001/12/23 23:25:19 azarah Exp $
-
-# Config is in /etc/conf.d/httpd
-
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/httpd.rc6,v 1.7 2002/01/23 04:46:52 woodchip Exp $
depend() {
need net
}
-checkconfig() {
- if [ ! -e /etc/httpd/httpd.conf ] ; then
- eerror "You need an /etc/httpd/httpd.conf to run apache"
- eerror "There is a sample file in /usr/share/doc/apache"
- return 1
- fi
-}
-
start() {
- checkconfig || return 1
ebegin "Starting apache"
- start-stop-daemon --quiet --start --exec /usr/sbin/httpd -- $HTTPD_OPTS
+ start-stop-daemon --quiet --start --exec /usr/sbin/httpd -- ${HTTPD_OPTS}
eend $?
}