summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-08-05 03:06:41 +0000
committerAron Griffis <agriffis@gentoo.org>2004-08-05 03:06:41 +0000
commitb5fe204a72fab2dce734051b3cf501ee1708f182 (patch)
treed0a510d9acdf23a3307588f0f733da3fa1d4de6e /net-www
parentChanged to use installed dev-libs/expat rather than one that came with the pa... (diff)
downloadhistorical-b5fe204a72fab2dce734051b3cf501ee1708f182.tar.gz
historical-b5fe204a72fab2dce734051b3cf501ee1708f182.tar.bz2
historical-b5fe204a72fab2dce734051b3cf501ee1708f182.zip
Bring back mozilla-bin. It's been gone for two years. Having these mozilla.org-built versions in portage makes it easier to test differences between our builds and theirs. And nowadays they can both be installed simultaneously.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla-bin/ChangeLog14
-rw-r--r--net-www/mozilla-bin/Manifest6
-rw-r--r--net-www/mozilla-bin/files/digest-mozilla-bin-1.7.21
-rw-r--r--net-www/mozilla-bin/files/mozilla-bin-icon.pngbin0 -> 2350 bytes
-rw-r--r--net-www/mozilla-bin/files/mozilla-bin.desktop8
-rw-r--r--net-www/mozilla-bin/metadata.xml5
-rw-r--r--net-www/mozilla-bin/mozilla-bin-1.7.2.ebuild81
7 files changed, 115 insertions, 0 deletions
diff --git a/net-www/mozilla-bin/ChangeLog b/net-www/mozilla-bin/ChangeLog
new file mode 100644
index 000000000000..5710fb1f1aea
--- /dev/null
+++ b/net-www/mozilla-bin/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for net-www/mozilla-bin
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-bin/ChangeLog,v 1.1 2004/08/05 03:06:41 agriffis Exp $
+
+*mozilla-bin-1.7.2 (04 Aug 2004)
+
+ 04 Aug 2004; Aron Griffis <agriffis@gentoo.org> +metadata.xml,
+ +files/mozilla-bin-icon.png, +files/mozilla-bin.desktop,
+ +mozilla-bin-1.7.2.ebuild:
+ Bring back mozilla-bin. It's been gone for two years. Having these
+ mozilla.org-built versions in portage makes it easier to test differences
+ between our builds and theirs. And nowadays they can both be installed
+ simultaneously.
+
diff --git a/net-www/mozilla-bin/Manifest b/net-www/mozilla-bin/Manifest
new file mode 100644
index 000000000000..306bfb2a7808
--- /dev/null
+++ b/net-www/mozilla-bin/Manifest
@@ -0,0 +1,6 @@
+MD5 c2ee6333feed43b6ee14d7b2c1f08261 ChangeLog 637
+MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
+MD5 7d910849486b542006ed4368f032b0f7 mozilla-bin-1.7.2.ebuild 2117
+MD5 20d752803fe0a78a4167a6100d4209cb files/digest-mozilla-bin-1.7.2 85
+MD5 6d52ff4ce4567db1cad08ea40157a65d files/mozilla-bin-icon.png 2350
+MD5 4eac4e98b875ba3b652d6626756f5517 files/mozilla-bin.desktop 184
diff --git a/net-www/mozilla-bin/files/digest-mozilla-bin-1.7.2 b/net-www/mozilla-bin/files/digest-mozilla-bin-1.7.2
new file mode 100644
index 000000000000..16b216895080
--- /dev/null
+++ b/net-www/mozilla-bin/files/digest-mozilla-bin-1.7.2
@@ -0,0 +1 @@
+MD5 1e2f35f14e5032cdea7223819337b3d3 mozilla-i686-pc-linux-gnu-1.7.2.tar.gz 13810856
diff --git a/net-www/mozilla-bin/files/mozilla-bin-icon.png b/net-www/mozilla-bin/files/mozilla-bin-icon.png
new file mode 100644
index 000000000000..a176ed2c61af
--- /dev/null
+++ b/net-www/mozilla-bin/files/mozilla-bin-icon.png
Binary files differ
diff --git a/net-www/mozilla-bin/files/mozilla-bin.desktop b/net-www/mozilla-bin/files/mozilla-bin.desktop
new file mode 100644
index 000000000000..04a75f366641
--- /dev/null
+++ b/net-www/mozilla-bin/files/mozilla-bin.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mozilla (bin)
+Comment=Mozilla Application Suite
+Exec=/usr/bin/mozilla %U
+Icon=mozilla-bin-icon.png
+Terminal=false
+Type=Application
+Categories=Application;Network;
diff --git a/net-www/mozilla-bin/metadata.xml b/net-www/mozilla-bin/metadata.xml
new file mode 100644
index 000000000000..74d9257900cf
--- /dev/null
+++ b/net-www/mozilla-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mozilla</herd>
+</pkgmetadata>
diff --git a/net-www/mozilla-bin/mozilla-bin-1.7.2.ebuild b/net-www/mozilla-bin/mozilla-bin-1.7.2.ebuild
new file mode 100644
index 000000000000..5b8ffb6b891e
--- /dev/null
+++ b/net-www/mozilla-bin/mozilla-bin-1.7.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-bin/mozilla-bin-1.7.2.ebuild,v 1.1 2004/08/05 03:06:41 agriffis Exp $
+
+inherit nsplugins eutils mozilla-launcher
+
+IUSE=""
+
+# handle _rc versions
+MY_PV=${PV/_alpha/a} # handle alpha
+MY_PV=${MY_PV/_beta/b} # handle beta
+MY_PV=${MY_PV/_rc/rc} # handle rc
+
+MY_PN=${PN/-bin/}
+S=${WORKDIR}/mozilla
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+HOMEPAGE="http://www.mozilla.org"
+# Mirrors have it in one of the following places, depending on what
+# mirror you check and when you check it... :-(
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla${PV}/mozilla-i686-pc-linux-gnu-${PV}.tar.gz"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~x86 ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ =x11-libs/gtk+-1.2*
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ virtual/x11
+ >=net-www/mozilla-launcher-1.13"
+
+src_install() {
+ # Install mozilla in /opt
+ dodir /opt
+ mv ${S} ${D}/opt/mozilla
+
+ # Plugin path setup (rescuing the existing plugins)
+ src_mv_plugins /opt/mozilla/plugins
+
+ # Fixing permissions
+ chown -R root:root ${D}/opt/mozilla
+
+ # mozilla-launcher-1.8 supports -bin versions
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/mozilla-bin
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozilla-bin-icon.png
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozilla-bin.desktop
+}
+
+pkg_preinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/mozilla
+
+ # Remove the old plugins dir
+ pkg_mv_plugins ${MOZILLA_FIVE_HOME}/plugins
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/mozilla
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}