summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-01 21:31:37 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-01 21:31:37 +0000
commita492e41b3487c85f5fd49c5f7342947e1f28fb1c (patch)
tree86e5e8ef46a346edb7d1152dea8dd63cdba615ba /net-www
parentVersion bumped. (diff)
downloadhistorical-a492e41b3487c85f5fd49c5f7342947e1f28fb1c.tar.gz
historical-a492e41b3487c85f5fd49c5f7342947e1f28fb1c.tar.bz2
historical-a492e41b3487c85f5fd49c5f7342947e1f28fb1c.zip
Version bumped.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/horde-turba/Manifest4
-rw-r--r--net-www/horde-turba/files/digest-horde-turba-1.2.11
-rw-r--r--net-www/horde-turba/horde-turba-1.2.1.ebuild68
3 files changed, 71 insertions, 2 deletions
diff --git a/net-www/horde-turba/Manifest b/net-www/horde-turba/Manifest
index 79e07d6efec3..9f893faf1759 100644
--- a/net-www/horde-turba/Manifest
+++ b/net-www/horde-turba/Manifest
@@ -1,7 +1,7 @@
-MD5 b2d5b02df336d57dbe31ad71076916da ChangeLog 662
+MD5 3daed486deaa344af3cbf842829e4e3c ChangeLog 793
MD5 7992e6996cbdbeaf5150c6a6029ce1db horde-turba-1.1.ebuild 2420
MD5 e2e1b601a163302d2354571982351b43 horde-turba-1.2.ebuild 1924
-MD5 056a1d56ea0bf0f84265f4788781f324 horde-turba-1.2.1.ebuild 1924
+MD5 3612cf8aa979b482fde291cc859f34c0 horde-turba-1.2.1.ebuild 1926
MD5 f3018d21fa59ceba6a6b2062f16734ed files/digest-horde-turba-1.1 62
MD5 10da92ad2d67b2b5393a1ce281e74a85 files/digest-horde-turba-1.2 61
MD5 c040f6dc39be9087c0815f2eb07dbf27 files/digest-horde-turba-1.2.1 63
diff --git a/net-www/horde-turba/files/digest-horde-turba-1.2.1 b/net-www/horde-turba/files/digest-horde-turba-1.2.1
new file mode 100644
index 000000000000..1e8ef72a9878
--- /dev/null
+++ b/net-www/horde-turba/files/digest-horde-turba-1.2.1
@@ -0,0 +1 @@
+MD5 1101266f404db0f4639cf41c25a64c35 turba-1.2.1.tar.gz 482633
diff --git a/net-www/horde-turba/horde-turba-1.2.1.ebuild b/net-www/horde-turba/horde-turba-1.2.1.ebuild
new file mode 100644
index 000000000000..4d51412314e6
--- /dev/null
+++ b/net-www/horde-turba/horde-turba-1.2.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/horde-turba-1.2.1.ebuild,v 1.1 2003/10/01 21:31:31 mholzer Exp $
+
+DESCRIPTION="Turba ${PV} is the Horde address book / contact management program"
+HOMEPAGE="http://www.horde.org"
+MY_P=${P/horde-/}
+SRC_URI="ftp://ftp.horde.org/pub/turba/tarballs/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2.4"
+IUSE=""
+S=${WORKDIR}/${MY_P}
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
+ GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
+ return 0
+ else
+ eerror "Missing SQL or LDAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+ dodir ${HTTPD_ROOT}/horde/turba
+ cp -r . ${D}/${HTTPD_ROOT}/horde/turba
+
+ # protecting files
+ chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/turba
+ find ${D}/${HTTPD_ROOT}/horde/turba/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/turba/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ einfo "Please read ${HTTPD_ROOT}/horde/turba/docs/INSTALL !"
+}