summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-19 20:04:31 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-19 20:04:31 +0000
commit9b3f41d715881e4eb641a3f29676ac8a815adff0 (patch)
tree217f9f78074e41ef9891a4514aee17cbb009ccd3 /net-www
parentfix for #10799 (diff)
downloadhistorical-9b3f41d715881e4eb641a3f29676ac8a815adff0.tar.gz
historical-9b3f41d715881e4eb641a3f29676ac8a815adff0.tar.bz2
historical-9b3f41d715881e4eb641a3f29676ac8a815adff0.zip
Added mozilla-plugin compatibility.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phoenix-bin/ChangeLog11
-rw-r--r--net-www/phoenix-bin/files/digest-phoenix-bin-0.4-r21
-rw-r--r--net-www/phoenix-bin/phoenix-bin-0.4-r2.ebuild54
3 files changed, 65 insertions, 1 deletions
diff --git a/net-www/phoenix-bin/ChangeLog b/net-www/phoenix-bin/ChangeLog
index 859642afff11..34935d21499a 100644
--- a/net-www/phoenix-bin/ChangeLog
+++ b/net-www/phoenix-bin/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/phoenix-bin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/ChangeLog,v 1.8 2002/11/17 14:21:19 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/ChangeLog,v 1.9 2002/11/19 20:04:31 phoenix Exp $
+
+*phoenix-bin-0.4-r1 (19 Nov 2002)
+
+ 19 Nov 2002; phoen][x <phoenix@gentoo.org> phoenix-bin-0.4-r2.ebuild
+ files/digest-phoenix-bin0.4-r2 :
+ Made phoenix mozilla plugin compliant. The new plugin layout for
+ phoenix and mozilla is: All plugins go to /usr/share/mozilla/plugins
+ and the browsers plugins/ dir is symlinked to that very directory.
+ Check bug #10056 for further details.
*phoenix-bin-0.4-r1 (17 Nov 2002)
diff --git a/net-www/phoenix-bin/files/digest-phoenix-bin-0.4-r2 b/net-www/phoenix-bin/files/digest-phoenix-bin-0.4-r2
new file mode 100644
index 000000000000..f0908313af1f
--- /dev/null
+++ b/net-www/phoenix-bin/files/digest-phoenix-bin-0.4-r2
@@ -0,0 +1 @@
+MD5 102fc4ac90a61b81dc99432d051449a0 phoenix-0.4-i686-pc-linux-gnu.tar.gz 9568682
diff --git a/net-www/phoenix-bin/phoenix-bin-0.4-r2.ebuild b/net-www/phoenix-bin/phoenix-bin-0.4-r2.ebuild
new file mode 100644
index 000000000000..d06000b55f86
--- /dev/null
+++ b/net-www/phoenix-bin/phoenix-bin-0.4-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/phoenix-bin-0.4-r2.ebuild,v 1.1 2002/11/19 20:04:31 phoenix Exp $
+
+IUSE=""
+
+MY_PN=${PN/-bin/}
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="The Phoenix Web Browser"
+SRC_URI="http://ftp.mozilla.org/pub/${MY_PN}/releases/${PV}/${MY_PN}-${PV}-i686-pc-linux-gnu.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/phoenix/"
+RESTRICT="nostrip"
+
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-libs/lib-compat-1.0-r2
+ >=x11-libs/gtk+-1.2.10-r9
+ virtual/x11"
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/share/mozilla/plugins"
+ mkdir -p ${D}/${PLUGIN_DIR}
+
+ dodir /usr/lib
+
+ mv ${S} ${D}/usr/lib
+
+ # Plugin path setup (rescuing the existent plugins)
+ mv ${D}/usr/lib/${MY_PN}/plugins ${D}/usr/lib/${MY_PN}/plugins.temp
+ dosym ${PLUGIN_DIR} /usr/lib/${MY_PN}/
+ mv ${D}/usr/lib/${MY_PN}/plugins.temp/* ${D}/usr/lib/${MY_PN}/plugins/
+ rmdir ${D}/usr/lib/${MY_PN}/plugins.temp
+
+ # Fixing permissions
+ chown -R root.root ${D}/usr/lib/${MY_PN}
+
+ # Truetype fonts
+ cd ${D}/usr/lib/${MY_PN}/defaults/pref
+ einfo "Enabling truetype fonts"
+ patch < ${FILESDIR}/phoenix-0.4-antialiasing-patch
+
+ # Misc stuff
+ dobin ${FILESDIR}/phoenix
+ dosym /usr/lib/libstdc++-libc6.1-1.so.2 /usr/lib/${MY_PN}/libstdc++-libc6.2-2.so.3
+}
+
+pkg_preinst() {
+ # Remove the old plugins dir
+ [ -d /usr/lib/phoenix/plugins ] && rm -r /usr/lib/phoenix/plugins
+}