summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-03 19:48:24 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-03 19:48:24 +0000
commit7f494fbe18e3efb1d39d5f8d05f383f59cceb8b2 (patch)
tree11bf0044e73759d1fabaf430cd9399d1302f49ab /net-www
parentversion bump (diff)
downloadhistorical-7f494fbe18e3efb1d39d5f8d05f383f59cceb8b2.tar.gz
historical-7f494fbe18e3efb1d39d5f8d05f383f59cceb8b2.tar.bz2
historical-7f494fbe18e3efb1d39d5f8d05f383f59cceb8b2.zip
version bump
Diffstat (limited to 'net-www')
-rw-r--r--net-www/links/Manifest4
-rw-r--r--net-www/links/links-2.1_pre14.ebuild123
2 files changed, 125 insertions, 2 deletions
diff --git a/net-www/links/Manifest b/net-www/links/Manifest
index a91d663c73cc..d2abcbb3d886 100644
--- a/net-www/links/Manifest
+++ b/net-www/links/Manifest
@@ -1,8 +1,8 @@
MD5 62c2cb8d4841bab0f3b7bb9d0d5f270f links-0.96-r2.ebuild 1200
-MD5 8b00dcb2c13e809f531b430e3f95fef6 links-2.1_pre14.ebuild 3358
+MD5 4e849e6d4b831a037b7ebd48f7855d1c links-2.1_pre14.ebuild 3364
MD5 529b2dcf6e5e100a0f6120cf7ac35a60 links-2.1_pre9.ebuild 3154
MD5 1165fadfdfad4adbb952b621e4ebed0b links-2.1_pre11.ebuild 3356
-MD5 da596e3a96b5fe96f198f7d7c9bda186 ChangeLog 7225
+MD5 0027d6a4148348f27d54e4bddeb6bff0 ChangeLog 7422
MD5 8b00dcb2c13e809f531b430e3f95fef6 links-2.1_pre13.ebuild 3358
MD5 52bed2c64a669feed86577cb52f8cbb5 files/links-0.96-r2-gentoo.patch 1400
MD5 e8eedeca8d9b94ce7cc0e5f919500740 files/digest-links-2.1_pre9 67
diff --git a/net-www/links/links-2.1_pre14.ebuild b/net-www/links/links-2.1_pre14.ebuild
new file mode 100644
index 000000000000..11598894fa58
--- /dev/null
+++ b/net-www/links/links-2.1_pre14.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.1_pre14.ebuild,v 1.1 2003/12/03 19:48:23 seemant Exp $
+
+IUSE="ssl javascript png X gpm tiff fbcon svga jpeg"
+
+DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
+
+# To handle pre-version ...
+MYP="${P/_/}"
+S="${WORKDIR}/${MYP}"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ javascript? ( >=sys-devel/flex-2.5.4a )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3 >=media-libs/libpng-1.2.1 )
+ X? ( virtual/x11 >=media-libs/libpng-1.2.1 )
+ directfb? ( dev-libs/DirectFB )
+ fbcon? ( >=media-libs/libpng-1.2.1 sys-libs/gpm )"
+
+PROVIDE="virtual/textbrowser"
+
+pkg_setup (){
+
+ if [ ! `use gpm` ] && [ `use fbcon` ] ; then
+ einfo
+ einfo "gpm has been installed since you have included fbcon in your USE flags."
+ einfo "The links framebuffer driver requires gpm in order to compile."
+ einfo
+ fi
+
+}
+
+src_compile (){
+
+ local myconf
+ myconf="--program-suffix=2"
+
+ use X \
+ && myconf="${myconf} --enable-graphics --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use png \
+ && myconf="${myconf} --with-libpng" \
+ || myconf="${myconf} --without-libpng"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ use svga \
+ && myconf="${myconf} --enable-graphics --with-svgalib" \
+ || myconf="${myconf} --without-svgalib"
+
+ use fbcon \
+ && myconf="${myconf} --enable-graphics --with-fb" \
+ || myconf="${myconf} --without-fb"
+
+ use directfb \
+ && myconf="${myconf} --enable-graphics --with-directfb" \
+ || myconf="${myconf} --without-directfb"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use javascript \
+ && myconf="${myconf} --enable-javascript" \
+ || myconf="${myconf} --disable-javascript"
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so if
+ # 'sys-libs/gpm' is compiled on your system, you'll compile links
+ # with gpm support ...
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install (){
+ einstall
+
+ if [ ! -f /usr/bin/links ]
+ then
+ dosym links2 /usr/bin/links
+ fi
+
+ # Only install links icon if X driver was compiled in ...
+ use X && { insinto /usr/share/pixmaps ; doins graphics/links.xpm ; }
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES TODO
+ dohtml doc/links_cal/*
+}
+
+
+pkg_postinst() {
+
+ if use svga
+ then
+ einfo "You had the svga USE flag enabled, but for security reasons"
+ einfo "the links2 binary is NOT setuid by default. In order to"
+ einfo "enable links2 to work in SVGA, please change the permissions"
+ einfo "of /usr/bin/links2 to enable suid."
+ fi
+}