summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-01-14 21:36:04 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-01-14 21:36:04 +0000
commit23b7da553dd0fdbb043fe024ade394ae7049d9fd (patch)
treefdd75bffe6ed79fb29aedcaadc532debc317e11a /net-www
parentAdd missing depend on pkgconfig, bug 151171 (diff)
downloadhistorical-23b7da553dd0fdbb043fe024ade394ae7049d9fd.tar.gz
historical-23b7da553dd0fdbb043fe024ade394ae7049d9fd.tar.bz2
historical-23b7da553dd0fdbb043fe024ade394ae7049d9fd.zip
Cleanup.
Package-Manager: portage-2.1.2_rc4-r8
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_watch/ChangeLog9
-rw-r--r--net-www/mod_watch/mod_watch-3.18-r2.ebuild25
-rw-r--r--net-www/mod_watch/mod_watch-4.03-r2.ebuild26
-rw-r--r--net-www/mod_xslt/ChangeLog8
-rw-r--r--net-www/mod_xslt/metadata.xml2
-rw-r--r--net-www/mod_xslt/mod_xslt-2.0.4.ebuild18
6 files changed, 50 insertions, 38 deletions
diff --git a/net-www/mod_watch/ChangeLog b/net-www/mod_watch/ChangeLog
index f36f90f9ab1c..bd64ee0ccb29 100644
--- a/net-www/mod_watch/ChangeLog
+++ b/net-www/mod_watch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_watch
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/ChangeLog,v 1.15 2006/06/06 09:56:00 hollow Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/ChangeLog,v 1.16 2007/01/14 21:31:33 chtekk Exp $
+
+ 14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
+ -mod_watch-3.18-r1.ebuild, mod_watch-3.18-r2.ebuild,
+ -mod_watch-4.03-r1.ebuild, mod_watch-4.03-r2.ebuild:
+ Cleanup.
*mod_watch-4.03-r2 (06 Jun 2006)
*mod_watch-3.18-r2 (06 Jun 2006)
diff --git a/net-www/mod_watch/mod_watch-3.18-r2.ebuild b/net-www/mod_watch/mod_watch-3.18-r2.ebuild
index 8e985ef0c636..3dd5cbcca202 100644
--- a/net-www/mod_watch/mod_watch-3.18-r2.ebuild
+++ b/net-www/mod_watch/mod_watch-3.18-r2.ebuild
@@ -1,23 +1,25 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-3.18-r2.ebuild,v 1.1 2006/06/06 09:56:00 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-3.18-r2.ebuild,v 1.2 2007/01/14 21:31:33 chtekk Exp $
inherit apache-module
-DESCRIPTION="Bandwidth graphing for Apache with MRTG"
-HOMEPAGE="http://www.snert.com/Software/mod_watch/"
-KEYWORDS="~x86"
-
-MY_V=${PV/./}
-SRC_URI="http://www.snert.com/Software/download/${PN}${MY_V}.tgz"
+KEYWORDS="x86"
-IUSE=""
+DESCRIPTION="Bandwidth graphing module for Apache1 with MRTG."
+HOMEPAGE="http://www.snert.com/Software/mod_watch/"
+SRC_URI="http://www.snert.com/Software/download/${PN}${PV/./}.tgz"
LICENSE="as-is"
SLOT="1"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APXS1_ARGS="-c ${PN}.c Memory.c Mutex.c Shared.c SharedHash.c NetworkTable.c"
APACHE1_MOD_CONF="77_mod_watch"
APACHE1_MOD_DEFINE="WATCH"
-APXS1_ARGS="-c mod_watch.c Memory.c Mutex.c Shared.c SharedHash.c NetworkTable.c"
DOCFILES="CHANGES.TXT LICENSE.TXT"
@@ -25,7 +27,7 @@ need_apache1
src_compile() {
sed -i -e "s:/usr/local/sbin:/usr/sbin:" \
- apache2mrtg.pl || die "Path fixing failed."
+ apache2mrtg.pl || die "Path fixing failed"
apache1_src_compile
}
@@ -33,4 +35,5 @@ src_compile() {
src_install() {
apache1_src_install
dosbin apache2mrtg.pl mod_watch.pl
+ keepdir "${ROOT}"/var/lib/${PN}
}
diff --git a/net-www/mod_watch/mod_watch-4.03-r2.ebuild b/net-www/mod_watch/mod_watch-4.03-r2.ebuild
index c0577eac8ab7..13bb0c7584a8 100644
--- a/net-www/mod_watch/mod_watch-4.03-r2.ebuild
+++ b/net-www/mod_watch/mod_watch-4.03-r2.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-4.03-r2.ebuild,v 1.1 2006/06/06 09:56:00 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-4.03-r2.ebuild,v 1.2 2007/01/14 21:31:33 chtekk Exp $
-inherit eutils apache-module
+inherit apache-module
-MY_V=${PV/./}
+KEYWORDS="ppc x86"
-DESCRIPTION="Bandwidth graphing for Apache with MRTG"
+DESCRIPTION="Bandwidth graphing module for Apache2 with MRTG."
HOMEPAGE="http://www.snert.com/Software/mod_watch/"
-SRC_URI="http://www.snert.com/Software/download/${PN}${MY_V}.tgz"
-
-KEYWORDS="~ppc ~x86"
-DEPEND=""
+SRC_URI="http://www.snert.com/Software/download/${PN}${PV/./}.tgz"
LICENSE="as-is"
SLOT="0"
IUSE=""
+DEPEND=""
+RDEPEND=""
+
S="${WORKDIR}/${PN}-4.3"
APACHE2_MOD_CONF="77_mod_watch"
@@ -29,16 +29,16 @@ src_compile() {
sed -i \
-e "s:APXS=\\(.*\\):APXS=${APXS2} # \\1:" \
-e "s:APACHECTL=\\(.*\\):APACHECTL=${APACHECTL2} # \\1:" \
- Makefile.dso || die "Path fixing failed."
+ Makefile.dso || die "Path fixing failed"
sed -i -e "s:/usr/local/sbin:/usr/sbin:" \
- apache2mrtg.pl || die "Path fixing failed."
+ apache2mrtg.pl || die "Path fixing failed"
- emake -f Makefile.dso build || die "Make failed."
+ emake -f Makefile.dso build || die "emake failed"
}
src_install() {
apache2_src_install
dosbin apache2mrtg.pl mod_watch.pl Contrib/mod_watch_list.pl
- keepdir /var/lib/mod_watch
+ keepdir "${ROOT}"/var/lib/${PN}
}
diff --git a/net-www/mod_xslt/ChangeLog b/net-www/mod_xslt/ChangeLog
index ad637d05e0c8..f051bdf62f03 100644
--- a/net-www/mod_xslt/ChangeLog
+++ b/net-www/mod_xslt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mod_xslt
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/ChangeLog,v 1.21 2006/06/05 18:41:13 chtekk Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/ChangeLog,v 1.22 2007/01/14 21:36:04 chtekk Exp $
+
+ 14 Jan 2007; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
+ mod_xslt-2.0.4.ebuild:
+ Cleanup.
05 Jun 2006; Luca Longinotti <chtekk@gentoo.org>
-files/mod-xslt-1.0.5a-debug.patch, -files/mod_xslt-1.0.5a-register.patch,
diff --git a/net-www/mod_xslt/metadata.xml b/net-www/mod_xslt/metadata.xml
index 8f398d815b6c..a1f5ceff2352 100644
--- a/net-www/mod_xslt/metadata.xml
+++ b/net-www/mod_xslt/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>apache</herd>
<maintainer>
- <email>apache-bugs@gentoo.org</email>
+ <email>apache-bugs@gentoo.org</email>
</maintainer>
</pkgmetadata>
diff --git a/net-www/mod_xslt/mod_xslt-2.0.4.ebuild b/net-www/mod_xslt/mod_xslt-2.0.4.ebuild
index e521f181526a..59a2a78171a4 100644
--- a/net-www/mod_xslt/mod_xslt-2.0.4.ebuild
+++ b/net-www/mod_xslt/mod_xslt-2.0.4.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/mod_xslt-2.0.4.ebuild,v 1.11 2006/06/05 18:41:13 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/mod_xslt-2.0.4.ebuild,v 1.12 2007/01/14 21:36:04 chtekk Exp $
-inherit eutils apache-module
+inherit apache-module
-DESCRIPTION="An xslt filtering DSO module for Apache2."
+KEYWORDS="amd64 ppc x86"
+
+DESCRIPTION="An XSLT filtering module for Apache2."
HOMEPAGE="http://www.mod-xslt.com/"
SRC_URI="mirror://sourceforge/mod-xslt/${PN}.${PV}.tgz"
-
LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
SLOT="0"
+IUSE=""
RDEPEND="dev-libs/libxslt
- dev-libs/libxml2"
+ dev-libs/libxml2"
DEPEND="${RDEPEND}
dev-lang/perl"
@@ -23,7 +23,7 @@ S="${WORKDIR}/${PN}.${PV}"
APXS2_ARGS="-I/usr/include/libxml2 -lxslt -lxml2 -lpthread -lz -lm -c ${PN}.c"
-APACHE2_MOD_CONF="25_mod_xslt"
+APACHE2_MOD_CONF="25_${PN}"
APACHE2_MOD_DEFINE="XSLT"
DOCFILES="ChangeLog.txt README.txt"