summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-30 13:23:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-30 13:23:31 +0000
commit0aac2212983a605e9ac8bde4f6d6968ced8d5e33 (patch)
tree61cb41028de435a51d687649105a6fa0184bd53b /net-www
parentupdate to 0.2.10 (diff)
downloadhistorical-0aac2212983a605e9ac8bde4f6d6968ced8d5e33.tar.gz
historical-0aac2212983a605e9ac8bde4f6d6968ced8d5e33.tar.bz2
historical-0aac2212983a605e9ac8bde4f6d6968ced8d5e33.zip
De-bloated the galeon install process somewhat by removing the gnome-core required dependency.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon/ChangeLog13
-rw-r--r--net-www/galeon/files/digest-galeon-1.2.0-r21
-rw-r--r--net-www/galeon/galeon-1.2.0-r2.ebuild71
3 files changed, 82 insertions, 3 deletions
diff --git a/net-www/galeon/ChangeLog b/net-www/galeon/ChangeLog
index 8a9b7dcb62f5..15c68d1b187a 100644
--- a/net-www/galeon/ChangeLog
+++ b/net-www/galeon/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/galeon
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.3 2002/03/23 22:38:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.4 2002/03/30 13:23:31 seemant Exp $
+
+*galeon-1.2.0-r2 (30 Mar 2002)
+
+ 30 Mar 2002; Seemant Kulleen <seemant@gentoo.org> galeon-1.2.0-r2.ebuild :
+
+ The big de-bloating! gnome-core is actually NOT a required a dependency,
+ which means, non gnome users can use galeon with only the following GNOME
+ components: gnome-libs, gnome-vfs, oaf (and by extension ORBit), libxml.
+ And, libglade and gdk-pixbuf may be compiled without GNOME-support.
*galeon-1.2.0-r1 (23 Mar 2002)
@@ -15,5 +24,3 @@
New stable release of galeon. (Note to developers: galeon changed the
way it deals with installing gconfd schemas)
-
-
diff --git a/net-www/galeon/files/digest-galeon-1.2.0-r2 b/net-www/galeon/files/digest-galeon-1.2.0-r2
new file mode 100644
index 000000000000..bd8672c095b2
--- /dev/null
+++ b/net-www/galeon/files/digest-galeon-1.2.0-r2
@@ -0,0 +1 @@
+MD5 766744240a9e06f9aad427c2e6e214f2 galeon-1.2.0.tar.gz 3921182
diff --git a/net-www/galeon/galeon-1.2.0-r2.ebuild b/net-www/galeon/galeon-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..f550cec23a71
--- /dev/null
+++ b/net-www/galeon/galeon-1.2.0-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.0-r2.ebuild,v 1.1 2002/03/30 13:23:31 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small web-browser for gnome that uses mozillas render engine"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz
+ http://prdownloads.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://galeon.sourceforge.net"
+
+DEPEND="~net-www/mozilla-0.9.9
+ >=gnome-base/gnome-libs-1.4.1.4
+ >=gnome-base/libglade-0.17-r1
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/gconf-1.0.7-r2
+ >=gnome-base/oaf-0.6.7
+ >=dev-libs/libxml-1.8.16
+ >=media-libs/gdk-pixbuf-0.16.0-r1
+ bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use bonobo && myconf="${myconf} --enable-gnome-file-selector"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-mozilla-libs=${MOZILLA_FIVE_HOME} \
+ --with-mozilla-includes=${MOZILLA_FIVE_HOME}/include \
+ --without-debug \
+ --disable-applet \
+ --disable-install-schemas \
+ --enable-nautilus-view=auto \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # galeon-config-tool was rewritten for 1.2.0 and causes sandbox
+ # violations if gconfd is shut down... The schemas seem to install
+ # fine without it (at least it seems like it... *sigh*)
+ #gconftool --shutdown
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING* FAQ NEWS README TODO THANKS
+}
+
+pkg_postinst() {
+
+ galeon-config-tool --fix-gconf-permissions
+ galeon-config-tool --pkg-install-schemas
+ scrollkeeper-update
+
+}
+