summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-25 16:10:25 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-25 16:10:25 +0000
commitff93ef3cc565dd3956d10de40ca5c8c797b15af9 (patch)
tree73a9e912dfda423e9fd63a5d9dd4ffdc42bcc5a2 /net-www/mozilla
parentlove thy libc (diff)
downloadhistorical-ff93ef3cc565dd3956d10de40ca5c8c797b15af9.tar.gz
historical-ff93ef3cc565dd3956d10de40ca5c8c797b15af9.tar.bz2
historical-ff93ef3cc565dd3956d10de40ca5c8c797b15af9.zip
QA - fix use invocation
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/ChangeLog5
-rw-r--r--net-www/mozilla/mozilla-1.6-r1.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 0192649e8503..67a68698faa4 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/mozilla
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.177 2004/06/25 01:05:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.178 2004/06/25 16:00:39 agriffis Exp $
+
+ 25 Jun 2004; Aron Griffis <agriffis@gentoo.org> mozilla-1.6-r1.ebuild:
+ QA - fix use invocation
22 Jun 2004; Brad Laue <brad@gentoo.org> files/icon/mozilla.desktop,
mozilla-1.7.ebuild:
diff --git a/net-www/mozilla/mozilla-1.6-r1.ebuild b/net-www/mozilla/mozilla-1.6-r1.ebuild
index 58cebc8511ad..364a337b42db 100644
--- a/net-www/mozilla/mozilla-1.6-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.6-r1.ebuild,v 1.12 2004/06/25 01:05:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.6-r1.ebuild,v 1.13 2004/06/25 16:00:39 agriffis Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome debug xinerama"
# Internal USE flags that I do not really want to advertise ...
@@ -157,7 +157,7 @@ src_unpack() {
unset WANT_AUTOCONF
# Unpack the enigmail plugin
- if [ -n "`use crypt`" -a -z "`use moznomail`" ]
+ if use crypt && ! use moznomail
then
mv -f ${WORKDIR}/ipc ${S}/extensions/
mv -f ${WORKDIR}/enigmail ${S}/extensions/
@@ -205,7 +205,7 @@ src_compile() {
# Currently --enable-elf-dynstr-gc only works for x86 and ppc,
# thanks to Jason Wever <weeve@gentoo.org> for the fix.
- if [ -n "`use x86`" -o -n "`use ppc`" ]
+ if use x86 || use ppc
then
myconf="${myconf} --enable-elf-dynstr-gc"
fi
@@ -304,7 +304,7 @@ src_compile() {
then
myconf="${myconf} --disable-mailnews"
fi
- if [ -n "`use moznocompose`" -a -n "`use moznomail`" ]
+ if use moznocompose && use moznomail
then
myconf="${myconf} --disable-composer"
fi
@@ -418,7 +418,7 @@ src_compile() {
# *********************************************************************
# Build the enigmail plugin
- if [ -n "`use crypt`" -a -z "`use moznomail`" ]
+ if use crypt && ! use moznomail
then
einfo "Building Enigmail plugin..."
cd ${S}/extensions/ipc