summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-11-23 01:02:03 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-11-23 01:02:03 +0000
commitb1b5b95b6099e0cfd707de36e88df6971f7e721f (patch)
tree7cd2279c26094717adffafb766530c42f69a9b64 /net-www/mozilla
parentadded env.d file for multi-kdelibs-conforming 2.2.2 (diff)
downloadhistorical-b1b5b95b6099e0cfd707de36e88df6971f7e721f.tar.gz
historical-b1b5b95b6099e0cfd707de36e88df6971f7e721f.tar.bz2
historical-b1b5b95b6099e0cfd707de36e88df6971f7e721f.zip
New version of Mozilla , 0.9.6
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/files/digest-mozilla-0.9.61
-rw-r--r--net-www/mozilla/mozilla-0.9.6.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/net-www/mozilla/files/digest-mozilla-0.9.6 b/net-www/mozilla/files/digest-mozilla-0.9.6
new file mode 100644
index 000000000000..daac8dec0fb0
--- /dev/null
+++ b/net-www/mozilla/files/digest-mozilla-0.9.6
@@ -0,0 +1 @@
+MD5 f3faa4ec9674d649b2adeba1c3b83d6e mozilla-source-0.9.6.tar.gz 35303424
diff --git a/net-www/mozilla/mozilla-0.9.6.ebuild b/net-www/mozilla/mozilla-0.9.6.ebuild
new file mode 100644
index 000000000000..3da1844ad937
--- /dev/null
+++ b/net-www/mozilla/mozilla-0.9.6.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-0.9.6.ebuild,v 1.1 2001/11/23 01:02:03 verwilst Exp $
+
+S=${WORKDIR}/mozilla
+DESCRIPTION="The Mozilla web browser"
+
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla${PV}/src/${PN}-source-${PV}.tar.gz"
+HOMEPAGE="http://www.mozilla.org"
+
+PROVIDE="virtual/x11-web-browser"
+
+RDEPEND=">=gnome-base/ORBit-0.5.10-r1
+ >=dev-libs/glib-1.2.10
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.9
+ app-arch/zip
+ app-arch/unzip
+ mozqt? ( x11-libs/qt-x11 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl"
+
+
+src_compile() {
+
+ export MOZILLA_OFFICIAL=1
+ export BUILD_OFFICIAL=1
+
+ chown -R root.root *
+
+ if [ "`use mozqt`" ] ; then
+ myconf="--with-qt --enable-toolkit=qt --without-gtk"
+ else
+ myconf="--with-gtk --enable-toolkit=gtk"
+ fi
+
+ if [ -z "$DEBUG" ] ; then
+ myconf="${myconf} --enable-strip-libs"
+ fi
+
+ export BUILD_MODULES=all
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr/lib/mozilla \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-pedantic \
+ --enable-xsl \
+ --enable-crypto \
+ --enable-detect-webshell-leaks \
+ --with-java-supplement \
+ --with-extensions=default \
+ --enable-optimize=-O2 \
+ --with-default-mozilla-five-home=/usr/lib/mozilla \
+ ${myconf} || die
+
+ make depend || die
+ make || die
+}
+
+src_install() {
+
+ dodir /usr/lib/mozilla/include
+ cd ${S}/dist/include
+ cp -LfR * ${D}/usr/lib/mozilla/include
+# rm ${D}/usr/lib/mozilla/include/*.h
+
+# cd ${S}/include
+# cp -f *.h ${D}/usr/lib/mozilla/include
+# cp -f nspr/*.h ${D}/usr/lib/mozilla/include/nspr
+# cp -f nspr/obsolete/*.h ${D}/usr/lib/mozilla/include/nspr/obsolete
+# cp -f nspr/private/*.h ${D}/usr/lib/mozilla/include/nspr/private
+# cp -f nspr/md/*.cfg ${D}/usr/lib/mozilla/include/nspr/md
+
+ cd ${S}/xpinstall/packager
+ make || die
+ dodir /usr/lib
+
+ tar xzf ${S}/dist/mozilla-`uname -m`-pc-linux-gnu.tar.gz \
+ -C ${D}/usr/lib
+
+# mv ${D}/usr/lib/package ${D}/usr/lib/mozilla
+ exeinto /usr/bin
+ doexe ${FILESDIR}/mozilla
+ insinto /etc/env.d
+ doins ${FILESDIR}/10mozilla
+ dodoc LEGAL LICENSE README/mozilla/README*
+
+ # Take care of non root execution
+ # (seems the problem is that not all files are readible by the user)
+ chmod -R g+r,o+r ${D}/usr/lib/mozilla
+
+ # Install icon and .desktop for menu entry
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${S}/build/package/rpm/SOURCES/mozilla-icon.png
+ insinto /usr/share/gnome/apps/Internet
+ doins ${S}/build/package/rpm/SOURCES/mozilla.desktop
+ fi
+
+ # Fix to get it removed at unmerge
+ touch ${D}/usr/lib/mozilla/component.reg
+}
+
+pkg_postinst () {
+
+ # Take care of component registration
+ export MOZILLA_FIVE_HOME="/usr/lib/mozilla"
+
+ # Needed to update the run time bindings for REGXPCOM
+ # (do not remove next line!)
+ env-update
+ # Register components, setup Chrome .rdf files and fix file permissions
+ /usr/lib/mozilla/regxpcom
+ chmod g+r,o+r /usr/lib/mozilla/component.reg
+ /usr/lib/mozilla/regchrome
+ find /usr/lib/mozilla -type d -perm 0700 -exec chmod 755 {} \; || :
+
+
+ echo
+ echo "*****************************************************************"
+ echo "* NB: Please unmerge old versions prior to 0.9.5 as the header *"
+ echo "* layout in /usr/lib/mozilla/include have changed and will *"
+ echo "* result in compile errors when compiling programs that need *"
+ echo "* mozilla headers and libs (galeon, nautilus, ...) *"
+ echo "*****************************************************************"
+ echo
+}
+