summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-04-14 02:13:30 +0000
committerChuck Short <zul@gentoo.org>2004-04-14 02:13:30 +0000
commit7abbea153a8975e8225d791bc6c7955518656ef1 (patch)
tree634ddd40cf857419798a6d4797de47d133a50cf6 /net-www/mod_ssl
parentRemoved old versions of mod_ssl since we removed old version of apache-1.3.*,... (diff)
downloadhistorical-7abbea153a8975e8225d791bc6c7955518656ef1.tar.gz
historical-7abbea153a8975e8225d791bc6c7955518656ef1.tar.bz2
historical-7abbea153a8975e8225d791bc6c7955518656ef1.zip
Fixes booboo.
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/Manifest2
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.161
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.16.ebuild75
3 files changed, 78 insertions, 0 deletions
diff --git a/net-www/mod_ssl/Manifest b/net-www/mod_ssl/Manifest
index 369e682510ba..5126439e3d03 100644
--- a/net-www/mod_ssl/Manifest
+++ b/net-www/mod_ssl/Manifest
@@ -1,5 +1,7 @@
MD5 df76c29ac69b12f59e76cbbad58f4351 ChangeLog 3429
MD5 d2da0e45d7e39184d1cb7abbe3879086 metadata.xml 159
+MD5 d9660a5d5e0e7004669341c99a92e91a mod_ssl-2.8.16.ebuild 2178
MD5 e6af8d7f57cd15375439824dd6eecbf8 files/ssl.default-vhost.conf 6974
MD5 e451c018a8da27b6842d9224364962a1 files/mod_ssl.conf 2449
MD5 7cdc6f06443dc935bf836249bc085ecd files/gentestcrt.sh 8799
+MD5 2d40e1b1ed8c3b290e75eda14bcd0948 files/digest-mod_ssl-2.8.16 73
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.16 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.16
new file mode 100644
index 000000000000..f3e983b37cf4
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.16
@@ -0,0 +1 @@
+MD5 4f6c580ffa07d33e8584406132b98e86 mod_ssl-2.8.16-1.3.29.tar.gz 754325
diff --git a/net-www/mod_ssl/mod_ssl-2.8.16.ebuild b/net-www/mod_ssl/mod_ssl-2.8.16.ebuild
new file mode 100644
index 000000000000..767f2c54e271
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.16.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.16.ebuild,v 1.5 2004/04/14 02:13:30 zul Exp $
+
+MY_P=${P}-1.3.29
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An SSL module for the Apache Web server"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.modssl.org/"
+
+KEYWORDS="x86 ppc sparc alpha hppa"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="=net-www/apache-1.3.29*
+ >=dev-libs/openssl-0.9.6k"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ dodir /usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}