summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-10-23 21:18:09 +0000
committerStuart Herbert <stuart@gentoo.org>2004-10-23 21:18:09 +0000
commit71042b17a15719ed33f76c73bb9a12d6a6a82116 (patch)
tree50f9ef114fe5b6597be206d3e011ccb35d902dc7 /net-www/mod_ssl
parentVersion bump (diff)
downloadhistorical-71042b17a15719ed33f76c73bb9a12d6a6a82116.tar.gz
historical-71042b17a15719ed33f76c73bb9a12d6a6a82116.tar.bz2
historical-71042b17a15719ed33f76c73bb9a12d6a6a82116.zip
Version bump to match apache-1.3.32
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.211
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.21.ebuild80
3 files changed, 87 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index a0b8ab8d1f4a..b5388b528cb0 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.51 2004/10/21 01:48:40 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.52 2004/10/23 21:18:09 stuart Exp $
+
+*mod_ssl-2.8.21 (23 Oct 2004)
+
+ 23 Oct 2004; Stuart Herbert <stuart@gentoo.org> +mod_ssl-2.8.21.ebuild:
+ Version bump to match apache-1.3.32
*mod_ssl-2.8.20 (21 Oct 2004)
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.21 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.21
new file mode 100644
index 000000000000..0b0cd49d2dd9
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.21
@@ -0,0 +1 @@
+MD5 19994ade6f8c46aa6cac87bca797fe82 mod_ssl-2.8.21-1.3.32.tar.gz 754629
diff --git a/net-www/mod_ssl/mod_ssl-2.8.21.ebuild b/net-www/mod_ssl/mod_ssl-2.8.21.ebuild
new file mode 100644
index 000000000000..7f1e733ad3c8
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.21.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.21.ebuild,v 1.1 2004/10/23 21:18:09 stuart Exp $
+
+MY_P=${P}-1.3.32
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An SSL module for the Apache Web server"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.modssl.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips"
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+
+DEPEND="=net-www/apache-1.3.32*
+ >=dev-libs/openssl-0.9.6k"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ if has_version '=sys-libs/gdbm-1.8.3*' ; then
+ myconf = "--enable-rule=SSL_SDBM"
+ fi
+
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs ${myconf} || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ dodir /usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/net-www/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}