summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-01 10:03:33 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-01 10:03:33 +0000
commitb8b4bd8af13f5aaafc445d4e36c9413051fff78b (patch)
tree5106ab54e0e193cc73a073cd1bbf67c3f6ba3eed /net-www/mod_mp3
parentfixoids (diff)
downloadhistorical-b8b4bd8af13f5aaafc445d4e36c9413051fff78b.tar.gz
historical-b8b4bd8af13f5aaafc445d4e36c9413051fff78b.tar.bz2
historical-b8b4bd8af13f5aaafc445d4e36c9413051fff78b.zip
Version bump
Diffstat (limited to 'net-www/mod_mp3')
-rw-r--r--net-www/mod_mp3/ChangeLog7
-rw-r--r--net-www/mod_mp3/files/digest-mod_mp3-0.391
-rw-r--r--net-www/mod_mp3/mod_mp3-0.39.ebuild58
3 files changed, 65 insertions, 1 deletions
diff --git a/net-www/mod_mp3/ChangeLog b/net-www/mod_mp3/ChangeLog
index 27464cc0f6f2..149d61b76bad 100644
--- a/net-www/mod_mp3/ChangeLog
+++ b/net-www/mod_mp3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_mp3
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.4 2002/08/27 16:15:55 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.5 2002/11/01 10:03:33 aliz Exp $
+
+*mod_mp3-0.39 (01 Nov 2002)
+
+ 01 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
*mod_mp3-0.35-r2 (27 Aug 2002)
diff --git a/net-www/mod_mp3/files/digest-mod_mp3-0.39 b/net-www/mod_mp3/files/digest-mod_mp3-0.39
new file mode 100644
index 000000000000..adeafc4ef265
--- /dev/null
+++ b/net-www/mod_mp3/files/digest-mod_mp3-0.39
@@ -0,0 +1 @@
+MD5 357f0d7b8d3b5f4ec1baf50dafb0bf24 mod_mp3-0.39.tar.gz 55047
diff --git a/net-www/mod_mp3/mod_mp3-0.39.ebuild b/net-www/mod_mp3/mod_mp3-0.39.ebuild
new file mode 100644
index 000000000000..678527c6110c
--- /dev/null
+++ b/net-www/mod_mp3/mod_mp3-0.39.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.39.ebuild,v 1.1 2002/11/01 10:03:33 aliz Exp $
+
+IUSE="mysql postgres"
+
+DESCRIPTION="Module for turning Apache into an MP3 or Ogg streaming server"
+HOMEPAGE="http://media.tangent.org/"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ >=net-www/apache-1.3.24
+ sys-devel/perl
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( dev-db/postgresql )"
+
+LICENSE="as-is"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-postgres"
+ ./configure ${myconf} || die
+ make clean
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe src/mod_mp3.so
+
+ dodoc CONTRIBUTORS MANIFEST TODO ChangeLog LICENSE README VERSION
+ dodoc support/{faq.pod,mp3_with_mysql.conf,mysql_schema,pgsql_schema}
+ dohtml faq.html
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_mp3.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_mp3.so mod_mp3.c mp3_module \
+ define=MP3 addconf=conf/addon-modules/mod_mp3.conf
+ :;
+}