summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-04-22 22:20:49 +0000
committerChuck Short <zul@gentoo.org>2004-04-22 22:20:49 +0000
commitafc1ca554d9c60a3aeb8703e3fa116ce812f98b8 (patch)
tree81a962e98674f1b5ffde6faae3c79fa20be022fb /net-www/mod_mp3/mod_mp3-0.40.ebuild
parentAdded to ~ppc (diff)
downloadhistorical-afc1ca554d9c60a3aeb8703e3fa116ce812f98b8.tar.gz
historical-afc1ca554d9c60a3aeb8703e3fa116ce812f98b8.tar.bz2
historical-afc1ca554d9c60a3aeb8703e3fa116ce812f98b8.zip
Version bump, closes #41674.
Diffstat (limited to 'net-www/mod_mp3/mod_mp3-0.40.ebuild')
-rw-r--r--net-www/mod_mp3/mod_mp3-0.40.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-www/mod_mp3/mod_mp3-0.40.ebuild b/net-www/mod_mp3/mod_mp3-0.40.ebuild
new file mode 100644
index 000000000000..06ed19903813
--- /dev/null
+++ b/net-www/mod_mp3/mod_mp3-0.40.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.40.ebuild,v 1.1 2004/04/22 22:20:49 zul Exp $
+
+IUSE="mysql postgres"
+
+DESCRIPTION="Module for turning Apache into an MP3 or Ogg streaming server"
+HOMEPAGE="http://media.tangent.org/"
+KEYWORDS="~x86 ~sparc"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ =net-www/apache-1*
+ dev-lang/perl
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( dev-db/postgresql )"
+
+LICENSE="as-is"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-postgres"
+ ./configure ${myconf} || die
+ make clean
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe src/mod_mp3.so
+
+ dodoc CONTRIBUTORS MANIFEST TODO ChangeLog LICENSE README VERSION
+ dodoc support/{faq.pod,mp3_with_mysql.conf,mysql_schema,pgsql_schema}
+ dohtml faq.html
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_mp3.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_mp3.so mod_mp3.c mp3_module \
+ define=MP3 addconf=conf/addon-modules/mod_mp3.conf
+ :;
+}