summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-04-10 22:19:00 +0000
committerDean Bailey <alron@gentoo.org>2003-04-10 22:19:00 +0000
commitf32c1e93ac29b14e092e8fe40d2e60b8c02b314e (patch)
treeeccb00f2fd513d65b1bb525bdfd2ebd158963278 /net-www/horde
parentadd pygtk deps (diff)
downloadhistorical-f32c1e93ac29b14e092e8fe40d2e60b8c02b314e.tar.gz
historical-f32c1e93ac29b14e092e8fe40d2e60b8c02b314e.tar.bz2
historical-f32c1e93ac29b14e092e8fe40d2e60b8c02b314e.zip
Fix to 2.2.1 to make VFS work properly.
Diffstat (limited to 'net-www/horde')
-rw-r--r--net-www/horde/ChangeLog9
-rw-r--r--net-www/horde/files/2.2.1/vfs.sql19
-rw-r--r--net-www/horde/files/digest-horde-2.2.1-r21
-rw-r--r--net-www/horde/horde-2.2.1-r2.ebuild70
4 files changed, 97 insertions, 2 deletions
diff --git a/net-www/horde/ChangeLog b/net-www/horde/ChangeLog
index b17a867ec672..cb4de0e38580 100644
--- a/net-www/horde/ChangeLog
+++ b/net-www/horde/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-www/horde
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.7 2003/04/08 21:48:05 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.8 2003/04/10 22:19:00 alron Exp $
+
+*horde-2.2.1-r2 (10 Apr 2003)
+ 10 Apr 2003;Dean Bailey <alron@gentoo.org> horde-2.2.1-r2 :
+ Added vfs.sql, a table needed to use hordes VFS functions. Was missing from the
+ horde 2.2.1 tarball.
*horde-2.2.1-r1 (08 Apr 2003)
- 08 Apr 2003l Dean Bailey <alron@gentoo.org> horde-2.2.1-r1 :
+ 08 Apr 2003; Dean Bailey <alron@gentoo.org> horde-2.2.1-r1 :
Fixed an issue where alot of the required pear files were missing or outdated.
Added dependancy on horde-pear.
diff --git a/net-www/horde/files/2.2.1/vfs.sql b/net-www/horde/files/2.2.1/vfs.sql
new file mode 100644
index 000000000000..f3325863e18d
--- /dev/null
+++ b/net-www/horde/files/2.2.1/vfs.sql
@@ -0,0 +1,19 @@
+-- $Horde: horde/scripts/db/vfs.sql,v 1.3 2002/08/19 20:13:49 chuck Exp $
+
+CREATE TABLE horde_vfs (
+ vfs_id BIGINT NOT NULL,
+ vfs_type SMALLINT NOT NULL,
+ vfs_path VARCHAR(255) NOT NULL,
+ vfs_name VARCHAR(255) NOT NULL,
+ vfs_modified BIGINT NOT NULL,
+ vfs_owner VARCHAR(255) NOT NULL,
+ vfs_data LONGBLOB,
+-- Or, on some DBMS systems:
+-- vfs_data IMAGE,
+ PRIMARY KEY (vfs_id)
+);
+
+CREATE INDEX vfs_path_idx ON horde_vfs (vfs_path);
+CREATE INDEX vfs_name_idx ON horde_vfs (vfs_name);
+
+GRANT SELECT, INSERT, UPDATE, DELETE ON horde_vfs TO horde;
diff --git a/net-www/horde/files/digest-horde-2.2.1-r2 b/net-www/horde/files/digest-horde-2.2.1-r2
new file mode 100644
index 000000000000..d14f36b4d994
--- /dev/null
+++ b/net-www/horde/files/digest-horde-2.2.1-r2
@@ -0,0 +1 @@
+MD5 0a1e087f5017524a6b1b3d62204f49bb horde-2.2.1.tar.gz 537836
diff --git a/net-www/horde/horde-2.2.1-r2.ebuild b/net-www/horde/horde-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..e29e77dac6fb
--- /dev/null
+++ b/net-www/horde/horde-2.2.1-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/horde-2.2.1-r2.ebuild,v 1.1 2003/04/10 22:19:00 alron Exp $
+
+DESCRIPTION="Horde Application Framework ${PV}"
+HOMEPAGE="http://www.horde.org"
+SRC_URI="ftp://ftp.horde.org/pub/horde/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+DEPEND=""
+RDEPEND=">=dev-php/mod_php-4.1.0
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=net-www/horde-pear-1.0.1"
+IUSE=""
+
+# We will use these to set the permissions properly
+HTTPD_USER="apache"
+HTTPD_GROUP=`grep $HTTPD_USER /etc/passwd |cut -d: -f4`
+
+# Allow users to move the default data directory by setting the
+# home directory of the 'apache' user elsewhere.
+HTTPD_ROOT=`grep $HTTPD_USER /etc/passwd | cut -d: -f6`/htdocs
+
+
+
+pkg_setup() {
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eewarn "HTTPD_ROOT is null!"
+ eewarn "You probably want to check /etc/passwd"
+ die "Need to have a place to put horde in"
+ fi
+ if [ -L ${HTTPD_ROOT}/horde ] ; then
+ ewarn "You need to unmerge your old Horde version first."
+ ewarn "Horde will be installed into ${HTTPD_ROOT}/horde"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ dodir ${HTTPD_ROOT}/horde
+ cp -r . ${D}/${HTTPD_ROOT}/horde
+ cp ${FILESDIR}/${PV}/vfs.sql ${D}/${HTTPD_ROOT}/horde/scripts/db
+ # protecting files
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${D}/${HTTPD_ROOT}/horde
+ find ${D}/${HTTPD_ROOT}/horde/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/ -type d -exec chmod 0750 {} \;
+ chmod 0000 ${D}/${HTTPD_ROOT}/horde/test.php
+}
+
+pkg_postinst() {
+ einfo "Horde requires PHP to have :"
+ einfo " ==> 'short_open_tag enabled = On'"
+ einfo " ==> 'magic_quotes_runtime set = Off'"
+ einfo " ==> 'file_uploads enabled = On'"
+ einfo "Please edit /etc/php4/php.ini."
+ einfo ""
+ einfo "Please read ${HTTPD_ROOT}/horde/docs/INSTALL !"
+}
+
+