summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 00:39:55 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 00:39:55 +0000
commit290a3baf3f006f0706b634b56080e506ca57e735 (patch)
tree865ba479761ce8f5bd287643c5c696249c1e29ac /net-www/horde-imp
parentmanifest (diff)
downloadhistorical-290a3baf3f006f0706b634b56080e506ca57e735.tar.gz
historical-290a3baf3f006f0706b634b56080e506ca57e735.tar.bz2
historical-290a3baf3f006f0706b634b56080e506ca57e735.zip
use HORDE_PHP_FEATURES from new eclass
Diffstat (limited to 'net-www/horde-imp')
-rw-r--r--net-www/horde-imp/files/digest-horde-imp-3.2.21
-rw-r--r--net-www/horde-imp/horde-imp-3.2.2.ebuild24
-rw-r--r--net-www/horde-imp/horde-imp-3.2.3.ebuild17
3 files changed, 3 insertions, 39 deletions
diff --git a/net-www/horde-imp/files/digest-horde-imp-3.2.2 b/net-www/horde-imp/files/digest-horde-imp-3.2.2
deleted file mode 100644
index 1aa7a2eca15e..000000000000
--- a/net-www/horde-imp/files/digest-horde-imp-3.2.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 757e4d3b6b1b7137712ed4c4a358e822 imp-3.2.2.tar.gz 1489544
diff --git a/net-www/horde-imp/horde-imp-3.2.2.ebuild b/net-www/horde-imp/horde-imp-3.2.2.ebuild
deleted file mode 100644
index a7d3fccc511c..000000000000
--- a/net-www/horde-imp/horde-imp-3.2.2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2.2.ebuild,v 1.10 2004/01/27 00:57:20 vapier Exp $
-
-inherit horde
-
-DESCRIPTION="Horde IMP provides webmail access to IMAP/POP3 mailboxes"
-
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
-
-DEPEND=""
-RDEPEND=">=net-www/horde-2.2.4"
-
-pkg_setup() {
- # FIXME: Is this really how we want to do this ?
- GREP=`grep imap /var/db/pkg/dev-php/mod_php*/USE`
- if [ "${GREP}" != "" ]; then
- return 0
- else
- eerror "Missing IMAP support in mod_php !"
- die "aborting..."
- fi
- horde_pkg_setup
-}
diff --git a/net-www/horde-imp/horde-imp-3.2.3.ebuild b/net-www/horde-imp/horde-imp-3.2.3.ebuild
index 03a0dadddb84..9de0c28c5036 100644
--- a/net-www/horde-imp/horde-imp-3.2.3.ebuild
+++ b/net-www/horde-imp/horde-imp-3.2.3.ebuild
@@ -1,24 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2.3.ebuild,v 1.3 2004/03/29 01:34:14 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2.3.ebuild,v 1.4 2004/04/06 00:36:58 vapier Exp $
+HORDE_PHP_FEATURES="imap"
inherit horde
DESCRIPTION="Horde IMP provides webmail access to IMAP/POP3 mailboxes"
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa"
+KEYWORDS="x86 ppc sparc alpha hppa"
DEPEND=""
RDEPEND=">=net-www/horde-2.2.5"
-
-pkg_setup() {
- # FIXME: Is this really how we want to do this ?
- GREP=`grep imap /var/db/pkg/dev-php/mod_php*/USE`
- if [ "${GREP}" != "" ]; then
- return 0
- else
- eerror "Missing IMAP support in mod_php !"
- die "aborting..."
- fi
- horde_pkg_setup
-}