summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-02-12 19:58:15 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-02-12 19:58:15 +0000
commit694231a868a90c4ee9d3f77dfc5bf5066b22043a (patch)
tree6e412651c8364d626247b984c2d43921c54126a4 /net-wireless/linux-wlan-ng-modules/files
parentRemoved old version. (diff)
downloadhistorical-694231a868a90c4ee9d3f77dfc5bf5066b22043a.tar.gz
historical-694231a868a90c4ee9d3f77dfc5bf5066b22043a.tar.bz2
historical-694231a868a90c4ee9d3f77dfc5bf5066b22043a.zip
Removed old revisions.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'net-wireless/linux-wlan-ng-modules/files')
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/0.2.2-kernel-2.6.14.patch196
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.21
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.2-r11
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.2-module_param.patch12
4 files changed, 0 insertions, 210 deletions
diff --git a/net-wireless/linux-wlan-ng-modules/files/0.2.2-kernel-2.6.14.patch b/net-wireless/linux-wlan-ng-modules/files/0.2.2-kernel-2.6.14.patch
deleted file mode 100644
index 44a89a50c585..000000000000
--- a/net-wireless/linux-wlan-ng-modules/files/0.2.2-kernel-2.6.14.patch
+++ /dev/null
@@ -1,196 +0,0 @@
-Index: src/version.h.in
-===================================================================
---- src/version.h.in (revision 1748)
-+++ src/version.h.in (revision 1750)
-@@ -50,6 +50,7 @@
- #endif
-
- /* WLAN_HOSTIF (generally set on the command line, not detected) */
-+#define WLAN_NONE 0
- #define WLAN_PCMCIA 1
- #define WLAN_ISA 2
- #define WLAN_PCI 3
-Index: src/include/wlan/wlan_compat.h
-===================================================================
---- src/include/wlan/wlan_compat.h (revision 1748)
-+++ src/include/wlan/wlan_compat.h (revision 1750)
-@@ -568,6 +568,10 @@
- #define in_atomic() 0
- #endif
-
-+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,13))
-+#define URB_ASYNC_UNLINK 0
-+#endif
-+
- #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,7))
- #define URB_ASYNC_UNLINK USB_ASYNC_UNLINK
- #define usb_fill_bulk_urb FILL_BULK_URB
-Index: src/p80211/p80211frm.c
-===================================================================
---- src/p80211/p80211frm.c (revision 1748)
-+++ src/p80211/p80211frm.c (revision 1750)
-@@ -65,6 +65,7 @@
- #include <linux/string.h>
- #include <asm/byteorder.h>
-
-+#include <wlan/version.h>
- #include <wlan/wlan_compat.h>
-
- /*================================================================*/
-Index: src/p80211/p80211conv.c
-===================================================================
---- src/p80211/p80211conv.c (revision 1748)
-+++ src/p80211/p80211conv.c (revision 1750)
-@@ -70,13 +70,12 @@
-
- #include <asm/byteorder.h>
-
-+#include <wlan/version.h>
- #include <wlan/wlan_compat.h>
-
--
- /*================================================================*/
- /* Project Includes */
-
--#include <wlan/version.h>
- #include <wlan/p80211types.h>
- #include <wlan/p80211hdr.h>
- #include <wlan/p80211conv.h>
-Index: src/p80211/p80211req.c
-===================================================================
---- src/p80211/p80211req.c (revision 1748)
-+++ src/p80211/p80211req.c (revision 1750)
-@@ -53,8 +53,6 @@
- /*================================================================*/
- /* System Includes */
-
--#define __NO_VERSION__ /* prevent the static definition */
--
- #include <linux/config.h>
- #include <linux/version.h>
-
-@@ -70,12 +68,12 @@
- #include <net/sock.h>
- #include <linux/netlink.h>
-
-+#include <wlan/version.h>
- #include <wlan/wlan_compat.h>
-
- /*================================================================*/
- /* Project Includes */
-
--#include <wlan/version.h>
- #include <wlan/p80211types.h>
- #include <wlan/p80211hdr.h>
- #include <wlan/p80211mgmt.h>
-@@ -351,8 +349,13 @@
- void p80211indicate_init(void)
- {
- DBFENTER;
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14))
-+ netlink_kernel_create( P80211_NL_SOCK_IND, &p80211ind_rx);
-+#else
- nl_indicate =
-- netlink_kernel_create( P80211_NL_SOCK_IND, &p80211ind_rx);
-+ netlink_kernel_create( P80211_NL_SOCK_IND, P80211_NL_MCAST_GRP_MLME, &p80211ind_rx, THIS_MODULE);
-+
-+#endif
- if ( nl_indicate == NULL ) {
- WLAN_LOG_DEBUG(2,"Failed to create indicate netlink i/f.\n");
- }
-Index: src/p80211/p80211wep.c
-===================================================================
---- src/p80211/p80211wep.c (revision 1748)
-+++ src/p80211/p80211wep.c (revision 1750)
-@@ -56,6 +56,7 @@
- #include <linux/slab.h>
- #include <linux/random.h>
-
-+#include <wlan/version.h>
- #include <wlan/wlan_compat.h>
-
- // #define WEP_DEBUG
-Index: src/p80211/p80211mod.c
-===================================================================
---- src/p80211/p80211mod.c (revision 1748)
-+++ src/p80211/p80211mod.c (revision 1750)
-@@ -70,12 +70,12 @@
- #include <linux/wireless.h>
- #include <linux/netdevice.h>
-
-+#include <wlan/version.h>
- #include <wlan/wlan_compat.h>
-
- /*================================================================*/
- /* Project Includes */
-
--#include <wlan/version.h>
- #include <wlan/p80211types.h>
- #include <wlan/p80211hdr.h>
- #include <wlan/p80211mgmt.h>
-Index: src/p80211/Makefile
-===================================================================
---- src/p80211/Makefile (revision 1748)
-+++ src/p80211/Makefile (revision 1750)
-@@ -50,7 +50,7 @@
-
- ifneq ($(KERNELRELEASE),)
-
--EXTRA_CFLAGS += -I$(WLAN_SRC)/include $(WLAN_INCLUDE_DEBUG)
-+EXTRA_CFLAGS += -I$(WLAN_SRC)/include $(WLAN_INCLUDE_DEBUG) -DWLAN_HOSTIF=WLAN_NONE
-
- ifeq ($(KERN_25), y)
-
-Index: src/prism2/driver/hfa384x_usb.c
-===================================================================
---- src/prism2/driver/hfa384x_usb.c (revision 1748)
-+++ src/prism2/driver/hfa384x_usb.c (revision 1750)
-@@ -2108,7 +2108,7 @@
- ctlx->outbuf.rmemreq.offset,
- ctlx->outbuf.rmemreq.page);
-
-- WLAN_LOG_DEBUG(4,"pktsize=%d\n",
-+ WLAN_LOG_DEBUG(4,"pktsize=%ld\n",
- ROUNDUP64(sizeof(ctlx->outbuf.rmemreq)));
-
- ctlx->reapable = mode;
-@@ -3131,7 +3131,7 @@
-
- if (result) {
- WLAN_LOG_WARNING(
-- "Read from index %d failed, continuing\n",
-+ "Read from index %ld failed, continuing\n",
- i );
- continue;
- }
-@@ -4320,7 +4320,7 @@
- if ( skblen >
- (sizeof(p80211msg_lnxind_wlansniffrm_t) +
- WLAN_HDR_A4_LEN + WLAN_DATA_MAXLEN + WLAN_CRC_LEN) ) {
-- WLAN_LOG_DEBUG(1, "overlen frm: len=%d\n",
-+ WLAN_LOG_DEBUG(1, "overlen frm: len=%ld\n",
- skblen - sizeof(p80211msg_lnxind_wlansniffrm_t));
- }
-
-Index: src/prism2/driver/prism2_cs.c
-===================================================================
---- src/prism2/driver/prism2_cs.c (revision 1748)
-+++ src/prism2/driver/prism2_cs.c (revision 1750)
-@@ -61,7 +61,7 @@
- ----------------------------------------------------------------*/
- static void cs_error(client_handle_t handle, int func, int ret)
- {
--#if CS_RELEASE_CODE < 0x2911
-+#if (defined(CS_RELEASE_CODE) && (CS_RELEASE_CODE < 0x2911))
- CardServices(ReportError, dev_info, (void *)func, (void *)ret);
- #else
- error_info_t err = { func, ret };
-@@ -208,7 +208,7 @@
- #endif
- link->conf.IntType = INT_MEMORY_AND_IO;
- link->priv = wlandev;
--#if CS_RELEASE_CODE > 0x2911
-+#if (defined(CS_RELEASE_CODE) && (CS_RELEASE_CODE < 0x2911))
- link->irq.Instance = wlandev;
- #endif
-
diff --git a/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.2 b/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.2
deleted file mode 100644
index 5d45e8b8245e..000000000000
--- a/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 54b11244fa50a85b31f21c64a8f259b7 linux-wlan-ng-0.2.2.tar.bz2 458937
diff --git a/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.2-r1 b/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.2-r1
deleted file mode 100644
index 5d45e8b8245e..000000000000
--- a/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.2-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 54b11244fa50a85b31f21c64a8f259b7 linux-wlan-ng-0.2.2.tar.bz2 458937
diff --git a/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.2-module_param.patch b/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.2-module_param.patch
deleted file mode 100644
index cf614c810e7c..000000000000
--- a/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.2-module_param.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urp linux-wlan-ng-0.2.1/src/prism2/driver/prism2_cs.c linux-wlan-ng-0.2.1-module_param/src/prism2/driver/prism2_cs.c
---- linux-wlan-ng-0.2.1/src/prism2/driver/prism2_cs.c 2005-07-20 19:16:55.000000000 +0200
-+++ linux-wlan-ng-0.2.1-module_param/src/prism2/driver/prism2_cs.c 2005-08-24 21:41:34.000000000 +0200
-@@ -21,7 +21,7 @@ static u_int prism2_ignorevcc=0; /* Boo
- * is set to and what the CIS
- * says.
- */
--#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,11) )
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,11)) && (LINUX_VERSION_CODE > KERNEL_VERSION(2,5,0))
- #if (LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,5))
- static int numlist = 4;
- module_param_array(irq_list, int, numlist, 0444);