summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-09-08 08:40:10 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-09-08 08:40:10 +0000
commit88adfdf7a01a6d9798555f9c9840e2a40c771ab9 (patch)
tree9ff146d75f7cccbfc946b9576255a66451f120d0 /net-print/pnm2ppa
parentmark db-4.0 as stable on x86, and put it into testing on all other arches (diff)
downloadhistorical-88adfdf7a01a6d9798555f9c9840e2a40c771ab9.tar.gz
historical-88adfdf7a01a6d9798555f9c9840e2a40c771ab9.tar.bz2
historical-88adfdf7a01a6d9798555f9c9840e2a40c771ab9.zip
repoman fixes
Diffstat (limited to 'net-print/pnm2ppa')
-rw-r--r--net-print/pnm2ppa/Manifest8
-rw-r--r--net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild83
-rw-r--r--net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild14
-rw-r--r--net-print/pnm2ppa/pnm2ppa-1.12.ebuild14
4 files changed, 59 insertions, 60 deletions
diff --git a/net-print/pnm2ppa/Manifest b/net-print/pnm2ppa/Manifest
index e7bf997c666c..02d98dde8acc 100644
--- a/net-print/pnm2ppa/Manifest
+++ b/net-print/pnm2ppa/Manifest
@@ -1,8 +1,8 @@
-MD5 4bb3b59ae16c51c54ef86338a76c5721 ChangeLog 2661
-MD5 9953a7d3e513fe45610847b6e1a1ee2e pnm2ppa-1.0.91-r3.ebuild 5099
-MD5 9d5b04eff20eeeea01cc8d2af387a601 pnm2ppa-1.11.2.ebuild 2945
-MD5 a0ef1a6c2eaf8dc2a995a36c1f25cd0d pnm2ppa-1.12.ebuild 2915
+MD5 a0819292089b6d6717d69e490169263e ChangeLog 2662
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
+MD5 78939d4dd4eee34cbdaa692ba2765f51 pnm2ppa-1.0.91-r3.ebuild 5012
+MD5 7c417539d85c5b44d85ec70d5ef36e70 pnm2ppa-1.11.2.ebuild 2926
+MD5 6f95350c7f2d923c643c77abe5883250 pnm2ppa-1.12.ebuild 2896
MD5 1ca58b2f4948498a7edf92208be8f721 files/digest-pnm2ppa-1.0.91-r3 116
MD5 59bee745e2c3c4448a94e43af5b5cd58 files/digest-pnm2ppa-1.11.2 121
MD5 0a1deb7cd4d00d5222a2e71b4306dcde files/digest-pnm2ppa-1.12 117
diff --git a/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild b/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild
index 11537f2ac499..9fd9cbea416a 100644
--- a/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild
+++ b/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild,v 1.9 2003/09/07 00:18:10 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild,v 1.10 2003/09/08 08:40:06 lanius Exp $
# Note: this also d/ls the hp-ppa-howto and installs it under /usr/share/doc/${P}
IUSE="ncurses gtk"
@@ -40,55 +40,54 @@ RDEPEND="${DEPEND}
src_unpack() {
- cd ${WORKDIR}
- unpack ${P}.tgz
- cd ${S}
- unpack howto.tgz
+ cd ${WORKDIR}
+ unpack ${P}.tgz
+ cd ${S}
+ unpack howto.tgz
cd ${WORKDIR}
patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
-
}
src_compile() {
export CFLAGS="-DNDEBUG ${CFLAGS}"
- emake \
+ emake \
CFLAGS="${CFLAGS} -DLANG_EN" || die
- cd ${S}/ppa_protocol
- emake \
+ cd ${S}/ppa_protocol
+ emake \
CFLAGS="${CFLAGS}" || die
- cd ${S}/ppaSet-beta1
- # This requires gtk, ncurses etc. on which we don't want to depend
- # so we simply fail if they aren't installed
- echo "The following may fail, don't pay attention to any error"
- sleep 1s
-
- use gtk && \
- make \
- BASEDIR=/usr/share/pnm2ppa/ppaSet \
- BINDIR=/usr/bin \
- PNM2PPA=/usr/bin/pnm2ppa \
- CALIBRATE_PPA=/usr/bin/calibrate_ppa \
+ cd ${S}/ppaSet-beta1
+ # This requires gtk, ncurses etc. on which we don't want to depend
+ # so we simply fail if they aren't installed
+ echo "The following may fail, don't pay attention to any error"
+ sleep 1s
+
+ use gtk && \
+ make \
+ BASEDIR=/usr/share/pnm2ppa/ppaSet \
+ BINDIR=/usr/bin \
+ PNM2PPA=/usr/bin/pnm2ppa \
+ CALIBRATE_PPA=/usr/bin/calibrate_ppa \
CFLAGS="${CFLAGS}" gPpaSet
use ncurses && \
- make \
- BASEDIR=/usr/share/pnm2ppa/ppaSet \
+ make \
+ BASEDIR=/usr/share/pnm2ppa/ppaSet \
BINDIR=/usr/bin \
- PNM2PPA=/usr/bin/pnm2ppa \
- CALIBRATE_PPA=/usr/bin/calibrate_ppa \
+ PNM2PPA=/usr/bin/pnm2ppa \
+ CALIBRATE_PPA=/usr/bin/calibrate_ppa \
CFLAGS="${CFLAGS}" nPpaSet
- make \
- BASEDIR=/usr/share/pnm2ppa/ppaSet \
+ make \
+ BASEDIR=/usr/share/pnm2ppa/ppaSet \
BINDIR=/usr/bin \
- PNM2PPA=/usr/bin/pnm2ppa \
- CALIBRATE_PPA=/usr/bin/calibrate_ppa \
+ PNM2PPA=/usr/bin/pnm2ppa \
+ CALIBRATE_PPA=/usr/bin/calibrate_ppa \
CFLAGS="${CFLAGS}"
}
@@ -132,7 +131,7 @@ src_install () {
exeinto /etc/pdq/interfaces
doexe dummy
- cd ${S}/ppaSet-beta1
+ cd ${S}/ppaSet-beta1
use gtk && \
yes "" | make \
BASEDIR=${D}/usr/ppaSet \
@@ -180,21 +179,21 @@ src_install () {
pkg_postinst() {
- einfo "
- Now, you *must* edit /etc/pnm2ppa.conf and choose (at least)
- your printer model and papersize.
+ einfo "
+ Now, you *must* edit /etc/pnm2ppa.conf and choose (at least)
+ your printer model and papersize.
- Run calibrate_ppa to calibrate color offsets.
+ Run calibrate_ppa to calibrate color offsets.
- Read the docs in /usr/share/pnm2ppa/ to configure the printer,
- configure lpr substitutes, cups, pdq, networking etc.
+ Read the docs in /usr/share/pnm2ppa/ to configure the printer,
+ configure lpr substitutes, cups, pdq, networking etc.
- Note that lpr and pdq drivers *have* been installed, but if your
- config file management has /etc blocked (the default), they have
- been installed under different filenames. Read the appropriate
- Gentoo documentation for more info.
+ Note that lpr and pdq drivers *have* been installed, but if your
+ config file management has /etc blocked (the default), they have
+ been installed under different filenames. Read the appropriate
+ Gentoo documentation for more info.
- Note: lpr has been configured for default papersize letter
- "
+ Note: lpr has been configured for default papersize letter
+ "
}
diff --git a/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild b/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild
index a67b98681edd..c2f3a95caffd 100644
--- a/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild
+++ b/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild,v 1.5 2003/09/08 07:07:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild,v 1.6 2003/09/08 08:40:06 lanius Exp $
# Note: this also d/ls the hp-ppa-howto and installs it under /usr/share/doc/${P}
@@ -27,11 +27,11 @@ RDEPEND="${DEPEND}
dev-util/dialog"
src_unpack() {
- unpack ${MY_P}.tar.gz
- cd ${S}
- unpack howto.tgz
+ unpack ${MY_P}.tar.gz
+ cd ${S}
+ unpack howto.tgz
- patch -l -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ patch -l -p0 < ${FILESDIR}/${PF}-gentoo.diff
}
src_compile() {
@@ -101,9 +101,9 @@ pkg_postinst() {
einfo ""
einfo "Run calibrate_ppa to calibrate color offsets."
einfo ""
- einfo "Read the docs in /usr/share/pnm2ppa/ to configure the printer,"
+ einfo "Read the docs in /usr/share/pnm2ppa/ to configure the printer,"
einfo "configure lpr substitutes, cups, pdq, networking etc."
- einfo ""
+ einfo ""
einfo "Note that lpr and pdq drivers *have* been installed, but if your"
einfo "config file management has /etc blocked (the default), they have"
einfo "been installed under different filenames. Read the appropriate"
diff --git a/net-print/pnm2ppa/pnm2ppa-1.12.ebuild b/net-print/pnm2ppa/pnm2ppa-1.12.ebuild
index b0ccf1ff246b..588d028f3aee 100644
--- a/net-print/pnm2ppa/pnm2ppa-1.12.ebuild
+++ b/net-print/pnm2ppa/pnm2ppa-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.12.ebuild,v 1.5 2003/09/08 07:07:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.12.ebuild,v 1.6 2003/09/08 08:40:06 lanius Exp $
# Note: this also d/ls the hp-ppa-howto and installs it under /usr/share/doc/${P}
@@ -25,11 +25,11 @@ RDEPEND="${DEPEND}
dev-util/dialog"
src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- unpack howto.tgz
+ unpack ${P}.tar.gz
+ cd ${S}
+ unpack howto.tgz
- patch -l -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ patch -l -p0 < ${FILESDIR}/${PF}-gentoo.diff
}
src_compile() {
@@ -99,9 +99,9 @@ pkg_postinst() {
einfo ""
einfo "Run calibrate_ppa to calibrate color offsets."
einfo ""
- einfo "Read the docs in /usr/share/pnm2ppa/ to configure the printer,"
+ einfo "Read the docs in /usr/share/pnm2ppa/ to configure the printer,"
einfo "configure lpr substitutes, cups, pdq, networking etc."
- einfo ""
+ einfo ""
einfo "Note that lpr and pdq drivers *have* been installed, but if your"
einfo "config file management has /etc blocked (the default), they have"
einfo "been installed under different filenames. Read the appropriate"